summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-03-18 20:06:07 +0000
committerChris White <chriswhite@gentoo.org>2005-03-18 20:06:07 +0000
commitb769e2371879d44bab6c4fea92c8583b06357da1 (patch)
tree84c9eae9f22f43c1af4fa9f7b9581655820d40db /media-video/cinepaint
parentnew ebuild which does not depend on glib, has optional tcpwrappers support. (diff)
downloadhistorical-b769e2371879d44bab6c4fea92c8583b06357da1.tar.gz
historical-b769e2371879d44bab6c4fea92c8583b06357da1.tar.bz2
historical-b769e2371879d44bab6c4fea92c8583b06357da1.zip
Bump to version 0.19. gcc3.4 patch no longer needed. Added a patch to fix lcms header locations.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'media-video/cinepaint')
-rw-r--r--media-video/cinepaint/ChangeLog9
-rw-r--r--media-video/cinepaint/Manifest17
-rw-r--r--media-video/cinepaint/cinepaint-0.19.0.ebuild42
-rw-r--r--media-video/cinepaint/files/cinepaint-lcms.patch92
-rw-r--r--media-video/cinepaint/files/digest-cinepaint-0.19.01
5 files changed, 153 insertions, 8 deletions
diff --git a/media-video/cinepaint/ChangeLog b/media-video/cinepaint/ChangeLog
index 433a5097d350..5c6712d5409b 100644
--- a/media-video/cinepaint/ChangeLog
+++ b/media-video/cinepaint/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/cinepaint
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/ChangeLog,v 1.5 2005/03/13 20:34:59 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/ChangeLog,v 1.6 2005/03/18 20:06:07 chriswhite Exp $
+
+*cinepaint-0.19.0 (19 Mar 2005)
+
+ 19 Mar 2005; Chris White <chriswhite@gentoo.org>
+ +files/cinepaint-lcms.patch, +cinepaint-0.19.0.ebuild:
+ Bump to version 0.19. gcc3.4 patch no longer needed. Added a patch to fix
+ lcms header locations.
13 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org>
+files/cinepaint-0.18.3-gcc34.patch, cinepaint-0.18.3.ebuild:
diff --git a/media-video/cinepaint/Manifest b/media-video/cinepaint/Manifest
index a1234a56da29..c5f989a0afb4 100644
--- a/media-video/cinepaint/Manifest
+++ b/media-video/cinepaint/Manifest
@@ -1,17 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 1ee52edbe3665f912c2735fc43aa7448 cinepaint-0.18.ebuild 735
+MD5 e9da414b792b8012a765af95d5354c91 ChangeLog 1320
MD5 0e37bb9998012e8213845f1848f92d7f cinepaint-0.18.3.ebuild 985
-MD5 8e838cbf47dd689052b484d0d9dba67b ChangeLog 1076
+MD5 1ee52edbe3665f912c2735fc43aa7448 cinepaint-0.18.ebuild 735
MD5 31018765c8c65a239dba78a98c405543 metadata.xml 224
-MD5 732e3bb45a2f1945a5c3217a87c53a50 files/cinepaint-0.18.3-gcc34.patch 1476
+MD5 71b8b05f57ca044d8b9a370be61b27a4 cinepaint-0.19.0.ebuild 1116
MD5 18b54df1c9a511a226297daf13dccaec files/digest-cinepaint-0.18 67
MD5 0f99a4352d9c27f40fe6b07cea9d759d files/digest-cinepaint-0.18.3 69
+MD5 732e3bb45a2f1945a5c3217a87c53a50 files/cinepaint-0.18.3-gcc34.patch 1476
+MD5 b599a2e8ee54c88ac8fd777a115ee471 files/digest-cinepaint-0.19.0 69
+MD5 856e66a70aa9fce7961a6ec541b56300 files/cinepaint-lcms.patch 3192
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
+Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFCNKP506ebR+OMO78RAkuJAJ92jXwrv1reuBK2Bc/qTgcZx42G5ACfZ+Ee
-EIDQdkRWqMYw3+VYC4useoo=
-=UNdv
+iD8DBQFCOzAGFdQwWVoAgN4RAtSYAJ9DtS/EKD2Ij/jWnmHnL5W5lN70VACgvm25
+1hCsCNkb19/IQ0yYJ9h8pz0=
+=JLRw
-----END PGP SIGNATURE-----
diff --git a/media-video/cinepaint/cinepaint-0.19.0.ebuild b/media-video/cinepaint/cinepaint-0.19.0.ebuild
new file mode 100644
index 000000000000..c0ebff45150d
--- /dev/null
+++ b/media-video/cinepaint/cinepaint-0.19.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/cinepaint-0.19.0.ebuild,v 1.1 2005/03/18 20:06:07 chriswhite Exp $
+
+inherit eutils versionator
+
+MY_PV=$(replace_version_separator 2 '-')
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="motion picture editing tool used for painting and retouching of movies"
+SRC_URI="mirror://sourceforge/cinepaint/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://cinepaint.sourceforge.net/"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+LICENSE="GPL-2"
+IUSE="png zlib"
+
+DEPEND="=x11-libs/gtk+-1*
+ png? ( >=media-libs/libpng-1.2 )
+ zlib? ( sys-libs/zlib )
+ media-libs/openexr
+ media-libs/tiff
+ media-libs/jpeg"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # lcms is <lcms/lcms.h> not <lcms.h>
+ # fix that in configure detection
+ # and in source
+ epatch ${FILESDIR}/${PN}-lcms.patch
+}
+
+src_compile(){
+ econf --with-openexr-prefix=/usr || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install(){
+ einstall DESTDIR=${D} || die "einstall failed"
+ dodoc AUTHORS ChangeLog COPYING* README* NEWS
+}
diff --git a/media-video/cinepaint/files/cinepaint-lcms.patch b/media-video/cinepaint/files/cinepaint-lcms.patch
new file mode 100644
index 000000000000..bb3ee314b755
--- /dev/null
+++ b/media-video/cinepaint/files/cinepaint-lcms.patch
@@ -0,0 +1,92 @@
+diff -ur cinepaint-0.19-0_old/app/cms.h cinepaint-0.19-0/app/cms.h
+--- cinepaint-0.19-0_old/app/cms.h 2004-11-23 20:58:15.000000000 +0900
++++ cinepaint-0.19-0/app/cms.h 2005-03-19 03:48:07.864524744 +0900
+@@ -20,7 +20,7 @@
+ #ifndef __CMS_H__
+ #define __CMS_H__
+
+-#include <lcms.h>
++#include <lcms/lcms.h>
+ #include <gtk/gtk.h>
+
+ #include "canvas.h"
+diff -ur cinepaint-0.19-0_old/app/depth/commands.c cinepaint-0.19-0/app/depth/commands.c
+--- cinepaint-0.19-0_old/app/depth/commands.c 2004-12-04 05:25:34.000000000 +0900
++++ cinepaint-0.19-0/app/depth/commands.c 2005-03-19 03:48:40.364583984 +0900
+@@ -16,7 +16,7 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
+-#include <lcms.h>
++#include <lcms/lcms.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+diff -ur cinepaint-0.19-0_old/app/look_profile.c cinepaint-0.19-0/app/look_profile.c
+--- cinepaint-0.19-0_old/app/look_profile.c 2004-11-23 20:58:14.000000000 +0900
++++ cinepaint-0.19-0/app/look_profile.c 2005-03-19 03:48:23.599132720 +0900
+@@ -1,5 +1,5 @@
+ #include <gtk/gtk.h>
+-#include <lcms.h>
++#include <lcms/lcms.h>
+
+ #include "../lib/version.h"
+ #include "actionarea.h"
+cinepaint-0.19-0だけに発見: cinepaint-configure.patch
+diff -ur cinepaint-0.19-0_old/configure cinepaint-0.19-0/configure
+--- cinepaint-0.19-0_old/configure 2005-01-02 03:40:51.000000000 +0900
++++ cinepaint-0.19-0/configure 2005-03-19 03:44:25.962259016 +0900
+@@ -21898,7 +21898,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
+-#include <lcms.h>
++#include <lcms/lcms.h>
+ _ACEOF
+ rm -f conftest.$ac_objext
+ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+@@ -21941,7 +21941,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <lcms.h>
++#include <lcms/lcms.h>
+ _ACEOF
+ if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
+ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
+cinepaint-0.19-0だけに発見: libtool
+diff -ur cinepaint-0.19-0_old/plug-ins/tiff/info.c cinepaint-0.19-0/plug-ins/tiff/info.c
+--- cinepaint-0.19-0_old/plug-ins/tiff/info.c 2004-12-31 20:58:29.000000000 +0900
++++ cinepaint-0.19-0/plug-ins/tiff/info.c 2005-03-19 03:49:23.415039320 +0900
+@@ -37,7 +37,7 @@
+ #include "tiff_plug_in.h"
+ #include "info.h"
+
+-#include <lcms.h>
++#include <lcms/lcms.h>
+
+ #ifndef DEBUG
+ /*#define DEBUG*/
+diff -ur cinepaint-0.19-0_old/plug-ins/tiff/tiff_plug_in.h cinepaint-0.19-0/plug-ins/tiff/tiff_plug_in.h
+--- cinepaint-0.19-0_old/plug-ins/tiff/tiff_plug_in.h 2004-11-23 21:17:14.000000000 +0900
++++ cinepaint-0.19-0/plug-ins/tiff/tiff_plug_in.h 2005-03-19 03:49:37.939831216 +0900
+@@ -79,7 +79,7 @@
+ #include <gtk/gtk.h>
+ #endif
+ #endif
+-#include <lcms.h>
++#include <lcms/lcms.h>
+ #if GIMP_MAJOR_VERSION == 0 && GIMP_MINOR_VERSION == 15
+ #include "libgimp/gimpcms.h"
+ #endif
+--- cinepaint-0.19-0_old/plug-ins/jpeg/jpeg.c 2005-03-19 04:01:43.243568288 +0900
++++ cinepaint-0.19-0/plug-ins/jpeg/jpeg.c 2005-03-19 04:02:19.068122128 +0900
+@@ -33,7 +33,7 @@
+ #include "lib/plugin_main.h"
+
+ #include <stdio.h>
+-#include "lcms.h"
++#include <lcms/lcms.h>
+ #include "iccjpeg.h"
+
+
diff --git a/media-video/cinepaint/files/digest-cinepaint-0.19.0 b/media-video/cinepaint/files/digest-cinepaint-0.19.0
new file mode 100644
index 000000000000..33328d45861c
--- /dev/null
+++ b/media-video/cinepaint/files/digest-cinepaint-0.19.0
@@ -0,0 +1 @@
+MD5 2ea2019c8ca3cfce9defc2ca3aae2a39 cinepaint-0.19-0.tar.gz 7218293