summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-20 05:19:36 +0000
committerMax Kalika <max@gentoo.org>2003-08-20 05:19:36 +0000
commita82d69e17003fc8628ee1b28fb506e223880440c (patch)
tree5beb3cd30f27f99c2c44eab5b8176b017ff7cb66 /media-tv
parentppc support (diff)
downloadhistorical-a82d69e17003fc8628ee1b28fb506e223880440c.tar.gz
historical-a82d69e17003fc8628ee1b28fb506e223880440c.tar.bz2
historical-a82d69e17003fc8628ee1b28fb506e223880440c.zip
Fix bug #26515.
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/xmltv/ChangeLog9
-rw-r--r--media-tv/xmltv/Manifest7
-rw-r--r--media-tv/xmltv/files/digest-xmltv-0.5.14-r1 (renamed from media-tv/xmltv/files/digest-xmltv-0.5.14)0
-rw-r--r--media-tv/xmltv/files/xmltv-0.5.14-code_500.patch53
-rw-r--r--media-tv/xmltv/xmltv-0.5.14-r1.ebuild (renamed from media-tv/xmltv/xmltv-0.5.14.ebuild)28
5 files changed, 70 insertions, 27 deletions
diff --git a/media-tv/xmltv/ChangeLog b/media-tv/xmltv/ChangeLog
index 3dd6935b5af4..4860a9ce54d3 100644
--- a/media-tv/xmltv/ChangeLog
+++ b/media-tv/xmltv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/xmltv
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/ChangeLog,v 1.2 2003/08/18 16:00:14 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/ChangeLog,v 1.3 2003/08/20 05:19:35 max Exp $
+
+*xmltv-0.5.14-r1 (19 Aug 2003)
+
+ 19 Aug 2003; Max Kalika <max@gentoo.org> xmltv-0.5.14-r1.ebuild,
+ xmltv-0.5.14.ebuild, files/xmltv-0.5.14-code_500.patch:
+ Add patch to handle 500 error codes returned by zap2it. Thanks to Mark Lopes
+ for the submission. Fixes bug #26515.
*xmltv-0.5.16 (18 Aug 2003)
diff --git a/media-tv/xmltv/Manifest b/media-tv/xmltv/Manifest
index a6da53dfca5d..a51da3080c59 100644
--- a/media-tv/xmltv/Manifest
+++ b/media-tv/xmltv/Manifest
@@ -1,5 +1,6 @@
-MD5 8efe29bb59b43eaf84d13c03ceea7f0d xmltv-0.5.14.ebuild 6046
MD5 1d8dd134abfa7fc0c682a5b8afbacffe xmltv-0.5.16.ebuild 6014
-MD5 8a4ceb4207d7bca72e132d3012de01ee ChangeLog 3302
-MD5 35c0ccab3f399ea2ed58bb3c97bfa8e7 files/digest-xmltv-0.5.14 65
+MD5 3b8359824986b08e491ab2d4c4831062 xmltv-0.5.14-r1.ebuild 6110
+MD5 cd19910f41cdf5f15c90ff83c592975b ChangeLog 3579
MD5 fdac3cb914cbd57d6e7cc4d75a9b32e7 files/digest-xmltv-0.5.16 65
+MD5 35c0ccab3f399ea2ed58bb3c97bfa8e7 files/digest-xmltv-0.5.14-r1 65
+MD5 e515eee3cdb5c503cd44ddba41527013 files/xmltv-0.5.14-code_500.patch 2320
diff --git a/media-tv/xmltv/files/digest-xmltv-0.5.14 b/media-tv/xmltv/files/digest-xmltv-0.5.14-r1
index 55dff50afa60..55dff50afa60 100644
--- a/media-tv/xmltv/files/digest-xmltv-0.5.14
+++ b/media-tv/xmltv/files/digest-xmltv-0.5.14-r1
diff --git a/media-tv/xmltv/files/xmltv-0.5.14-code_500.patch b/media-tv/xmltv/files/xmltv-0.5.14-code_500.patch
new file mode 100644
index 000000000000..dcdbe4ceda62
--- /dev/null
+++ b/media-tv/xmltv/files/xmltv-0.5.14-code_500.patch
@@ -0,0 +1,53 @@
+--- xmltv-0.5.15/grab/na/ZapListings.pm.orig 2003-07-06 12:13:03.000000000 -0700
++++ xmltv-0.5.15/grab/na/ZapListings.pm 2003-08-11 19:47:27.000000000 -0700
+@@ -913,7 +913,7 @@
+ }
+
+ my $res=&doRequest($self->{ua}, $req, $self->{Debug});
+- if ( !$res->is_success || $res->content()=~m/your session has timed out/i ) {
++ if ( !($res->is_success || $res->code eq '500') || $res->content()=~m/your session has timed out/i ) {
+ # again.
+ $res=&doRequest($self->{ua}, $req, $self->{Debug});
+
+@@ -926,7 +926,7 @@
+ }
+ }
+
+- if ( !$res->is_success ) {
++ if ( !($res->is_success || $res->code eq '500') ) {
+ main::errorMessage("zap2it failed to give us a page: ".$res->code().":".
+ HTTP::Status::status_message($res->code())."\n");
+ main::errorMessage("check postal/zip code or www site (maybe they're down)\n");
+@@ -955,7 +955,7 @@
+ $req = $self->Form2Request($self->{GridForm});
+
+ $res=&doRequest($self->{ua}, $req, $self->{Debug});
+- if ( !$res->is_success || $res->content()=~m/your session has timed out/i ) {
++ if ( !($res->is_success || $res->code eq '500') || $res->content()=~m/your session has timed out/i ) {
+ # again.
+ $res=&doRequest($self->{ua}, $req, $self->{Debug});
+
+@@ -968,7 +968,7 @@
+ }
+ }
+
+- if ( !$res->is_success ) {
++ if ( !($res->is_success || $res->code eq '500') ) {
+ main::errorMessage("zap2it failed to give us a page: ".$res->code().":".
+ HTTP::Status::status_message($res->code())."\n");
+ main::errorMessage("check postal/zip code or www site (maybe they're down)\n");
+@@ -2050,12 +2050,12 @@
+ # looks like some requests require two identical calls since
+ # the zap2it server gives us a cookie that works with the second
+ # attempt after the first fails
+- if ( !$res->is_success || $res->content()=~m/your session has timed out/i ) {
++ if ( !($res->is_success || $res->code eq '500') || $res->content()=~m/your session has timed out/i ) {
+ # again.
+ $res=&doRequest($self->{ua}, $req, $self->{Debug});
+ }
+
+- if ( !$res->is_success ) {
++ if ( !($res->is_success || $res->code eq '500') ) {
+ main::errorMessage("zap2it failed to give us a page: ".$res->code().":".
+ HTTP::Status::status_message($res->code())."\n");
+ main::errorMessage("check postal/zip code or www site (maybe they're down)\n");
diff --git a/media-tv/xmltv/xmltv-0.5.14.ebuild b/media-tv/xmltv/xmltv-0.5.14-r1.ebuild
index a2ad11a7dddd..0ddef1e31444 100644
--- a/media-tv/xmltv/xmltv-0.5.14.ebuild
+++ b/media-tv/xmltv/xmltv-0.5.14-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/xmltv-0.5.14.ebuild,v 1.1 2003/07/09 00:08:10 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/xmltv-0.5.14-r1.ebuild,v 1.1 2003/08/20 05:19:35 max Exp $
inherit perl-module
-IUSE=""
DESCRIPTION="Set of utilities to manage TV listings stored in the XMLTV format."
HOMEPAGE="http://membled.com/work/apps/xmltv/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -91,7 +90,6 @@ DEPEND="${DEPEND} dev-perl/HTML-Tree"
# && DEPEND="${DEPEND} dev-perl/perl-tk dev-perl/Tk-TableMatrix dev-perl/XML-Simple"
make_config() {
-
if [ -z "${XMLTV_OPTS}" ] ; then
# No customization needed, build everything (default)
echo "yes"
@@ -103,59 +101,46 @@ make_config() {
# Enable Germany and Austria
[ "`has tv_grab_de ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Brittain
[ "`has tv_grab_uk ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Alternate Brittain
[ "`has tv_grab_uk_rt ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Italy
[ "`has tv_grab_it ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable North America
[ "`has tv_grab_na ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Sweden and Norway
[ "`has tv_grab_sn ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable New Zealand
[ "`has tv_grab_nz ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Finland
[ "`has tv_grab_fi ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Spain
[ "`has tv_grab_es ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Netherlands
[ "`has tv_grab_nl ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Alternate Netherlands
[ "`has tv_grab_nl_wolf ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Hungary
[ "`has tv_grab_hu ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable Denmark
[ "`has tv_grab_nl ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable GUI checking.
[ "`has tv_check ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
-
# Enable CGI support
[ "`has tv_pick_cgi ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+}
+src_unpack() {
+ unpack ${A} && cd "${S}"
+ epatch "${FILESDIR}/xmltv-${PV}-code_500.patch"
}
src_compile() {
-
make_config | perl-module_src_compile
-
}
src_install() {
-
perl-module_src_install
for i in `grep -rl "${D}" "${D}"` ; do
@@ -169,16 +154,13 @@ src_install() {
einfo "to where the ScriptAlias directive is configured."
einfo
fi
-
}
pkg_postinst() {
-
ewarn "If you are upgrading from < 0.5.10 and you need to use the"
ewarn "DE (Germany/Austria), UK or UK_RT (Britain), or IT (Italy)"
ewarn "grabbers, please make sure you have the appropriate value"
ewarn "specified in your XMLTV_OPTS setting because these grabbers"
ewarn "no longer build by default."
echo
-
}