summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-18 11:59:36 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-18 11:59:36 +0000
commit3fabc445fdd81d1082c29d9ad9a74e8fa922a400 (patch)
tree4c7437ba12be1db50bbb24f9f64b19da2ad382b0 /media-tv
parentmoved to media-tv (diff)
downloadhistorical-3fabc445fdd81d1082c29d9ad9a74e8fa922a400.tar.gz
historical-3fabc445fdd81d1082c29d9ad9a74e8fa922a400.tar.bz2
historical-3fabc445fdd81d1082c29d9ad9a74e8fa922a400.zip
moved to media-tv
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/nvtv/Manifest14
-rw-r--r--media-tv/nvtv/files/digest-nvtv-0.4.41
-rw-r--r--media-tv/nvtv/files/nvtv.start21
-rw-r--r--media-tv/nvtv/nvtv-0.4.4.ebuild51
-rw-r--r--media-tv/rivatv/ChangeLog37
-rw-r--r--media-tv/rivatv/Manifest7
6 files changed, 120 insertions, 11 deletions
diff --git a/media-tv/nvtv/Manifest b/media-tv/nvtv/Manifest
index 5dcf8aa75b12..f1431ca9f354 100644
--- a/media-tv/nvtv/Manifest
+++ b/media-tv/nvtv/Manifest
@@ -1,12 +1,4 @@
-MD5 87186ee3a56c1f7c5df3fa9f962d0e42 ChangeLog 1132
-MD5 4950392c319991ca7875976ed748f409 nvtv-0.4.0.ebuild 1072
-MD5 5064d7a953a326e4f300d00c9589317a nvtv-0.4.2-r1.ebuild 1181
-MD5 1d9a6a71a5f86ab59ed8b836d380eaf3 nvtv-0.4.2.ebuild 1062
-MD5 690543ea796b2b60cfd7ecbb2628e33c nvtv-0.4.3.ebuild 1178
-MD5 254d60521f583b1e65ca58f2a805add4 nvtv-0.4.4.ebuild 1179
-MD5 60b5426ddb549a68c6b748753d997972 files/digest-nvtv-0.4.0 62
-MD5 57460ca795faa6a6236e75f78a87e3f3 files/digest-nvtv-0.4.2 62
-MD5 57460ca795faa6a6236e75f78a87e3f3 files/digest-nvtv-0.4.2-r1 62
-MD5 fb73360503403af233ab9db4afb2e23c files/digest-nvtv-0.4.3 62
+MD5 6e7ed6b686a40817f72c64e3462396fc nvtv-0.4.4.ebuild 1174
+MD5 b1e6f7c646455d478c4b1bc46be05e0f ChangeLog 1265
MD5 5f2bf6c79b70ba39b3c942a63dc046e9 files/digest-nvtv-0.4.4 62
-MD5 6bf1bc6c8ac044e309137bc96f9a7064 files/nvtv.start 551
+MD5 9ab4a460e891477b0f575c2fb123c641 files/nvtv.start 549
diff --git a/media-tv/nvtv/files/digest-nvtv-0.4.4 b/media-tv/nvtv/files/digest-nvtv-0.4.4
new file mode 100644
index 000000000000..c955f76a363d
--- /dev/null
+++ b/media-tv/nvtv/files/digest-nvtv-0.4.4
@@ -0,0 +1 @@
+MD5 46188ffd2a30ef152f7e3c6dc4bf678a nvtv-0.4.4.tar.gz 763349
diff --git a/media-tv/nvtv/files/nvtv.start b/media-tv/nvtv/files/nvtv.start
new file mode 100644
index 000000000000..ed52011dd66d
--- /dev/null
+++ b/media-tv/nvtv/files/nvtv.start
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nvtv/files/nvtv.start,v 1.1 2003/06/18 11:59:23 seemant Exp $
+
+depend() {
+ use modules logger
+}
+
+start() {
+ ebegin "Starting NVidia TV-Out Server"
+ start-stop-daemon --start --quiet --exec /usr/sbin/nvtvd \
+ --background 1>&2
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping NVidia TV-Out Server"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/nvtvd 1>&2
+ eend $?
+}
diff --git a/media-tv/nvtv/nvtv-0.4.4.ebuild b/media-tv/nvtv/nvtv-0.4.4.ebuild
new file mode 100644
index 000000000000..8cf27a52a471
--- /dev/null
+++ b/media-tv/nvtv/nvtv-0.4.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nvtv/nvtv-0.4.4.ebuild,v 1.1 2003/06/18 11:59:23 seemant Exp $
+
+IUSE="X gtk gtk2"
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="TV-Out for NVidia cards"
+HOMEPAGE="http://sourceforge.net/projects/nv-tv-out/"
+SRC_URI="mirror://sourceforge/nv-tv-out/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="sys-apps/pciutils
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )
+ X? ( >=x11-base/xfree-4.0 )"
+
+src_compile() {
+ local myconf
+
+ if use gtk2; then
+ myconf="${myconf} --with-gtk=gtk2"
+ elif use gtk; then
+ myconf="${myconf} --with-gtk=gtk1"
+ else
+ myconf="${myconf} --without-gtk";
+ fi
+
+ use X && myconf="${myconf} --with-x" || myconf="${myconf} --without-x"
+
+ econf ${myconf}
+
+ # The CFLAGS don't seem to make it into the Makefile.
+ cd src
+ emake CXFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin src/nvtv
+ dosbin src/nvtvd
+
+ dodoc ANNOUNCE BUGS FAQ INSTALL README \
+ doc/USAGE doc/chips.txt doc/overview.txt \
+ doc/timing.txt xine/tvxine
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nvtv.start nvtv
+}
diff --git a/media-tv/rivatv/ChangeLog b/media-tv/rivatv/ChangeLog
new file mode 100644
index 000000000000..b5beea60914f
--- /dev/null
+++ b/media-tv/rivatv/ChangeLog
@@ -0,0 +1,37 @@
+# ChangeLog for media-tv/rivatv
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/rivatv/ChangeLog,v 1.1 2003/06/18 11:59:36 seemant Exp $
+
+*rivatv-0.8.1 (18 Jun 2003)
+
+ 18 Jun 2003; Seemant Kulleen <seemant@gentoo.org> rivatv-0.8.0-r1.ebuild,
+ rivatv-0.8.1.ebuild, rivatv-0.8.2.ebuild:
+ moved to media-tv
+
+ 12 Jun 2003; <msterret@gentoo.org> rivatv-0.8.0-r1.ebuild,
+ rivatv-0.8.1.ebuild:
+ fix Header
+
+*rivatv-0.8.2 (10 Feb 2003)
+
+ 10 Feb 2003; B.Lauwers <blauwers@gentoo.org> rivatv-0.8.2.ebuild:
+ Version bump from old ebuild to add new driver support and bugfixes
+
+*rivatv-0.8.1 (09 Dec 2002)
+
+ 9 Dec 2002; B.Lauwers <blauwers@gentoo.org> rivatv-0.8.1.ebuild:
+
+ Version bump from old ebuild to add new driver support and bugfixes
+
+*rivatv-0.8.0 (16 Jun 2002)
+
+ 16 June 2002; Doug Goldstein (Cardoe) <dougg@ufl.edu> rivatv-0.8.0-r1.ebuild:
+
+ cleaned up ebuild and fixed it so it'll actually emerge without giving a whole long error msg
+ about how we changed the kernel ebuild names and then need to be emerged --nodeps to get it to work
+
+*rivatv-0.8.0-0 (07/06/2002)
+
+ 7 Jun 2002; B.Lauwers <blauwers@gentoo.org> ChangeLog, rivatv-0.8.0.ebuild :
+
+ Intial ebuild for rivatv from http://drama.obuda.kando.hu/~fero/cgi-bin/rivatv.php
diff --git a/media-tv/rivatv/Manifest b/media-tv/rivatv/Manifest
new file mode 100644
index 000000000000..b69044811923
--- /dev/null
+++ b/media-tv/rivatv/Manifest
@@ -0,0 +1,7 @@
+MD5 4c17d1bc8e012d2cc93079a1d6bdc992 ChangeLog 1161
+MD5 18463df326d65c0301677229e74e2c5e rivatv-0.8.0-r1.ebuild 1215
+MD5 0a8ddfe1ecf92fe957a8dde2c8af24b9 rivatv-0.8.1.ebuild 1213
+MD5 2cd90a369739384dccfcc9691aeee4cc rivatv-0.8.2.ebuild 994
+MD5 94dc3c0091e479d11d285de52267521d files/digest-rivatv-0.8.0-r1 63
+MD5 c70f4f5b9e57a7ab53345aa005ac3733 files/digest-rivatv-0.8.1 64
+MD5 675738a65f00503869783cd7f88ce0b1 files/digest-rivatv-0.8.2 64