summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-10-20 03:01:43 +0000
committerMax Kalika <max@gentoo.org>2003-10-20 03:01:43 +0000
commitabc8a8ba362cde0caac2e4cadb7e0e034ea35874 (patch)
tree8eccc7e1e154135e7e1d7ed339ea4fe5b18c55fa /media-tv/mythtv
parentRevert location of libdvb back to media-libs. (diff)
downloadhistorical-abc8a8ba362cde0caac2e4cadb7e0e034ea35874.tar.gz
historical-abc8a8ba362cde0caac2e4cadb7e0e034ea35874.tar.bz2
historical-abc8a8ba362cde0caac2e4cadb7e0e034ea35874.zip
Bump to version 0.12. Add support for alsa, dvb, lcd, lirc, xvmc. Add Qt mysql support check.
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/ChangeLog8
-rw-r--r--media-tv/mythtv/Manifest4
-rw-r--r--media-tv/mythtv/files/digest-mythtv-0.121
-rw-r--r--media-tv/mythtv/mythtv-0.12.ebuild145
4 files changed, 156 insertions, 2 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index f3262eca87f2..d58418199a05 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.7 2003/09/17 06:20:58 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.8 2003/10/20 02:58:33 max Exp $
+
+*mythtv-0.12 (19 Oct 2003)
+
+ 19 Oct 2003; Max Kalika <max@gentoo.org> mythtv-0.12.ebuild:
+ Bump to version 0.12. Add support for alsa, dvb, lcd, lirc, xvmc. Add Qt
+ mysql support check.
16 Sep 2003; Max Kalika <max@gentoo.org> mythtv-0.10.ebuild,
mythtv-0.11.ebuild:
diff --git a/media-tv/mythtv/Manifest b/media-tv/mythtv/Manifest
index 3c3aab535b85..8ea7a6c06e95 100644
--- a/media-tv/mythtv/Manifest
+++ b/media-tv/mythtv/Manifest
@@ -1,9 +1,11 @@
+MD5 cb8d94100292aae1e8cf80b9e0ada889 mythtv-0.12.ebuild 4421
MD5 ff7a010a65450c2f3c3aa1d78c9e3dbb mythtv-0.11.ebuild 2778
-MD5 7a5ab62a76505f82c8abade1634f53f2 ChangeLog 3278
+MD5 816f0de7930383744dd858db142a1228 ChangeLog 3468
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 152e8592b5f35fa068bfe1c4093e03d2 mythtv-0.10.ebuild 2841
MD5 ce8c4dae21199ea11abd156b16cc3b8a files/mythbackend.conf 867
MD5 897368570b822b7a42c9693e16f1f052 files/mythbackend.rc6 1670
MD5 e14a28e72b9ac693884dc418dbeef119 files/digest-mythtv-0.10 65
MD5 5234ae53ed7b1bb9ed541d47207430f8 files/digest-mythtv-0.11 65
+MD5 8919549e83320ae499758823c2488901 files/digest-mythtv-0.12 65
MD5 b3a4780890d53640604812b8069a8297 files/mythfilldatabase.cron 74
diff --git a/media-tv/mythtv/files/digest-mythtv-0.12 b/media-tv/mythtv/files/digest-mythtv-0.12
new file mode 100644
index 000000000000..8df001fa6b0e
--- /dev/null
+++ b/media-tv/mythtv/files/digest-mythtv-0.12
@@ -0,0 +1 @@
+MD5 a0565cfb291822d49a68484b01af54b6 mythtv-0.12.tar.bz2 3010506
diff --git a/media-tv/mythtv/mythtv-0.12.ebuild b/media-tv/mythtv/mythtv-0.12.ebuild
new file mode 100644
index 000000000000..45542415749d
--- /dev/null
+++ b/media-tv/mythtv/mythtv-0.12.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.12.ebuild,v 1.1 2003/10/20 02:58:34 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Homebrew PVR project."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="alsa dvb lcd lirc nvidia"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3.1
+ >=media-sound/lame-3.93.1
+ >=media-libs/freetype-2.0
+ >=media-tv/xmltv-0.5.16
+ >=sys-apps/sed-4
+ alsa? ( media-libs/alsa-lib )
+ dvb? ( media-libs/libdvb )
+ lcd? ( app-misc/lcdproc )
+ lirc? ( app-misc/lirc )
+ nvidia? ( media-video/nvidia-glx )"
+
+RDEPEND="${DEPEND}
+ !media-tv/mythfrontend"
+
+pkg_setup() {
+ local qt_use="$(</var/db/pkg/`best_version x11-libs/qt`/USE)"
+ if [ ! "`has mysql ${qt_use}`" ] ; then
+ eerror "Qt is missing MySQL support. Please add"
+ eerror "'mysql' to your USE flags, and re-emerge Qt."
+ die "Qt needs mysql support"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:usr/local:usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ if [ "`use alsa`" ] ; then
+ sed -e "s:#CONFIG += using_alsa:CONFIG += using_alsa:" \
+ -e "s:#EXTRA_LIBS += -lasound:EXTRA_LIBS += -lasound:" \
+ -i "settings.pro" || die "enable alsa sed failed"
+ fi
+ if [ "`use dvb`" ] ; then
+ sed -e "s:#CONFIG += using_dvb:CONFIG += using_dvb:" \
+ -e "s:#DEFINES += USING_DVB:DEFINES += USING_DVB:" \
+ -e "s:#INCLUDEPATH += /usr/src:INCLUDEPATH += /usr:" \
+ -i "settings.pro" || die "enable dvb sed failed"
+ fi
+ if [ "`use lcd`" ] ; then
+ sed -e "s:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:" \
+ -i "settings.pro" || die "enable lcd sed failed"
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
+ -e "s:#EXTRA_LIBS += -llirc_client:EXTRA_LIBS += -llirc_client:" \
+ -i "settings.pro" || die "enable lirc sed failed"
+ fi
+ if [ "`use nvidia`" ] ; then
+ sed -e "s:#CONFIG += using_xvmc:CONFIG += using_xvmc:" \
+ -e "s:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:" \
+ -i "settings.pro" || die "enable xvmc sed failed"
+ fi
+ # Needs a VIA supported kernel driver.
+ #if [ "`use via`" ] ; then
+ # sed -e "s:#CONFIG += using_via:CONFIG += using_via:"
+ # -e "s:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:"
+ # -i "settings.pro" || die "enable lirc sed failed"
+ #fi
+
+ qmake -o "Makefile" "${PN}.pro"
+
+ econf
+ make || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ newbin "setup/setup" "mythsetup"
+
+ dodir /etc/mythtv
+ mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
+ dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
+
+ insinto /usr/share/mythtv/database
+ doins database/*
+
+ exeinto /usr/share/mythtv
+ doexe "${FILESDIR}/mythfilldatabase.cron"
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/mythbackend.rc6" mythbackend
+ insinto /etc/conf.d
+ newins "${FILESDIR}/mythbackend.conf" mythbackend
+
+ dodoc AUTHORS COPYING FAQ README UPGRADING keys.txt docs/*.txt
+ dohtml docs/*.html
+
+ keepdir /var/{log,run}/mythtv
+}
+
+pkg_postinst() {
+ ewarn "Please note that /usr/share/mythtv/setup has been moved"
+ ewarn "to /usr/bin/mythsetup"
+ echo
+
+ einfo "If this is the first time you install MythTV,"
+ einfo "you need to add /usr/share/mythtv/database/mc.sql"
+ einfo "to your mysql database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/mc.sql'"
+ einfo
+ einfo "Next, you need to run the mythsetup program."
+ einfo "It will ask you some questions about your hardware, and"
+ einfo "then run xmltv's grabber to configure your channels."
+ einfo
+ einfo "Once you have configured your database, you can run"
+ einfo "/usr/bin/mythfilldatabase to populate the schedule"
+ einfo "or copy /usr/share/mythtv/mythfilldatabase.cron to"
+ einfo "/etc/cron.daily for this to happen automatically."
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}