summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-05-02 19:21:50 +0000
committerJon Portnoy <avenj@gentoo.org>2003-05-02 19:21:50 +0000
commit90c7963385430aadbeda9cccb65bd3dc85ba9265 (patch)
tree02d42b36c9cc48f8aecce3e0fe1d1b57a2775d77 /media-sound
parentInitial import, ebuild submitted by Par Karlsson in bug #19289 (diff)
downloadhistorical-90c7963385430aadbeda9cccb65bd3dc85ba9265.tar.gz
historical-90c7963385430aadbeda9cccb65bd3dc85ba9265.tar.bz2
historical-90c7963385430aadbeda9cccb65bd3dc85ba9265.zip
Initial import, ebuild submitted by Par Karlsson in bug #19289
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/toolame/Manifest3
-rw-r--r--media-sound/toolame/files/digest-toolame-02l1
-rw-r--r--media-sound/toolame/files/toolame-02l-gentoo.diff69
-rw-r--r--media-sound/toolame/toolame-02l.ebuild26
4 files changed, 98 insertions, 1 deletions
diff --git a/media-sound/toolame/Manifest b/media-sound/toolame/Manifest
index f3b5bd323634..704f18993458 100644
--- a/media-sound/toolame/Manifest
+++ b/media-sound/toolame/Manifest
@@ -1,3 +1,4 @@
-MD5 21bc4ad704547678f15b766c51f1cfc2 toolame-02l.ebuild 532
+MD5 c1ab3d686d2c6904d7cf7da1258eda32 toolame-02l.ebuild 632
+MD5 1bb99dfda4cff21a0c81bd1773bb2c08 ChangeLog 419
MD5 03d22f398bef3ac46ba7c7a7910d2d80 files/toolame-02l-gentoo.diff 2153
MD5 5cc792797a252d3d4d12b9857d393ee8 files/digest-toolame-02l 60
diff --git a/media-sound/toolame/files/digest-toolame-02l b/media-sound/toolame/files/digest-toolame-02l
new file mode 100644
index 000000000000..28158002d0e5
--- /dev/null
+++ b/media-sound/toolame/files/digest-toolame-02l
@@ -0,0 +1 @@
+MD5 5946e2dd78fbb57e54386b3b5d873fee toolame-02l.tgz 127493
diff --git a/media-sound/toolame/files/toolame-02l-gentoo.diff b/media-sound/toolame/files/toolame-02l-gentoo.diff
new file mode 100644
index 000000000000..00057ac21a87
--- /dev/null
+++ b/media-sound/toolame/files/toolame-02l-gentoo.diff
@@ -0,0 +1,69 @@
+--- Makefile 2003-03-02 08:07:02.000000000 +0100
++++ Makefile.new 2003-04-14 14:00:10.000000000 +0200
+@@ -1,6 +1,3 @@
+-
+-CC = gcc
+-
+ c_sources = \
+ common.c \
+ encode.c \
+@@ -26,37 +23,16 @@
+
+ OBJ = $(c_sources:.c=.o)
+
+-#Uncomment this if you want to do some profiling/debugging
+-#PG = -g -pg
+-PG = -fomit-frame-pointer
+-
+-# Optimize flag. 3 is about as high as you can sanely go with GCC3.2.
+-OPTIM = -O3
+-
+ # These flags are pretty much mandatory
+ REQUIRED = -DNDEBUG -DINLINE=inline
+
+-#pick your architecture
+-ARCH = -march=pentium
+-#Possible x86 architectures
+-#gcc3.2 => i386, i486, i586, i686, pentium, pentium-mmx
+-# pentiumpro, pentium2, pentium3, pentium4, k6, k6-2, k6-3,
+-# athlon, athlon-tbird, athlon-4, athlon-xp and athlon-mp.
+-
+-#TWEAK the hell out of the compile. Some of these are real dodgy
+-# and will cause program instability
+-#TWEAKS = -finline-functions -fexpensive-optimizations -ffast-math \
+-# -malign-double \
+-# -mfancy-math-387 -funroll-loops -funroll-all-loops -pipe \
+-# -fschedule-insns2 -fno-strength-reduce
+-
+ #Set a stack of warnings to overcome my atrocious coding style . MFC.
+ WARNINGS = -Wall
+ WARNINGS2 = -Wstrict-prototypes -Wmissing-prototypes -Wunused -Wunused-function -Wunused-label -Wunused-parameter -Wunused-variable -Wunused-value -Wredundant-decls
+
+ NEW_02L_FIXES = -DNEWENCODE -DNEWATAN
+
+-CC_SWITCHES = $(OPTIM) $(REQUIRED) $(ARCH) $(PG) $(TWEAKS) $(WARNINGS) $(NEW_02L_FIXES)
++CC_SWITCHES = $(CFLAGS) $(REQUIRED) $(WARNINGS) $(NEW_02L_FIXES)
+
+ PGM = toolame
+
+@@ -75,16 +51,16 @@
+ $(CC) $(CC_SWITCHES) -c $< -o $@
+
+ $(PGM): $(OBJ) Makefile
+- $(CC) $(PG) -o $(PGM) $(OBJ) $(LIBS)
++ $(CC) -o $(PGM) $(OBJ) $(LIBS)
+
+ clean:
+- -rm $(OBJ) $(DEP)
++ -rm $(OBJ) $(DEP) 2>/dev/null
+
+ megaclean:
+- -rm $(OBJ) $(DEP) $(PGM) \#*\# *~
++ -rm $(OBJ) $(DEP) $(PGM) \#*\# *~ 2>/dev/null
+
+ distclean:
+- -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile
++ -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile 2>/dev/null
+
+ tags: TAGS
+
diff --git a/media-sound/toolame/toolame-02l.ebuild b/media-sound/toolame/toolame-02l.ebuild
new file mode 100644
index 000000000000..bc052a41c7be
--- /dev/null
+++ b/media-sound/toolame/toolame-02l.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/toolame/toolame-02l.ebuild,v 1.1 2003/05/02 19:21:29 avenj Exp $
+
+DESCRIPTION="tooLAME - an optimized mpeg 1/2 layer 2 audio encoder"
+HOMEPAGE="http://www.planckenergy.com"
+SRC_URI="mirror://sourceforge/toolame/${P}.tgz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ sys-devel/gcc"
+
+src_compile() {
+ epatch ${FILESDIR}/${P}-gentoo.diff || die
+ emake || die
+}
+
+src_install() {
+ dobin toolame || die
+ dodoc README HISTORY FUTURE html/* text/*
+}
+
+