summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-02-01 04:20:34 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-02-01 04:20:34 +0000
commit13387da5d050744819e89838b3629f7bea79535b (patch)
tree5384af8fa873cd673e126b0d32b59937e32344ec /media-sound/xmms
parentFixed off-by-one bug that crept in with dtd/1.2.9 conflicting changes (closes... (diff)
downloadhistorical-13387da5d050744819e89838b3629f7bea79535b.tar.gz
historical-13387da5d050744819e89838b3629f7bea79535b.tar.bz2
historical-13387da5d050744819e89838b3629f7bea79535b.zip
Fixed off-by-one bug that crept in with dtd/1.2.9 conflicting changes (closes bug #40019). Updated random patch to fix compilation in gcc2.x (closes bug #39877). Added id3v2 tag editor to mpg123 plugin (closes bug #39437). Removing broken ebuilds.
Diffstat (limited to 'media-sound/xmms')
-rw-r--r--media-sound/xmms/Manifest4
-rw-r--r--media-sound/xmms/files/digest-xmms-1.2.9-r1 (renamed from media-sound/xmms/files/digest-xmms-1.2.9)2
-rw-r--r--media-sound/xmms/files/digest-xmms-1.2.9_pre13
-rw-r--r--media-sound/xmms/xmms-1.2.9-r1.ebuild (renamed from media-sound/xmms/xmms-1.2.9.ebuild)18
-rw-r--r--media-sound/xmms/xmms-1.2.9_pre1.ebuild190
5 files changed, 10 insertions, 207 deletions
diff --git a/media-sound/xmms/Manifest b/media-sound/xmms/Manifest
index 3e6395ee35e0..40b250b7c821 100644
--- a/media-sound/xmms/Manifest
+++ b/media-sound/xmms/Manifest
@@ -1,8 +1,8 @@
MD5 c71268dd67b5e034324c1bd1d888a784 xmms-1.2.7-r23.ebuild 5450
MD5 266e5522544a4c4693600c39c46e3707 xmms-1.2.7-r25.ebuild 5860
-MD5 ab5906dc71d9c0500ddc935f635ecf7b xmms-1.2.9-r1.ebuild 5260
+MD5 0af5187c219f17364ad5da5b274ca507 xmms-1.2.9-r1.ebuild 5364
MD5 db30834f3b768c46406c8330fdc18a48 xmms-1.2.8-r4.ebuild 5213
-MD5 ae73f07422747f1dc68ec5a0ba5e95c0 ChangeLog 18551
+MD5 50a937340612647eaae96c2fcff314f3 ChangeLog 18551
MD5 5c8b4d52a2da5ae758538b56bc384e37 xmms-1.2.8-r3.ebuild 4926
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 20b60b9c94a35974970dafd0bbd050c4 files/digest-xmms-1.2.7-r23 211
diff --git a/media-sound/xmms/files/digest-xmms-1.2.9 b/media-sound/xmms/files/digest-xmms-1.2.9-r1
index 8a3924b7689e..3a4c025cafdb 100644
--- a/media-sound/xmms/files/digest-xmms-1.2.9
+++ b/media-sound/xmms/files/digest-xmms-1.2.9-r1
@@ -1,3 +1,3 @@
MD5 428084b80a6ee936f57a6703a610f039 xmms-1.2.9.tar.bz2 2414962
MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
-MD5 d05fe3f1f94a7007e435b4481ef9d898 xmms-1.2.9-gentoo-patches-0.2.tar.bz2 128642
+MD5 117d0543ce0fced4855133a16c1600a0 xmms-1.2.9-gentoo-patches-0.3.tar.bz2 99025
diff --git a/media-sound/xmms/files/digest-xmms-1.2.9_pre1 b/media-sound/xmms/files/digest-xmms-1.2.9_pre1
deleted file mode 100644
index 3c99e8265a03..000000000000
--- a/media-sound/xmms/files/digest-xmms-1.2.9_pre1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 6427625f618b8f7a3b5dfa8ff268d330 xmms-1.2.9-pre1.tar.bz2 2408754
-MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
-MD5 e8ac4285df0a2b820ebb9f4fcbcbdaa5 xmms-1.2.9_pre1-gentoo-patches-0.2.tar.bz2 81669
diff --git a/media-sound/xmms/xmms-1.2.9.ebuild b/media-sound/xmms/xmms-1.2.9-r1.ebuild
index c3859e6c8e69..84f328dffed0 100644
--- a/media-sound/xmms/xmms-1.2.9.ebuild
+++ b/media-sound/xmms/xmms-1.2.9-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.9.ebuild,v 1.5 2004/01/30 08:10:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.9-r1.ebuild,v 1.1 2004/02/01 04:20:26 eradicator Exp $
inherit flag-o-matic eutils
-PATCHVER="0.2"
+PATCHVER="0.3"
MY_P=${P/_pre/-pre}
S=${WORKDIR}/${MY_P}
@@ -20,7 +20,9 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
IUSE="xml nls esd gnome opengl mmx oggvorbis 3dnow mikmod directfb ipv6 cjk"
-DEPEND="=x11-libs/gtk+-1.2*
+DEPEND=">=sys-devel/automake-1.7.8
+ app-arch/unzip
+ =x11-libs/gtk+-1.2*
mikmod? ( >=media-libs/libmikmod-3.1.10 )
esd? ( >=media-sound/esound-0.2.22 )
xml? ( >=dev-libs/libxml-1.8.15 )
@@ -30,13 +32,7 @@ DEPEND="=x11-libs/gtk+-1.2*
RDEPEND="${DEPEND}
directfb? ( dev-libs/DirectFB )
- nls? ( dev-util/intltool )
- app-arch/unzip"
-
-#We want these things in DEPEND only
-DEPEND="$DEPEND
- >=sys-devel/automake-1.7.8
- >=sys-devel/autoconf-2.58"
+ nls? ( dev-util/intltool )"
PATCHDIR=${WORKDIR}/patches
@@ -49,7 +45,7 @@ src_unpack() {
epatch ${PATCHDIR}/${P}-dtd.patch
# Fix ansi C fubar so that it compiles with less-forgiving gcc2
-# epatch ${PATCHDIR}/${P}-id3v2edit.patch
+ epatch ${PATCHDIR}/${P}-id3v2edit.patch
# Patch to allow external programmes to have the "jump to" dialog box
epatch ${PATCHDIR}/${P}-jump.patch
diff --git a/media-sound/xmms/xmms-1.2.9_pre1.ebuild b/media-sound/xmms/xmms-1.2.9_pre1.ebuild
deleted file mode 100644
index 94eac07f6460..000000000000
--- a/media-sound/xmms/xmms-1.2.9_pre1.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms/xmms-1.2.9_pre1.ebuild,v 1.6 2004/01/30 08:10:05 mr_bones_ Exp $
-
-inherit flag-o-matic eutils
-
-PATCHVER="0.2"
-
-MY_P=${P/_pre/-pre}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="X MultiMedia System"
-HOMEPAGE="http://www.xmms.org/"
-SRC_URI="http://www.xmms.org/files/1.2.x/${MY_P}.tar.bz2
- mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2
- mirror://gentoo/${P}-gentoo-patches-${PATCHVER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
-IUSE="xml nls esd gnome opengl mmx oggvorbis 3dnow mikmod directfb ipv6 cjk"
-
-DEPEND="=x11-libs/gtk+-1.2*
- mikmod? ( >=media-libs/libmikmod-3.1.10 )
- esd? ( >=media-sound/esound-0.2.22 )
- xml? ( >=dev-libs/libxml-1.8.15 )
- gnome? ( <gnome-base/gnome-panel-1.5.0 )
- opengl? ( virtual/opengl )
- oggvorbis? ( >=media-libs/libvorbis-1.0 )"
-
-RDEPEND="${DEPEND}
- directfb? ( dev-libs/DirectFB )
- nls? ( dev-util/intltool )
- app-arch/unzip"
-
-#We want these things in DEPEND only
-DEPEND="$DEPEND
- >=sys-devel/automake-1.7.8
- >=sys-devel/autoconf-2.58"
-
-PATCHDIR=${WORKDIR}/patches
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # Add dynamic taste detection patch...
- # goto http://bugs.xmms.org/show_bug.cgi?id=756 to vote for its inclusion in mainline xmms
- epatch ${PATCHDIR}/${P}-dtd.patch
-
- # Fix ansi C fubar so that it compiles with less-forgiving gcc2
- epatch ${PATCHDIR}/${P}-gcc2_fix.patch
-
- # Patch to allow external programmes to have the "jump to" dialog box
- epatch ${PATCHDIR}/${P}-jump.patch
-
- # Save playlist, etc on SIGTERM and SIGINT, bug #13604.
- epatch ${PATCHDIR}/${P}-sigterm.patch
-
- #shadow Patch, bug #30420.
- epatch ${PATCHDIR}/${P}-shadow.patch
-
- # Patch for mpg123 to convert Japanese character code of MP3 tag info
- # the Japanese patch and the Russian one overlap, so its one or the other
- if use cjk; then
- epatch ${PATCHDIR}/${P}-mpg123j.patch
- else
- # add russian charset support
- epatch ${PATCHDIR}/${P}-russian-charset-csa20.patch
- fi
-
- if [ ! -f ${S}/config.rpath ] ; then
- touch ${S}/config.rpath
- chmod +x ${S}/config.rpath
- fi
-
- # Add /usr/local/share/xmms/Skins to the search path for skins
- epatch ${PATCHDIR}/${P}-fhs-skinsdir.patch
-
- # This patch passes audio output through the output plugin
- # before recording via the diskwriter plugin
- # http://forum.xmms.org/viewtopic.php?t=500&sid=c286e1c01fb924a2f81f519969f33764
- epatch ${PATCHDIR}/${P}-diskwriter-audio.patch
-
- # Patch to enable superior randomised playlists:
- epatch ${PATCHDIR}/${P}-random.patch
-
- # This patch changes the search-bar's behaviour when playing
- # sid tunes using xmms-sid plugin. It enables you to select the
- # different tunes that are sometimes included in a single .sid file
- epatch ${PATCHDIR}/${P}-sid-songpos.patch
-
- export WANT_AUTOCONF=2.5
- export WANT_AUTOMAKE=1.7
- for x in . libxmms ; do
- cd ${S}/${x}
- automake --gnu --add-missing --include-deps || die
- done
-}
-
-src_compile() {
- filter-flags -fforce-addr -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
-
- local myconf=""
-
- # Allow configure to detect mipslinux systems
- use mips && gnuconfig_update
-
- if use amd64; then
- myconf="${myconf} --disable-simd"
- else
- if use 3dnow || use mmx; then
- myconf="${myconf} --enable-simd"
- else
- myconf="${myconf} --disable-simd"
- fi
- fi
-
- use xml || myconf="${myconf} --disable-cdindex"
-
- econf \
- --with-dev-dsp=/dev/sound/dsp \
- --with-dev-mixer=/dev/sound/mixer \
- `use_with gnome` \
- `use_enable oggvorbis vorbis` \
- `use_enable oggvorbis oggtest` \
- `use_enable oggvorbis vorbistest` \
- `use_enable esd` \
- `use_enable esd esdtest` \
- `use_enable mikmod` \
- `use_enable mikmod mikmodtest` \
- `use_with mikmod libmikmod` \
- `use_enable opengl` \
- `use_enable nls` \
- `use_enable ipv6` \
- ${myconf} \
- || die
-
- ### emake seems to break some compiles, please keep @ make
- make || die
-}
-
-src_install() {
- einstall \
- incdir=${D}/usr/include \
- sysdir=${D}/usr/share/applets/Multimedia \
- GNOME_SYSCONFDIR=${D}/etc \
- install || die "make install failed"
-
- dodoc AUTHORS ChangeLog FAQ NEWS README TODO
-
- keepdir /usr/share/xmms/Skins
- insinto /usr/share/pixmaps/
- donewins gnomexmms/gnomexmms.xpm xmms.xpm
- doins xmms/xmms_logo.xpm
- insinto /usr/share/pixmaps/mini
- doins xmms/xmms_mini.xpm
-
- insinto /etc/X11/wmconfig
- donewins xmms/xmms.wmconfig xmms
-
- if use gnome; then
- insinto /usr/share/gnome/apps/Multimedia
- doins xmms/xmms.desktop
- dosed "s:xmms_mini.xpm:mini/xmms_mini.xpm:" \
- /usr/share/gnome/apps/Multimedia/xmms.desktop
- else
- rm ${D}/usr/share/man/man1/gnomexmms*
- fi
-
- # Add the sexy Gentoo Ice skin
- insinto /usr/share/xmms/Skins/gentoo_ice
- doins ${WORKDIR}/gentoo_ice/*
- docinto gentoo_ice
- dodoc ${WORKDIR}/README
-}
-
-pkg_postinst() {
- echo
- einfo "If you have been using the xmms-sid plugin before,"
- einfo "it would be a good idea to re-emerge it now, to have"
- einfo "the additional features introduced by the xmms-songpos patch"
- einfo "which let's you select one of several tunes sometimes included"
- einfo "in a single .sid file using the song-position slider."
- echo
- einfo "If you enjoy the dtd (Dynamic Taste Detection) patch, please"
- einfo "visit the url below and vote for this patch's inclusion in"
- einfo "main-line xmms."
- einfo "http://bugs.xmms.org/show_bug.cgi?id=756"
-}