summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-02-03 04:15:53 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-02-03 04:15:53 +0000
commitab1f1d580293e5bbd0c1d7182fe98f0f84719f12 (patch)
tree97a74085935320d1b34ac9d373eaabb3c93cf8ad /media-sound/xmms-shn
parentmerge fix (diff)
downloadhistorical-ab1f1d580293e5bbd0c1d7182fe98f0f84719f12.tar.gz
historical-ab1f1d580293e5bbd0c1d7182fe98f0f84719f12.tar.bz2
historical-ab1f1d580293e5bbd0c1d7182fe98f0f84719f12.zip
*** empty log message ***
Diffstat (limited to 'media-sound/xmms-shn')
-rw-r--r--media-sound/xmms-shn/files/digest-xmms-shn-2.2.31
-rw-r--r--media-sound/xmms-shn/xmms-shn-2.2.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/xmms-shn/files/digest-xmms-shn-2.2.3 b/media-sound/xmms-shn/files/digest-xmms-shn-2.2.3
new file mode 100644
index 000000000000..bac461e382e0
--- /dev/null
+++ b/media-sound/xmms-shn/files/digest-xmms-shn-2.2.3
@@ -0,0 +1 @@
+MD5 0ad558f9cbee57fb67f8b06adbccc6c3 xmms-shn-2.2.3.tar.bz2
diff --git a/media-sound/xmms-shn/xmms-shn-2.2.3.ebuild b/media-sound/xmms-shn/xmms-shn-2.2.3.ebuild
new file mode 100644
index 000000000000..3a0b5b993867
--- /dev/null
+++ b/media-sound/xmms-shn/xmms-shn-2.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xmms-shn/xmms-shn-2.2.3.ebuild,v 1.1 2001/02/03 04:15:51 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="This input plugin allows xmms to play .shn compressed (lossless) files"
+SRC_URI="http://shnutils.freeshell.org/xmms-shn/xmms-shn-2.2.3.tar.bz2"
+HOMEPAGE="http://shnutils.freeshell.org/xmms-shn"
+DEPEND=">=sys-libs/glibc-2.1.3 >=media-sound/xmms-1.2.3"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ local myconf
+ if [ "`use gnome`" ]
+ then
+ myconf="--prefix=/opt/gnome"
+ else
+ myconf="--prefix=/usr/X11R6"
+ fi
+ try ./configure $myconf --host=${CHOST}
+ try make
+}
+
+src_install() {
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING NEWS README
+}
+