summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-24 23:34:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-24 23:34:15 +0000
commitbbfdd9d5b856b6f831e46498ee0f4be25bf078df (patch)
treed8dda59610038dc224d7c747325fd88fc053d678 /media-sound/timidity-eawpatches/timidity-eawpatches-12-r5.ebuild
parentRemove timidity-update script, instead depend on eselect-timidity, and inform... (diff)
downloadhistorical-bbfdd9d5b856b6f831e46498ee0f4be25bf078df.tar.gz
historical-bbfdd9d5b856b6f831e46498ee0f4be25bf078df.tar.bz2
historical-bbfdd9d5b856b6f831e46498ee0f4be25bf078df.zip
Remove dependency on timidity++ (so that these patchsets can be used with libmodplug when it will work), remove message regarding timidity-updater, and use eselect timidity to set the current patchset if none was selected before.
Package-Manager: portage-2.1.2_rc2-r1
Diffstat (limited to 'media-sound/timidity-eawpatches/timidity-eawpatches-12-r5.ebuild')
-rw-r--r--media-sound/timidity-eawpatches/timidity-eawpatches-12-r5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/timidity-eawpatches/timidity-eawpatches-12-r5.ebuild b/media-sound/timidity-eawpatches/timidity-eawpatches-12-r5.ebuild
new file mode 100644
index 000000000000..faa6b5a1e420
--- /dev/null
+++ b/media-sound/timidity-eawpatches/timidity-eawpatches-12-r5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity-eawpatches/timidity-eawpatches-12-r5.ebuild,v 1.1 2006/11/24 23:31:02 flameeyes Exp $
+
+IUSE=""
+
+S=${WORKDIR}/eawpats
+
+DESCRIPTION="Eric Welsh's GUS patches for TiMidity"
+HOMEPAGE="http://www.stardate.bc.ca/eawpatches/html/default.htm"
+SRC_URI="http://5hdumat.samizdat.net/music/eawpats${PV}_full.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86-fbsd"
+
+# These can be used for libmodplug too, so don't depend on timidity++
+DEPEND="app-admin/eselect-esd"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:dir /home/user/eawpats/:dir /usr/share/timidity/eawpatches:" "${S}/linuxconfig/timidity.cfg"
+}
+
+src_install() {
+ local instdir=/usr/share/timidity
+
+ # Set our installation directory
+ insinto ${instdir}/eawpatches
+
+ # Install base timidity configuration for timidity-update
+ doins linuxconfig/timidity.cfg
+ rm -rf linuxconfig/ winconfig/
+
+ # Install base eawpatches
+ doins *.cfg *.pat
+ rm *.cfg *.pat
+
+ # Install patches from subdirectories
+ for d in `find . -type f -name \*.pat | sed 's,/[^/]*$,,' | sort -u`; do
+ insinto ${instdir}/eawpatches/${d}
+ doins ${d}/*.pat
+ done
+
+ # Install documentation, including subdirs
+ dodoc $(find . -name \*.txt)
+}
+
+pkg_postinst() {
+ eselect timidity update --global --if-unset
+}