summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-06-28 10:45:42 +0000
committerCédric Krier <cedk@gentoo.org>2008-06-28 10:45:42 +0000
commit1157f4d855a62fe7d4975a83b879aaa3db48dd27 (patch)
treed0ffd08f24866ceadaf22a816658c5f209af1abf /media-sound/sndpeek/sndpeek-1.3-r1.ebuild
parentForce qt4 to be enabled instead of having configure to die when enabling skin... (diff)
downloadhistorical-1157f4d855a62fe7d4975a83b879aaa3db48dd27.tar.gz
historical-1157f4d855a62fe7d4975a83b879aaa3db48dd27.tar.bz2
historical-1157f4d855a62fe7d4975a83b879aaa3db48dd27.zip
Add patch for gcc-4.3 for bug #229211
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'media-sound/sndpeek/sndpeek-1.3-r1.ebuild')
-rw-r--r--media-sound/sndpeek/sndpeek-1.3-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/sndpeek/sndpeek-1.3-r1.ebuild b/media-sound/sndpeek/sndpeek-1.3-r1.ebuild
new file mode 100644
index 000000000000..b6ca0e73b1f1
--- /dev/null
+++ b/media-sound/sndpeek/sndpeek-1.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sndpeek/sndpeek-1.3-r1.ebuild,v 1.1 2008/06/28 10:45:42 cedk Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="real-time audio visualization"
+HOMEPAGE="http://soundlab.cs.princeton.edu/software/sndpeek/"
+SRC_URI="http://soundlab.cs.princeton.edu/software/${PN}/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="oss jack alsa"
+
+DEPEND="virtual/glut
+ virtual/opengl
+ virtual/glu
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXext
+ jack? ( media-sound/jack-audio-connection-kit )
+ alsa? ( media-libs/alsa-lib )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+}
+
+pkg_setup() {
+ local cnt=0
+ use jack && cnt="$((${cnt} + 1))"
+ use alsa && cnt="$((${cnt} + 1))"
+ use oss && cnt="$((${cnt} + 1))"
+ if [[ "${cnt}" -eq 0 ]]; then
+ eerror "One of the following USE flags is needed: jack, alsa or oss"
+ die "Please set one audio engine type"
+ elif [[ "${cnt}" -ne 1 ]]; then
+ ewarn "You have set ${P} to use multiple audio engine."
+ fi
+}
+
+src_compile() {
+ cd "${S}/src/sndpeek"
+
+ local backend
+ if use jack; then
+ backend="jack"
+ elif use alsa; then
+ backend="alsa"
+ elif use oss; then
+ backend="oss"
+ fi
+ einfo "Compiling against ${backend}"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ dobin src/sndpeek/sndpeek
+
+ dodoc AUTHORS README THANKS TODO VERSIONS
+}