summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-05-21 18:50:41 +0000
committerJon Hood <squinky86@gentoo.org>2004-05-21 18:50:41 +0000
commit5b2817425229952d491dc2130a68f1750ac0d6d5 (patch)
tree185e43032149dc367ccfa1e4cd701fb8aa37074a /media-sound/snd/snd-7.4.ebuild
parentadded patch to fix 64bit arch defines, which broke mikmod output (diff)
downloadhistorical-5b2817425229952d491dc2130a68f1750ac0d6d5.tar.gz
historical-5b2817425229952d491dc2130a68f1750ac0d6d5.tar.bz2
historical-5b2817425229952d491dc2130a68f1750ac0d6d5.zip
version bump and ebuild cleanup irt #48464
Diffstat (limited to 'media-sound/snd/snd-7.4.ebuild')
-rw-r--r--media-sound/snd/snd-7.4.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/media-sound/snd/snd-7.4.ebuild b/media-sound/snd/snd-7.4.ebuild
new file mode 100644
index 000000000000..f19060748de3
--- /dev/null
+++ b/media-sound/snd/snd-7.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-7.4.ebuild,v 1.1 2004/05/21 18:50:41 squinky86 Exp $
+
+IUSE="esd motif guile X gtk ruby alsa"
+
+S="${WORKDIR}/${P/\.*//}"
+DESCRIPTION="Snd is a sound editor"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://snd.sourceforge.net"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="X? ( virtual/x11 )
+ dev-libs/gsl
+ media-libs/ladspa-sdk
+ media-libs/audiofile
+ esd? ( media-sound/esound )
+ alsa? ( media-libs/alsa-lib )
+ gtk? ( x11-libs/gtk+ )
+ guile? ( dev-util/guile )
+ motif? ( x11-libs/openmotif )
+ ruby? ( virtual/ruby )"
+
+
+src_compile() {
+ local myconf
+
+ use alsa \
+ && myconf="${myconf} --with-alsa" \
+ || myconf="${myconf} --without-alsa"
+
+ use esd \
+ && myconf="${myconf} --with-esd" \
+ || myconf="${myconf} --without-esd"
+
+ use gtk \
+ && myconf="${myconf} --with-gtk" \
+ || myconf="${myconf} --without-gtk"
+
+ use guile \
+ && myconf="${myconf} --with-guile --with-run" \
+ || myconf="${myconf} --without-guile"
+
+ use ruby \
+ && myconf="${myconf} --with-ruby" \
+ || myconf="${myconf} --without-ruby"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+# looks like gl is still broke
+# use gl \
+# && myconf="${myconf} --with-just-gl" \
+# || myconf="${myconf} --without-gl"
+
+ econf --with-ladspa --with-float-samples \
+ --with-float-sample-width ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ dobin snd
+
+ dodoc COPYING *.Snd *.scm *.rb *.png *.html
+
+ cd tutorial
+ dohtml *
+ insinto /usr/share/doc/${PF}/html/images/jpg
+ doins images/jpg/*
+}