summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-10 12:46:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-10 12:46:52 +0000
commit951f4ee3135b1110cb25807755dabcef6f8393fb (patch)
tree178dbb7a372c2f043014468e7e7f3bf25ce3dae0 /media-sound/seq24
parentUpdate to EAPI=2 and USE deps. (diff)
downloadhistorical-951f4ee3135b1110cb25807755dabcef6f8393fb.tar.gz
historical-951f4ee3135b1110cb25807755dabcef6f8393fb.tar.bz2
historical-951f4ee3135b1110cb25807755dabcef6f8393fb.zip
Update to EAPI=2 and USE deps.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 x86_64
Diffstat (limited to 'media-sound/seq24')
-rw-r--r--media-sound/seq24/ChangeLog7
-rw-r--r--media-sound/seq24/seq24-0.8.7-r1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/media-sound/seq24/ChangeLog b/media-sound/seq24/ChangeLog
index fc8600d9c921..7f76d2113be1 100644
--- a/media-sound/seq24/ChangeLog
+++ b/media-sound/seq24/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/seq24
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/ChangeLog,v 1.31 2008/06/04 13:05:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/ChangeLog,v 1.32 2008/10/10 12:44:41 flameeyes Exp $
+
+*seq24-0.8.7-r1 (10 Oct 2008)
+
+ 10 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> +seq24-0.8.7-r1.ebuild:
+ Update to EAPI=2 and USE deps.
04 Jun 2008; Alexis Ballier <aballier@gentoo.org> seq24-0.8.7.ebuild:
Fix build with libsigc++-2.2, thanks to tom <gimpel@sonnenkinder.org>, bug
diff --git a/media-sound/seq24/seq24-0.8.7-r1.ebuild b/media-sound/seq24/seq24-0.8.7-r1.ebuild
new file mode 100644
index 000000000000..1b1dab97692b
--- /dev/null
+++ b/media-sound/seq24/seq24-0.8.7-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/seq24-0.8.7-r1.ebuild,v 1.1 2008/10/10 12:44:41 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils
+
+IUSE="jack lash"
+DESCRIPTION="Seq24 is a loop based MIDI sequencer with focus on live performances."
+HOMEPAGE="http://www.filter24.org/seq24/"
+SRC_URI="http://www.filter24.org/seq24/${P}.tar.gz
+ mirror://gentoo/${P}-sigc22_fix.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=media-libs/alsa-lib-0.9.0[midi]
+ >=dev-cpp/gtkmm-2.4
+ >=dev-libs/libsigc++-2.0
+ jack? ( >=media-sound/jack-audio-connection-kit-0.90.0 )
+ lash? ( >=media-sound/lash-0.5.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # fix #220827
+ if has_version ">=dev-libs/libsigc++-2.2"; then
+ epatch "${WORKDIR}/${P}-sigc22_fix.patch"
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable jack jack-support) \
+ $(use_enable lash) \
+ --disable-alsatest \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README RTC SEQ24
+}