summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-05-08 11:11:11 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-05-08 11:11:11 +0000
commit90279acde0e22b115508e0bb9d76a731b90a05f4 (patch)
tree3afde59495529548e6862f6937bdb6368f03430d /media-sound/rip
parentVersion bump. Closes #13421. (diff)
downloadhistorical-90279acde0e22b115508e0bb9d76a731b90a05f4.tar.gz
historical-90279acde0e22b115508e0bb9d76a731b90a05f4.tar.bz2
historical-90279acde0e22b115508e0bb9d76a731b90a05f4.zip
Version bump. Closes #13421.
Diffstat (limited to 'media-sound/rip')
-rw-r--r--media-sound/rip/Manifest4
-rw-r--r--media-sound/rip/files/digest-rip-1.071
-rw-r--r--media-sound/rip/rip-1.07.ebuild36
3 files changed, 39 insertions, 2 deletions
diff --git a/media-sound/rip/Manifest b/media-sound/rip/Manifest
index 1b51aaa813a8..b376087b4ab2 100644
--- a/media-sound/rip/Manifest
+++ b/media-sound/rip/Manifest
@@ -1,5 +1,5 @@
-MD5 9d381d69531b87f49eefc52e03ac7452 ChangeLog 962
+MD5 877ae30355af1fbca36b10e03fb08287 ChangeLog 1111
MD5 97487de343fcba6a653804abadcc12b7 rip-1.01-r1.ebuild 812
-MD5 792dec38015a3675f4a507a2d5280100 rip-1.07.ebuild 710
+MD5 e3b81d4a2c4b65df49744b8281de2a4a rip-1.07.ebuild 802
MD5 6079edf2cba6cd4be440a12eca48f7ec files/digest-rip-1.07 60
MD5 5ff5f7a6e5370222da299fc32e4a0062 files/digest-rip-1.01-r1 60
diff --git a/media-sound/rip/files/digest-rip-1.07 b/media-sound/rip/files/digest-rip-1.07
new file mode 100644
index 000000000000..fb0346bf21e0
--- /dev/null
+++ b/media-sound/rip/files/digest-rip-1.07
@@ -0,0 +1 @@
+MD5 dd8c967220c854163279881b020dde69 rip-1.07.tar.gz 110261
diff --git a/media-sound/rip/rip-1.07.ebuild b/media-sound/rip/rip-1.07.ebuild
new file mode 100644
index 000000000000..62c355a1b917
--- /dev/null
+++ b/media-sound/rip/rip-1.07.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rip/rip-1.07.ebuild,v 1.1 2003/05/08 11:10:08 jje Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A command-line based audio CD ripper and mp3 encoder"
+SRC_URI="http://rip.sourceforge.net/download/${P}.tar.gz"
+HOMEPAGE="http://rip.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=""
+
+RDEPEND="media-sound/cdparanoia
+ sys-apps/eject
+ dev-lang/perl
+ >=dev-perl/CDDB_get-1.66
+ >=dev-perl/MP3-Info-0.91"
+
+src_compile() {
+ #the thing itself is just a perl script
+ #so we need an empty method here
+ echo "nothing to be done"
+
+}
+
+src_install () {
+
+ chmod 755 rip
+ dobin rip || die
+
+ # Install documentation.
+ dodoc COPYING FAQ README
+}