summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-12 09:14:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-12 09:14:54 +0000
commit6913a5af962ed5f120b37589421ae7e4d3030803 (patch)
tree5ea4a6d2299ea862d79c3271f7258dc7610f5ca6 /media-sound/rawrec/files
parentblock media-sound/mpc, see bug 230840 reported by Daniel Schömer <daniel DOT... (diff)
downloadhistorical-6913a5af962ed5f120b37589421ae7e4d3030803.tar.gz
historical-6913a5af962ed5f120b37589421ae7e4d3030803.tar.bz2
historical-6913a5af962ed5f120b37589421ae7e4d3030803.zip
dont use ldflags to link to libraries, bug #226899
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25.7 x86_64
Diffstat (limited to 'media-sound/rawrec/files')
-rw-r--r--media-sound/rawrec/files/rawrec-libs.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/media-sound/rawrec/files/rawrec-libs.patch b/media-sound/rawrec/files/rawrec-libs.patch
new file mode 100644
index 000000000000..c894c5ba692d
--- /dev/null
+++ b/media-sound/rawrec/files/rawrec-libs.patch
@@ -0,0 +1,22 @@
+Index: src/Makefile
+===================================================================
+--- src.orig/Makefile
++++ src/Makefile
+@@ -19,7 +19,7 @@ OPTFLAGS = -O2
+ CFLAGS = $(WARNFLAGS) $(OPTFLAGS) $(DEBUGFLAGS) -DUSEBUFFLOCK \
+ $(FANCY_THREAD_DEFINES) -D_REENTRANT -D_GNU_SOURCE \
+ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+-LDFLAGS = -lm -lpthread
++LIBS = -lm -lpthread
+
+ # The GNU way is just too painful. I'm not writing three tiers of
+ # variables just to get to /usr/local/man/man1. If it starts to seem
+@@ -35,7 +35,7 @@ MAN_DIR = /usr/local/man/man1
+ all: $(PROG) $(ALT_INVOC)
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LDFLAGS) -o $(PROG)
++ $(CC) $(LDFLAGS) $(OBJS) -o $(PROG) $(LIBS)
+
+ # Everything is rebuilt if this Makefile (which is hopefully named
+ # "Makefile") or any header changes.