summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Holland <tigger@gentoo.org>2003-07-31 15:44:26 +0000
committerRob Holland <tigger@gentoo.org>2003-07-31 15:44:26 +0000
commit2768be81a1de284617e6409d74e2fb33b08a3df9 (patch)
tree09ac4f6ac10d404d49aa62b13a06fcff894f0789 /media-sound/mpd
parentVersion bump, noted by sbh <starz@antisocial.com>, closes #25147 (diff)
downloadhistorical-2768be81a1de284617e6409d74e2fb33b08a3df9.tar.gz
historical-2768be81a1de284617e6409d74e2fb33b08a3df9.tar.bz2
historical-2768be81a1de284617e6409d74e2fb33b08a3df9.zip
Version bump, noted by sbh <starz@antisocial.com>, closes #25147
Diffstat (limited to 'media-sound/mpd')
-rw-r--r--media-sound/mpd/Manifest4
-rw-r--r--media-sound/mpd/files/digest-mpd-0.8.21
-rw-r--r--media-sound/mpd/mpd-0.8.2.ebuild44
3 files changed, 47 insertions, 2 deletions
diff --git a/media-sound/mpd/Manifest b/media-sound/mpd/Manifest
index 51ff8a471aca..d4836eb0081a 100644
--- a/media-sound/mpd/Manifest
+++ b/media-sound/mpd/Manifest
@@ -1,5 +1,5 @@
MD5 58f887042db750a9d8e72e410c7092c4 mpd-0.8.1.ebuild 1140
-MD5 419ce23e5cab38e216cfc27e05529c20 ChangeLog 398
-MD5 58f887042db750a9d8e72e410c7092c4 mpd-0.8.2.ebuild 1140
+MD5 2b28299d951f1fd15416fd2d198fd6a8 ChangeLog 558
+MD5 24efbb6aa450130a48c0d489924d6dcb mpd-0.8.2.ebuild 1141
MD5 584e630a8aba4c01febb8248c9f3247b files/digest-mpd-0.8.1 61
MD5 3ba62c82a1d52363a5cf5862b0ff5d7e files/digest-mpd-0.8.2 61
diff --git a/media-sound/mpd/files/digest-mpd-0.8.2 b/media-sound/mpd/files/digest-mpd-0.8.2
new file mode 100644
index 000000000000..304b3692e38f
--- /dev/null
+++ b/media-sound/mpd/files/digest-mpd-0.8.2
@@ -0,0 +1 @@
+MD5 010c746fb01588a727ce9668fa8be956 mpd-0.8.2.tar.gz 715140
diff --git a/media-sound/mpd/mpd-0.8.2.ebuild b/media-sound/mpd/mpd-0.8.2.ebuild
new file mode 100644
index 000000000000..8fd99f8a8472
--- /dev/null
+++ b/media-sound/mpd/mpd-0.8.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.8.2.ebuild,v 1.1 2003/07/31 15:44:19 tigger Exp $
+
+IUSE="oggvorbis mad"
+
+DESCRIPTION="Music Player Daemon (mpd)"
+SRC_URI="http://mercury.chem.pitt.edu/~shank/${P}.tar.gz"
+HOMEPAGE="http://musicpd.sourceforge.net/"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ mad? ( media-libs/libmad media-libs/libid3tag )
+ >=media-libs/flac-1.1.0
+ media-libs/libao
+ sys-libs/zlib"
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-oggtest \
+ --disable-vorbistest"
+ use mad \
+ || myconf="${myconf} --enable-mpd-mad --enable-mpd-id3tag"
+
+ econf ${myconf} || die "could not configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${S}
+ dobin mpd
+ dodoc mpdconf.example COMMANDS ChangeLog INSTALL README TODO UPGRADING
+}
+
+pkg_postinst() {
+ einfo "libao has issues with the ALSA drivers, please refer to the FAQ"
+ einfo "http://musicpd.sourceforge.net/faq.php"
+}