summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-10-11 23:28:06 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-10-11 23:28:06 +0000
commit99d450ad8513d9acaff0d90810f225ee20841aeb (patch)
tree990a19210a87c961fd4b9354259bab4c6b059dd5 /media-sound/mp3gain/mp3gain-1.4.6-r2.ebuild
parentimlib2 is required even with USE=-X. (diff)
downloadhistorical-99d450ad8513d9acaff0d90810f225ee20841aeb.tar.gz
historical-99d450ad8513d9acaff0d90810f225ee20841aeb.tar.bz2
historical-99d450ad8513d9acaff0d90810f225ee20841aeb.zip
Do not set CFLAGS in stone during src_unpack stage to avoid triggering the mass CFLAGS bug filing framework. Use toolchain-funcs eclass to set CC. Closes bug #240808 by Diego "Flameeyes" Pettenò <flameeyes@gentoo.org>.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.27-rc8-dirty x86_64
Diffstat (limited to 'media-sound/mp3gain/mp3gain-1.4.6-r2.ebuild')
-rw-r--r--media-sound/mp3gain/mp3gain-1.4.6-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-sound/mp3gain/mp3gain-1.4.6-r2.ebuild b/media-sound/mp3gain/mp3gain-1.4.6-r2.ebuild
new file mode 100644
index 000000000000..62aae6389169
--- /dev/null
+++ b/media-sound/mp3gain/mp3gain-1.4.6-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3gain/mp3gain-1.4.6-r2.ebuild,v 1.1 2008/10/11 23:28:06 chainsaw Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE=""
+
+MY_P=${P//./_}
+S=${WORKDIR}
+
+DESCRIPTION="MP3Gain automatically adjusts mp3s so that they all have the same volume"
+HOMEPAGE="http://mp3gain.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.zip"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ filter-flags -O*
+ sed -i -e "s:CC=.*:CC=$(tc-getCC):" "${S}"/Makefile || die "Unable to override compiler selection"
+ sed -i -e "s:CFLAGS= -Wall -O3 -DHAVE_MEMCPY:CFLAGS+= -Wall -DHAVE_MEMCPY:" "${S}"/Makefile ||
+ die "Unable to convince build system to respect CFLAGS"
+ epatch "${FILESDIR}"/${PV}-option-parser.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "Compile failed"
+}
+
+src_install () {
+ dobin mp3gain
+}