summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-18 21:56:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-18 21:56:26 +0000
commit69f9879180f2649f30e1c327801e8f5050a92351 (patch)
tree57720f9dc8ab9c5814ce2ffd9290cd33353907f3 /media-sound/kid3
parentRemove old and add quote (diff)
downloadhistorical-69f9879180f2649f30e1c327801e8f5050a92351.tar.gz
historical-69f9879180f2649f30e1c327801e8f5050a92351.tar.bz2
historical-69f9879180f2649f30e1c327801e8f5050a92351.zip
add a check for flac cxx use flag, FLAC++ is needed here
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'media-sound/kid3')
-rw-r--r--media-sound/kid3/ChangeLog6
-rw-r--r--media-sound/kid3/kid3-0.6.ebuild14
-rw-r--r--media-sound/kid3/kid3-0.7.ebuild14
-rw-r--r--media-sound/kid3/kid3-0.8.1.ebuild12
-rw-r--r--media-sound/kid3/kid3-0.9.ebuild12
5 files changed, 51 insertions, 7 deletions
diff --git a/media-sound/kid3/ChangeLog b/media-sound/kid3/ChangeLog
index b58241526a94..1ab1d1d0247a 100644
--- a/media-sound/kid3/ChangeLog
+++ b/media-sound/kid3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/kid3
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.27 2007/06/23 23:57:25 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.28 2007/11/18 21:52:08 aballier Exp $
+
+ 18 Nov 2007; Alexis Ballier <aballier@gentoo.org> kid3-0.6.ebuild,
+ kid3-0.7.ebuild, kid3-0.8.1.ebuild, kid3-0.9.ebuild:
+ add a check for flac cxx use flag, FLAC++ is needed here
*kid3-0.9 (23 Jun 2007)
diff --git a/media-sound/kid3/kid3-0.6.ebuild b/media-sound/kid3/kid3-0.6.ebuild
index 2342ca649a1b..a0ad5ea0f542 100644
--- a/media-sound/kid3/kid3-0.6.ebuild
+++ b/media-sound/kid3/kid3-0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.4 2006/07/25 08:02:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.5 2007/11/18 21:52:08 aballier Exp $
inherit kde
@@ -19,6 +19,16 @@ DEPEND=">=media-libs/id3lib-3.8.3
need-kde 3
+pkg_setup() {
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
+ kde_pkg_setup
+}
+
# Support for the KDE libraries is optional,
# but the configure step that detects them
# cannot be avoided. So KDE support is forced on.
diff --git a/media-sound/kid3/kid3-0.7.ebuild b/media-sound/kid3/kid3-0.7.ebuild
index 18486e89bda4..0f8cd5cec52c 100644
--- a/media-sound/kid3/kid3-0.7.ebuild
+++ b/media-sound/kid3/kid3-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.7.ebuild,v 1.1 2006/10/05 06:52:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.7.ebuild,v 1.2 2007/11/18 21:52:08 aballier Exp $
inherit kde
@@ -20,6 +20,16 @@ RDEPEND="${DEPEND}"
need-kde 3
+pkg_setup() {
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
+ kde_pkg_setup
+}
+
# Support for the KDE libraries is optional,
# but the configure step that detects them
# cannot be avoided. So KDE support is forced on.
diff --git a/media-sound/kid3/kid3-0.8.1.ebuild b/media-sound/kid3/kid3-0.8.1.ebuild
index 60b84c4abaa5..e0610f7f970e 100644
--- a/media-sound/kid3/kid3-0.8.1.ebuild
+++ b/media-sound/kid3/kid3-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.8.1.ebuild,v 1.6 2007/02/13 10:10:09 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.8.1.ebuild,v 1.7 2007/11/18 21:52:08 aballier Exp $
inherit kde
@@ -19,6 +19,16 @@ DEPEND=">=media-libs/id3lib-3.8.3
need-kde 3
+pkg_setup() {
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
+ kde_pkg_setup
+}
+
# Support for the KDE libraries is optional,
# but the configure step that detects them
# cannot be avoided. So KDE support is forced on.
diff --git a/media-sound/kid3/kid3-0.9.ebuild b/media-sound/kid3/kid3-0.9.ebuild
index c8bc9d4eaa9d..9a9f2d537e93 100644
--- a/media-sound/kid3/kid3-0.9.ebuild
+++ b/media-sound/kid3/kid3-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.9.ebuild,v 1.1 2007/06/23 23:57:25 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.9.ebuild,v 1.2 2007/11/18 21:52:08 aballier Exp $
inherit kde
@@ -27,6 +27,16 @@ for X in ${LANGS} ${LANGS_DOC} ; do
IUSE="${IUSE} linguas_${X}"
done
+pkg_setup() {
+ if use flac && ! built_with_use --missing true media-libs/flac cxx; then
+ eerror "To build ${PN} with flac support you need the C++ bindings for flac."
+ eerror "Please enable the cxx USE flag for media-libs/flac"
+ die "Missing FLAC C++ bindings."
+ fi
+
+ kde_pkg_setup
+}
+
src_unpack() {
kde_src_unpack