summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-06-15 22:45:44 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-06-15 22:45:44 +0000
commit5b680ac5abe9e0c0eb099ad89b62e26fdd85eafc (patch)
treef8b24d6688950ac3ba476e152859a980051e0a67 /media-sound/creox
parentVersion bump, thanks to TGL <degrenier@easyconnect.fr> in bug #54016 (diff)
downloadhistorical-5b680ac5abe9e0c0eb099ad89b62e26fdd85eafc.tar.gz
historical-5b680ac5abe9e0c0eb099ad89b62e26fdd85eafc.tar.bz2
historical-5b680ac5abe9e0c0eb099ad89b62e26fdd85eafc.zip
Added to ~amd64. Stable x86. Added patch to fix nptl support.
Diffstat (limited to 'media-sound/creox')
-rw-r--r--media-sound/creox/ChangeLog6
-rw-r--r--media-sound/creox/Manifest5
-rw-r--r--media-sound/creox/creox-0.2.2_rc2.ebuild13
-rw-r--r--media-sound/creox/files/creox-0.2.2_rc2-ebusy.patch77
4 files changed, 95 insertions, 6 deletions
diff --git a/media-sound/creox/ChangeLog b/media-sound/creox/ChangeLog
index 132f0af9e4f9..e75a1308a672 100644
--- a/media-sound/creox/ChangeLog
+++ b/media-sound/creox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/creox
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/creox/ChangeLog,v 1.4 2004/06/13 08:17:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/creox/ChangeLog,v 1.5 2004/06/15 22:45:44 eradicator Exp $
+
+ 15 Jun 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/creox-0.2.2_rc2-ebusy.patch:
+ Added to ~amd64. Stable x86. Added patch to fix nptl support.
13 Jun 2004; Jeremy Huddleston <eradicator@gentoo.org>
creox-0.2.2_rc2.ebuild:
diff --git a/media-sound/creox/Manifest b/media-sound/creox/Manifest
index 3be1224297a0..9872d284b486 100644
--- a/media-sound/creox/Manifest
+++ b/media-sound/creox/Manifest
@@ -1,4 +1,5 @@
-MD5 b4618021508fa3fb91971176ece617b9 ChangeLog 715
-MD5 ebd4fa8e092255e125be1b5511ab9490 creox-0.2.2_rc2.ebuild 563
+MD5 0c484fb44357ba2f12bdb11c9aebd02d ChangeLog 877
+MD5 7679abf41c68a6bd79f2cee67bb2b147 creox-0.2.2_rc2.ebuild 657
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 b4a14d554e1672d522b4030363f02999 files/digest-creox-0.2.2_rc2 67
+MD5 63cdddedab359f2b04ae837290c459e6 files/creox-0.2.2_rc2-ebusy.patch 3129
diff --git a/media-sound/creox/creox-0.2.2_rc2.ebuild b/media-sound/creox/creox-0.2.2_rc2.ebuild
index 5123369fcb03..3c18dcb75ba6 100644
--- a/media-sound/creox/creox-0.2.2_rc2.ebuild
+++ b/media-sound/creox/creox-0.2.2_rc2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/creox/creox-0.2.2_rc2.ebuild,v 1.4 2004/06/13 08:17:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/creox/creox-0.2.2_rc2.ebuild,v 1.5 2004/06/15 22:45:44 eradicator Exp $
-inherit kde
+inherit kde eutils
IUSE=""
@@ -13,9 +13,16 @@ DESCRIPTION="CREOX Real Time Effects Processor"
HOMEPAGE="http://www.uid0.sk/zyzstar/?creox"
SRC_URI="http://www.uid0.sk/zyzstar/projects/creox/downloads/${MY_P}.tar.bz2"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc ~amd64"
LICENSE="GPL-2"
need-kde 3
DEPEND="media-sound/jack-audio-connection-kit"
+
+src_unpack() {
+ kde_src_unpack
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-ebusy.patch
+}
diff --git a/media-sound/creox/files/creox-0.2.2_rc2-ebusy.patch b/media-sound/creox/files/creox-0.2.2_rc2-ebusy.patch
new file mode 100644
index 000000000000..7445e30a9610
--- /dev/null
+++ b/media-sound/creox/files/creox-0.2.2_rc2-ebusy.patch
@@ -0,0 +1,77 @@
+diff -Naur creox-0.2.2rc2.orig/creox/crthreadeventdispatcher.h creox-0.2.2rc2/creox/crthreadeventdispatcher.h
+--- creox-0.2.2rc2.orig/creox/crthreadeventdispatcher.h 2003-02-22 10:45:23.000000000 -0800
++++ creox-0.2.2rc2/creox/crthreadeventdispatcher.h 2004-06-15 15:30:40.477172272 -0700
+@@ -18,6 +18,7 @@
+ #define CRTHREADEVENTDISPATCHER_H
+
+ #include <pthread.h>
++#include <asm/errno.h>
+ #include <qobject.h>
+ #include <qevent.h>
+ #include "crexception.h"
+diff -Naur creox-0.2.2rc2.orig/creox/dsp_flow/threadeffector.h creox-0.2.2rc2/creox/dsp_flow/threadeffector.h
+--- creox-0.2.2rc2.orig/creox/dsp_flow/threadeffector.h 2003-03-02 13:12:17.000000000 -0800
++++ creox-0.2.2rc2/creox/dsp_flow/threadeffector.h 2004-06-15 15:30:40.478172105 -0700
+@@ -18,6 +18,7 @@
+ #define THREADEFFECTOR_H
+
+ #include <pthread.h>
++#include <asm/errno.h>
+ #include <string>
+ #include <jack/jack.h>
+ #include "crexception.h"
+diff -Naur creox-0.2.2rc2.orig/creox/effects_dsp/distortionprocessor.h creox-0.2.2rc2/creox/effects_dsp/distortionprocessor.h
+--- creox-0.2.2rc2.orig/creox/effects_dsp/distortionprocessor.h 2003-03-02 12:46:42.000000000 -0800
++++ creox-0.2.2rc2/creox/effects_dsp/distortionprocessor.h 2004-06-15 15:30:40.478172105 -0700
+@@ -18,6 +18,7 @@
+ #define DISTORTIONPROCESSOR_H
+
+ #include <pthread.h>
++#include <asm/errno.h>
+ #include "soundprocessor.h"
+
+ #define MAX_DISTORT_VALUE (65536)
+diff -Naur creox-0.2.2rc2.orig/creox/effects_dsp/echoprocessor.h creox-0.2.2rc2/creox/effects_dsp/echoprocessor.h
+--- creox-0.2.2rc2.orig/creox/effects_dsp/echoprocessor.h 2003-03-02 12:46:57.000000000 -0800
++++ creox-0.2.2rc2/creox/effects_dsp/echoprocessor.h 2004-06-15 15:30:40.479171938 -0700
+@@ -18,6 +18,7 @@
+ #define ECHOPROCESSOR_H
+
+ #include <pthread.h>
++#include <asm/errno.h>
+ #include "soundprocessor.h"
+
+ /**
+diff -Naur creox-0.2.2rc2.orig/creox/effects_dsp/flangerprocessor.h creox-0.2.2rc2/creox/effects_dsp/flangerprocessor.h
+--- creox-0.2.2rc2.orig/creox/effects_dsp/flangerprocessor.h 2003-09-16 11:59:43.000000000 -0700
++++ creox-0.2.2rc2/creox/effects_dsp/flangerprocessor.h 2004-06-15 15:30:40.480171770 -0700
+@@ -18,6 +18,7 @@
+ #define FLANGERPROCESSOR_H
+
+ #include <pthread.h>
++#include <asm/errno.h>
+ #include "soundprocessor.h"
+
+ /**
+diff -Naur creox-0.2.2rc2.orig/creox/effects_dsp/phaserprocessor.h creox-0.2.2rc2/creox/effects_dsp/phaserprocessor.h
+--- creox-0.2.2rc2.orig/creox/effects_dsp/phaserprocessor.h 2003-03-02 12:56:49.000000000 -0800
++++ creox-0.2.2rc2/creox/effects_dsp/phaserprocessor.h 2004-06-15 15:30:40.480171770 -0700
+@@ -18,6 +18,7 @@
+ #define PHASERPROCESSOR_H
+
+ #include <pthread.h>
++#include <asm/errno.h>
+ #include "soundprocessor.h"
+
+ /**
+diff -Naur creox-0.2.2rc2.orig/creox/effects_dsp/tremoloprocessor.h creox-0.2.2rc2/creox/effects_dsp/tremoloprocessor.h
+--- creox-0.2.2rc2.orig/creox/effects_dsp/tremoloprocessor.h 2003-03-02 13:07:35.000000000 -0800
++++ creox-0.2.2rc2/creox/effects_dsp/tremoloprocessor.h 2004-06-15 15:30:40.481171603 -0700
+@@ -18,6 +18,7 @@
+ #define TREMOLOPROCESSOR_H
+
+ #include <pthread.h>
++#include <asm/errno.h>
+ #include "soundprocessor.h"
+
+ /**