summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-07-20 13:49:00 +0000
committerCédric Krier <cedk@gentoo.org>2008-07-20 13:49:00 +0000
commitd2272f1bba02ca2cd562454125072a5e536417d0 (patch)
tree7257fbc2b78ca02c0a1f318221b0fa5f53370d07 /media-sound/chuck/chuck-1.2.1.2.ebuild
parentprevious commit replaced CXXFLAGS by CFLAGS by accident, thanks to RafaÅ‚ MuÅ... (diff)
downloadhistorical-d2272f1bba02ca2cd562454125072a5e536417d0.tar.gz
historical-d2272f1bba02ca2cd562454125072a5e536417d0.tar.bz2
historical-d2272f1bba02ca2cd562454125072a5e536417d0.zip
Version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'media-sound/chuck/chuck-1.2.1.2.ebuild')
-rw-r--r--media-sound/chuck/chuck-1.2.1.2.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/media-sound/chuck/chuck-1.2.1.2.ebuild b/media-sound/chuck/chuck-1.2.1.2.ebuild
new file mode 100644
index 000000000000..509557610f9a
--- /dev/null
+++ b/media-sound/chuck/chuck-1.2.1.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/chuck/chuck-1.2.1.2.ebuild,v 1.1 2008/07/20 13:49:00 cedk Exp $
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="Strongly-timed, Concurrent, and On-the-fly
+Audio Programming Language"
+HOMEPAGE="http://chuck.cs.princeton.edu/release/"
+SRC_URI="http://chuck.cs.princeton.edu/release/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="oss jack alsa examples"
+
+COMMON_DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ media-libs/libsndfile"
+RDEPEND="${COMMON_DEPEND}
+ app-admin/eselect"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+pkg_setup() {
+ local cnt=0
+ use jack && cnt="$((${cnt} + 1))"
+ use alsa && cnt="$((${cnt} + 1))"
+ use oss && cnt="$((${cnt} + 1))"
+ if [[ "${cnt}" -eq 0 ]] ; then
+ eerror "One of the following USE flags is needed: jack, alsa or oss"
+ die "Please set one audio engine type"
+ elif [[ "${cnt}" -ne 1 ]] ; then
+ ewarn "You have set ${P} to use multiple audio engine."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.2.1.1-hid-smc.patch"
+}
+
+src_compile() {
+ # when compile with athlon or athlon-xp flags
+ # chuck crashes on removing a shred with a double free or corruption
+ # it happens in Chuck_VM_Stack::shutdown() on the line
+ # SAFE_DELETE_ARRAY( stack );
+ replace-cpu-flags athlon athlon-xp i686
+
+ use jack && compile_backend jack
+ use alsa && compile_backend alsa
+ use oss && compile_backend oss
+}
+
+compile_backend() {
+ backend=$1
+ einfo "Compiling against ${backend}"
+ cd "${S}/src"
+ emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
+ mv chuck{,.${backend}}
+ emale -f "makefile.${backend}" clean
+}
+
+src_install() {
+ use jack && dobin src/chuck.jack
+ use alsa && dobin src/chuck.alsa
+ use oss && dobin src/chuck.oss
+
+ dodoc AUTHORS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
+ docinto doc
+ dodoc doc/*
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins `find examples -type f`
+ for dir in `find examples/* -type d`; do
+ insinto /usr/share/doc/${P}/$dir
+ doins $dir/*
+ done
+ fi
+
+ dodir /usr/share/eselect/modules
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}/chuck.eselect-0.1" chuck.eselect
+}
+
+pkg_postinst() {
+ elog "Chuck now can use many audio engines, so you can specify audio engine"
+ elog "with chuck.{jack,alsa,oss}"
+ elog "Or you can use 'eselect chuck' to set the audio engine"
+}