summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-21 23:06:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-21 23:06:09 +0000
commit369c502b4dc124db1efb2d06cf72c3e1c175ae47 (patch)
tree712e35c393860b8fca1d1577a52f95c302776d74 /media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild
parentarm/s390/sh stable (diff)
downloadhistorical-369c502b4dc124db1efb2d06cf72c3e1c175ae47.tar.gz
historical-369c502b4dc124db1efb2d06cf72c3e1c175ae47.tar.bz2
historical-369c502b4dc124db1efb2d06cf72c3e1c175ae47.zip
Add new revision, removing the SG_IO patches, that caused bugs #133145, #133150 and #138894. As upstream is not dead as it could have seemed, better stick as much as possible with upstream sources (although the current ones are also quite a bit patched). When new alpha will be added, patches *have to be* sent upstream.
Package-Manager: portage-2.1.2_pre3-r6
Diffstat (limited to 'media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild')
-rw-r--r--media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild b/media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild
new file mode 100644
index 000000000000..5c3ca8445911
--- /dev/null
+++ b/media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdparanoia/cdparanoia-3.9.8-r5.ebuild,v 1.1 2006/10/21 23:06:09 flameeyes Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="2.1"
+
+inherit eutils flag-o-matic libtool toolchain-funcs versionator autotools
+
+MY_P=${PN}-III-alpha$(get_version_component_range 2-3)
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="an advanced CDDA reader with error correction"
+HOMEPAGE="http://www.xiph.org/paranoia/"
+SRC_URI="http://www.xiph.org/paranoia/download/${MY_P}.src.tgz
+ mirror://gentoo/${P}-fbsd-2.patch.bz2"
+
+IUSE="kernel_linux"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # cdda_paranoia.h should include cdda_interface_h, else most configure
+ # scripts testing for support fails (gnome-vfs, etc).
+ epatch "${FILESDIR}/${P}-include-cdda_interface_h.patch"
+ epatch "${FILESDIR}/${P}-toc.patch"
+ epatch "${FILESDIR}/${P}-identify_crash.patch"
+ epatch "${FILESDIR}/${PV}-gcc34.patch"
+
+ # if libdir is specified, cdparanoia causes sandbox violations, and using
+ # einstall doesnt work around it. so lets patch in DESTDIR support
+ epatch "${FILESDIR}/${P}-use-destdir.patch"
+
+ epatch "${FILESDIR}/${P}-respectflags-pio.patch"
+
+ epatch "${DISTDIR}/${P}-fbsd-2.patch.bz2"
+ # Fix makefiles for parallel make
+ epatch "${FILESDIR}/${P}-parallel-fpic-fbsd.patch"
+
+ # Use directly the same exact patch as flex as it works
+ epatch "${FILESDIR}/flex-configure-LANG.patch"
+
+ # Let portage handle the stripping of binaries
+ sed -i -e "/strip cdparanoia/d" Makefile.in
+
+ # Fix Makefiles for parallel building. Bug #136128.
+ sed -i \
+ -e "s/^lib: $/lib: \$(OFILES)/" \
+ -e "s/^slib: $/slib: \$(OFILES)/" \
+ -e "/\$(MAKE) lessmessy$/d" \
+ interface/Makefile.in paranoia/Makefile.in
+
+ mv configure.guess config.guess
+ mv configure.sub config.sub
+ sed -i -e '/configure.\(guess\|sub\)/d' "${S}"/configure.in
+
+ eautoconf
+ elibtoolize
+}
+
+src_compile() {
+ tc-export CC AR RANLIB
+ append-flags -I"${S}/interface"
+
+ econf || die
+ emake OPT="${CFLAGS}" || die
+}
+
+src_install() {
+ dodir /usr/{bin,lib,include} /usr/share/man/man1
+ emake DESTDIR="${D}" install || die
+ dodoc FAQ.txt README
+}