summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-03-13 06:00:55 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-03-13 06:00:55 +0000
commit0f431dd61a5edb564e1872d7366715389a1c9b25 (patch)
tree3a57f48d7641a729feaf65ee43f0849b885f3351 /media-sound/bplay/bplay-0.991.ebuild
parentAdded USE dependent nls compilation (diff)
downloadhistorical-0f431dd61a5edb564e1872d7366715389a1c9b25.tar.gz
historical-0f431dd61a5edb564e1872d7366715389a1c9b25.tar.bz2
historical-0f431dd61a5edb564e1872d7366715389a1c9b25.zip
Bplay package provides simple tools for buffered recording and
playback of wave files. I find brec very useful for scripting. This is the first version of this ebuild.
Diffstat (limited to 'media-sound/bplay/bplay-0.991.ebuild')
-rw-r--r--media-sound/bplay/bplay-0.991.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-sound/bplay/bplay-0.991.ebuild b/media-sound/bplay/bplay-0.991.ebuild
new file mode 100644
index 000000000000..199f98e5f375
--- /dev/null
+++ b/media-sound/bplay/bplay-0.991.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Arcady Genkin <agenkin@thpoon.com>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/bplay/bplay-0.991.ebuild,v 1.1 2002/03/13 06:00:55 agenkin Exp $
+
+DESCRIPTION="No-frills command-line buffered player and recorder."
+HOMEPAGE="http://www.amberdata.demon.co.uk/bplay/"
+
+SRC_URI="http://www.amberdata.demon.co.uk/bplay/${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -Wall -DUSEBUFFLOCK" bplay || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe bplay
+ dosym /usr/bin/bplay /usr/bin/brec
+ doman bplay.1 brec.1
+ dodoc COPYING README
+}