summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-12 06:42:56 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-12 06:42:56 +0000
commit59cbad63ea59e5d66cf5662794ca9e966c0f967c (patch)
treeca00e01b0a2647bab61b2536dfc22f568af0c656 /media-sound/audacity
parentRemoved RDEPEND=${DEPEND} (diff)
downloadhistorical-59cbad63ea59e5d66cf5662794ca9e966c0f967c.tar.gz
historical-59cbad63ea59e5d66cf5662794ca9e966c0f967c.tar.bz2
historical-59cbad63ea59e5d66cf5662794ca9e966c0f967c.zip
Removed RDEPEND=${DEPEND}
Diffstat (limited to 'media-sound/audacity')
-rw-r--r--media-sound/audacity/audacity-1.0.0-r2.ebuild36
1 files changed, 13 insertions, 23 deletions
diff --git a/media-sound/audacity/audacity-1.0.0-r2.ebuild b/media-sound/audacity/audacity-1.0.0-r2.ebuild
index e15ddb59792f..2390afe995e0 100644
--- a/media-sound/audacity/audacity-1.0.0-r2.ebuild
+++ b/media-sound/audacity/audacity-1.0.0-r2.ebuild
@@ -1,34 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.0.0-r2.ebuild,v 1.3 2002/10/05 05:39:16 drobbins Exp $
-
-IUSE="oggvorbis"
-
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.0.0-r2.ebuild,v 1.4 2002/11/12 06:42:56 vapier Exp $
MY_P="${PN}-src-${PV}"
ID3V="id3lib-3.8.0"
-S=${WORKDIR}/${MY_P}
DESCRIPTION="A free, crossplatform audio editor."
SRC_URI="mirror://sourceforge/audacity/${MY_P}.tgz
mirror://sourceforge/id3lib/${ID3V}.tar.gz"
+HOMEPAGE="http://audacity.sourceforge.net/"
#the included id3lib breaks and I figure its better to
# update to stable than to attempt to hack the patch
# spider //
-HOMEPAGE="http://audacity.sourceforge.net/"
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="oggvorbis"
# doesn't compile with wxGTK-2.3.2
DEPEND="~x11-libs/wxGTK-2.2.9
oggvorbis? ( media-libs/libvorbis )
app-arch/zip"
-RDEPEND=${DEPEND}
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${MY_P}.tgz
@@ -40,38 +36,32 @@ src_unpack() {
rm -rf id3lib
mv ${ID3V} id3lib
-
-
# Only patch if using gcc 3.x
- if [ "`eval echo \`gcc -dumpversion\` | cut -f1 -d.`" -eq 3 ]
- then
+ if [ "`eval echo \`gcc -dumpversion\` | cut -f1 -d.`" -eq 3 ] ; then
cd ${WORKDIR}/audacity-src-${PV}/id3lib
# updated patch from id3lib
- pwd
- patch -p0 <${FILESDIR}/${ID3V}-gcc3.patch ||die "foo "
+ patch -p0 < ${FILESDIR}/${ID3V}-gcc3.patch || die "${ID3V}-gcc3.patch failed"
- # patch -p1 <${FILESDIR}/${P}-gcc31.patch || die
+ # patch -p1 <${FILESDIR}/${P}-gcc31.patch || die
fi
}
src_compile() {
- local myconf
- myconf="--with-id3"
+ local myconf="--with-id3"
+
use oggvorbis && myconf="${myconf} --with-vorbis"
# arts is broken! :(
# use arts && myconf="${myconf} --with-arts-soundserver"
cd ${WORKDIR}/audacity-src-1.0.0
- ./configure --prefix=/usr $myconf || die
-
- make || die
+ econf ${myconf}
+ make || die "make failed"
}
src_install () {
cd ${WORKDIR}/audacity-src-1.0.0
-
+
export PREFIX=${D}/usr
- make -e install || die
+ make -e install || die "make install failed"
}
-