summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Shattow <jnc@gentoo.org>2005-03-02 04:54:44 +0000
committerEric Shattow <jnc@gentoo.org>2005-03-02 04:54:44 +0000
commitdcd69e4159987f501cd83f07cfb89000625df30d (patch)
tree8c0927c40e08f6b75c75d43dd00174cfaf2d18d6 /media-sound/ardour/ardour-0.9_beta27.ebuild
parentNew version (diff)
downloadhistorical-dcd69e4159987f501cd83f07cfb89000625df30d.tar.gz
historical-dcd69e4159987f501cd83f07cfb89000625df30d.tar.bz2
historical-dcd69e4159987f501cd83f07cfb89000625df30d.zip
Version bump.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'media-sound/ardour/ardour-0.9_beta27.ebuild')
-rw-r--r--media-sound/ardour/ardour-0.9_beta27.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/ardour/ardour-0.9_beta27.ebuild b/media-sound/ardour/ardour-0.9_beta27.ebuild
new file mode 100644
index 000000000000..c7050257f8a4
--- /dev/null
+++ b/media-sound/ardour/ardour-0.9_beta27.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ardour/ardour-0.9_beta27.ebuild,v 1.1 2005/03/02 04:54:44 jnc Exp $
+
+inherit eutils
+
+DESCRIPTION="multi-track hard disk recording software"
+HOMEPAGE="http://ardour.org/"
+SRC_URI="http://ardour.org/releases/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="nls"
+
+RDEPEND="dev-util/pkgconfig
+ >=media-libs/liblrdf-0.3.6
+ >=media-sound/jack-audio-connection-kit-0.98.1
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=media-libs/libsndfile-1.0.4
+ sys-libs/gdbm
+ >=media-libs/ladspa-sdk-1.12
+ >=media-libs/libsamplerate-0.0.14
+ >=media-libs/liblrdf-0.3.1
+ >=dev-libs/libxml2-2.5.7
+ >=media-libs/libart_lgpl-2.3.16"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${P/_/}"
+
+src_compile() {
+ local myconf="--disable-dependency-tracking --enable-optimize --disable-ksi"
+
+ use nls || myconf="${myconf} --disable-nls"
+ econf ${myconf} || die "configure failed"
+
+ emake || die "parallel make failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ # Workaround for xorg bug concerning lucida fonts. bug 73056. (2004 Dec 3 eldad)
+ sed -e 's/lucida[^-]*-/helvetica-/' -i ${D}/etc/ardour/ardour_ui.rc
+
+ dodoc DOCUMENTATION/*
+}