summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2004-02-06 14:35:53 +0000
committerMax Kalika <max@gentoo.org>2004-02-06 14:35:53 +0000
commit5f69eed51b803bb91c91277174b1b377b975b006 (patch)
treea2eda643782031d38d98bd439b4d12f140047e77 /media-plugins
parentBump to version 1.4.1. (diff)
downloadhistorical-5f69eed51b803bb91c91277174b1b377b975b006.tar.gz
historical-5f69eed51b803bb91c91277174b1b377b975b006.tar.bz2
historical-5f69eed51b803bb91c91277174b1b377b975b006.zip
Ditch the postinst() message and don't attempt to install non-existant db files. Get rid of the alsa and lirc workarounds as they are no longer needed.
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mythdvd/ChangeLog6
-rw-r--r--media-plugins/mythdvd/Manifest4
-rw-r--r--media-plugins/mythdvd/mythdvd-0.14.ebuild48
-rw-r--r--media-plugins/mythgallery/Manifest4
-rw-r--r--media-plugins/mythgame/Manifest4
5 files changed, 19 insertions, 47 deletions
diff --git a/media-plugins/mythdvd/ChangeLog b/media-plugins/mythdvd/ChangeLog
index 386953049580..34879b5c5e60 100644
--- a/media-plugins/mythdvd/ChangeLog
+++ b/media-plugins/mythdvd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/mythdvd
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.8 2004/02/03 14:09:00 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.9 2004/02/06 14:35:53 max Exp $
+
+ 06 Feb 2004; Max Kalika <max@gentoo.org> mythdvd-0.14.ebuild:
+ Ditch the postinst() message and don't attempt to install non-existant db
+ files. Get rid of the alsa and lirc workarounds as they are no longer needed.
*mythdvd-0.14 (03 Feb 2004)
diff --git a/media-plugins/mythdvd/Manifest b/media-plugins/mythdvd/Manifest
index eb9d8b1267b2..475d1c4915b6 100644
--- a/media-plugins/mythdvd/Manifest
+++ b/media-plugins/mythdvd/Manifest
@@ -1,8 +1,8 @@
MD5 bdca7d5accce6ff791b81a2acc8b6df7 mythdvd-0.11.ebuild 1962
MD5 2dd8b7f31de6a77c3ed57ef51accbf87 mythdvd-0.13.ebuild 2374
MD5 7e81b395052da2d61bbae4268e107fef mythdvd-0.12.ebuild 2374
-MD5 6e2b92b8f53c498c10ca260ddf26db96 mythdvd-0.14.ebuild 2376
-MD5 8ee08598e8ac5a4b4d9f0394e7255d83 ChangeLog 978
+MD5 2c30ea3b65e1d25a109ada0814d1ed33 mythdvd-0.14.ebuild 1278
+MD5 5f1c0366a6977e4dc70026c6d8360ad8 ChangeLog 1198
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 29d1ec475eee7e6e4d5b6a605611c4c7 files/digest-mythdvd-0.11 64
MD5 43523be8d2e4958df76e6e1b2b63791c files/digest-mythdvd-0.12 65
diff --git a/media-plugins/mythdvd/mythdvd-0.14.ebuild b/media-plugins/mythdvd/mythdvd-0.14.ebuild
index 829395919a13..c0bb0030c8f4 100644
--- a/media-plugins/mythdvd/mythdvd-0.14.ebuild
+++ b/media-plugins/mythdvd/mythdvd-0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.14.ebuild,v 1.1 2004/02/03 13:51:53 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.14.ebuild,v 1.2 2004/02/06 14:35:53 max Exp $
inherit flag-o-matic
@@ -11,17 +11,17 @@ SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="alsa lirc transcode"
+IUSE="transcode"
-DEPEND="media-libs/libdvdread
- >=sys-apps/sed-4
+DEPEND=">=sys-apps/sed-4
>=media-plugins/mythvideo-${PV}
+ media-libs/libdvdread
transcode? ( media-video/transcode )
|| ( media-video/mplayer media-video/xine-ui media-video/ogle )
|| ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
src_unpack() {
- unpack ${A}
+ unpack ${A} && cd "${S}"
for i in `grep -lr "usr/local" "${S}"` ; do
sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
@@ -29,7 +29,8 @@ src_unpack() {
}
src_compile() {
- local myconf="--enable-vcd"
+ local myconf
+ myconf="--enable-vcd"
myconf="${myconf} `use_enable transcode`"
local cpu="`get-flag march || get-flag mcpu`"
@@ -39,44 +40,11 @@ src_compile() {
qmake -o "Makefile" "${PN}.pro"
- if [ "`use alsa`" ] ; then
- echo "CONFIG += using_alsa" >> settings.pro
- echo "EXTRA_LIBS += -lasound" >> settings.pro
- fi
- if [ "`use lirc`" ] ; then
- sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
- -e "s:#EXTRA_LIBS += -llirc_client:EXTRA_LIBS += -llirc_client:" \
- -i "settings.pro" || die "enable lirc sed failed"
- fi
-
econf ${myconf}
emake || die "compile problem"
}
src_install () {
einstall INSTALL_ROOT="${D}"
-
- insinto "/usr/share/mythtv/database/${PN}"
- doins dvddb/*.sql
-
- dodoc AUTHORS COPYING README UPGRADING
- newdoc dvddb/README README.db
-}
-
-pkg_postinst() {
- einfo "If this is the first time you install MythDVD,"
- einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
- einfo "to your MythTV database."
- einfo
- einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
- einfo
- einfo "If you're upgrading from an older version and for more"
- einfo "setup and usage instructions, please refer to:"
- einfo " /usr/share/doc/${PF}/README.gz"
- einfo " /usr/share/doc/${PF}/README.db.gz"
- einfo " /usr/share/doc/${PF}/UPGRADING.gz"
- ewarn "This part is important as there might be database changes"
- ewarn "which need to be performed or this package will not work"
- ewarn "properly."
- echo
+ dodoc AUTHORS COPYING README README-database UPGRADING
}
diff --git a/media-plugins/mythgallery/Manifest b/media-plugins/mythgallery/Manifest
index 590c9af7b050..4357036ad2e3 100644
--- a/media-plugins/mythgallery/Manifest
+++ b/media-plugins/mythgallery/Manifest
@@ -1,8 +1,8 @@
-MD5 8824eaefecb2a1ddcaf1b01646b33e41 mythgallery-0.14.ebuild 1731
+MD5 9abeebe9c3c4ca1c105759cee534c0fc mythgallery-0.14.ebuild 1120
MD5 ba206854f699cc17ed156eed8cac28e5 mythgallery-0.11.ebuild 1691
MD5 b474b37b70df35f655c1b838e53c5855 mythgallery-0.13.ebuild 1694
MD5 3656d3dd60d7e260d895dbc48c25c17f mythgallery-0.12.ebuild 1694
-MD5 4742fd8d29080de4024e42077cba54b5 ChangeLog 2372
+MD5 4822dd756fed5a0306de5b2ce850bd0a ChangeLog 2566
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 f367099e5641367ed71e682eed2243e5 files/digest-mythgallery-0.11 67
MD5 2ead189a9b4ae726aa0565a7f4d7a78f files/digest-mythgallery-0.12 68
diff --git a/media-plugins/mythgame/Manifest b/media-plugins/mythgame/Manifest
index 62a3082c420e..a0a032866a74 100644
--- a/media-plugins/mythgame/Manifest
+++ b/media-plugins/mythgame/Manifest
@@ -1,8 +1,8 @@
MD5 460b6a4bd044f61e7a12918894b083a8 mythgame-0.12.ebuild 1979
-MD5 6d3028e27c9825e49eafe99ec04f2599 mythgame-0.14.ebuild 1981
+MD5 ef51c10a6ac7b36963d9835e9614ceb2 mythgame-0.14.ebuild 1004
MD5 48e8b79e645e8f6bd87b5a82f2af177d mythgame-0.11.ebuild 1976
MD5 1bdcecbda5a923f58fb1b98217bda045 mythgame-0.13.ebuild 1979
-MD5 e35232a958260addaf4828ee05a4bd2b ChangeLog 2186
+MD5 e7d07a8241604475c270fd7e8b1056ca ChangeLog 2336
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 2bd60d4f779ab52e53d15145940b8946 files/digest-mythgame-0.11 65
MD5 ace6a7f7f30d271f0c3e7bb1ea4ea89b files/digest-mythgame-0.12 65