summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2012-04-07 19:08:48 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2012-04-07 19:08:48 +0000
commit2df6e2a4b4a7e8e7ac57cd3f8694ff6de6004d76 (patch)
treed40186a130c489dfb05aec25004acdff7ab369c5 /media-plugins
parentLowered dep to >=app-text/mupdf-1.0_rc1 (diff)
downloadhistorical-2df6e2a4b4a7e8e7ac57cd3f8694ff6de6004d76.tar.gz
historical-2df6e2a4b4a7e8e7ac57cd3f8694ff6de6004d76.tar.bz2
historical-2df6e2a4b4a7e8e7ac57cd3f8694ff6de6004d76.zip
compilefix >=vdr-1.7.27
Package-Manager: portage-2.1.10.11/cvs/Linux i686
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-text2skin/ChangeLog6
-rw-r--r--media-plugins/vdr-text2skin/files/vdr-1.7.27.diff94
-rw-r--r--media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild6
3 files changed, 104 insertions, 2 deletions
diff --git a/media-plugins/vdr-text2skin/ChangeLog b/media-plugins/vdr-text2skin/ChangeLog
index eae2ad88519a..d88d28ef5907 100644
--- a/media-plugins/vdr-text2skin/ChangeLog
+++ b/media-plugins/vdr-text2skin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-text2skin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-text2skin/ChangeLog,v 1.12 2012/01/15 19:31:24 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-text2skin/ChangeLog,v 1.13 2012/04/07 19:08:48 hd_brummy Exp $
+
+ 07 Apr 2012; Joerg Bornkessel <hd_brummy@gentoo.org>
+ vdr-text2skin-1.3.2.ebuild, +files/vdr-1.7.27.diff:
+ compilefix >=vdr-1.7.27
15 Jan 2012; Christian Ruppert <idl0r@gentoo.org> vdr-text2skin-1.2.ebuild,
vdr-text2skin-1.3.1.ebuild, vdr-text2skin-1.3.2.ebuild,
diff --git a/media-plugins/vdr-text2skin/files/vdr-1.7.27.diff b/media-plugins/vdr-text2skin/files/vdr-1.7.27.diff
new file mode 100644
index 000000000000..9d3280cf5849
--- /dev/null
+++ b/media-plugins/vdr-text2skin/files/vdr-1.7.27.diff
@@ -0,0 +1,94 @@
+diff -Naur text2skin-1.3.2.orig/display.c text2skin-1.3.2/display.c
+--- text2skin-1.3.2.orig/display.c 2012-04-07 20:45:11.000000000 +0200
++++ text2skin-1.3.2/display.c 2012-04-07 20:45:47.000000000 +0200
+@@ -1233,17 +1233,17 @@
+
+ case tRecordingPriority:
+ return mRecording != NULL
+- ? (cxType)mRecording->priority
++ ? (cxType)mRecording->Priority()
+ : (cxType)false;
+
+ case tRecordingLifetime:
+ return mRecording != NULL
+- ? (cxType)mRecording->lifetime
++ ? (cxType)mRecording->Lifetime()
+ : (cxType)false;
+
+ case tRecordingDateTime:
+ return mRecording != NULL
+- ? (cxType)TimeType(mRecording->start, Token.Attrib.Text)
++ ? (cxType)TimeType(mRecording->Start(), Token.Attrib.Text)
+ : (cxType)false;
+
+ case tRecordingTitle:
+diff -Naur text2skin-1.3.2.orig/render.c text2skin-1.3.2/render.c
+--- text2skin-1.3.2.orig/render.c 2012-04-07 20:45:11.000000000 +0200
++++ text2skin-1.3.2/render.c 2012-04-07 20:48:29.000000000 +0200
+@@ -597,14 +597,14 @@
+ if (Marks) {
+ bool start = true;
+ for (const cMark *m = Marks->First(); m; m = Marks->Next(m)) {
+- txPoint pt(Pos.x + m->position * Size.w / Total, Pos.y);
++ txPoint pt(Pos.x + m->Position() * Size.w / Total, Pos.y);
+ if (Selected && start) {
+ const cMark *m2 = Marks->Next(m);
+ DrawRectangle(txPoint(pt.x, Pos.y + Size.h / 3),
+- txSize(((m2 ? m2->position : Total) - m->position)
++ txSize(((m2 ? m2->Position() : Total) - m->Position())
+ * Size.w / Total + 1, Size.h - Size.h * 2 / 3 + 1), Selected);
+ }
+- DrawMark(pt, Size, start, m->position == Current, false, Mark, Cur);
++ DrawMark(pt, Size, start, m->Position() == Current, false, Mark, Cur);
+ start = !start;
+ }
+ }
+@@ -614,15 +614,15 @@
+ if (Marks) {
+ bool start = true;
+ for (const cMark *m = Marks->First(); m; m = Marks->Next(m)) {
+- txPoint pt(Pos.x, Pos.y + m->position * Size.h / Total);
++ txPoint pt(Pos.x, Pos.y + m->Position() * Size.h / Total);
+ if (Selected && start) {
+ const cMark *m2 = Marks->Next(m);
+ DrawRectangle(txPoint(Pos.x + Size.w / 3, pt.y),
+ txSize(Size.w - Size.w * 2 / 3 + 1,
+- ((m2 ? m2->position : Total) - m->position)
++ ((m2 ? m2->Position() : Total) - m->Position())
+ * Size.h / Total + 1), Selected);
+ }
+- DrawMark(pt, Size, start, m->position == Current, true, Mark, Cur);
++ DrawMark(pt, Size, start, m->Position() == Current, true, Mark, Cur);
+ start = !start;
+ }
+ }
+diff -Naur text2skin-1.3.2.orig/common.c text2skin-1.3.2/common.c
+--- text2skin-1.3.2.orig/common.c 2012-04-07 20:54:59.000000000 +0200
++++ text2skin-1.3.2/common.c 2012-04-07 20:56:00.000000000 +0200
+@@ -255,11 +255,11 @@
+ int start = 1; // first frame
+ bool isStart = true;
+
+- for (cMark *m = marks.First(); m; m = marks.GetNext(m->position)) {
++ for (cMark *m = marks.First(); m; m = marks.GetNext(m->Position())) {
+ if (isStart)
+- start = m->position;
++ start = m->Position();
+ else
+- length += (double)(m->position - start + 1 + diffIFrame) / (60 * FramesPerSecond); // [min]
++ length += (double)(m->Position() - start + 1 + diffIFrame) / (60 * FramesPerSecond); // [min]
+
+ isStart = !isStart;
+ }
+diff -Naur text2skin-1.3.2.orig/status.c text2skin-1.3.2/status.c
+--- text2skin-1.3.2.orig/status.c 2012-04-07 20:59:39.000000000 +0200
++++ text2skin-1.3.2/status.c 2012-04-07 21:01:12.000000000 +0200
+@@ -314,7 +314,7 @@
+
+ case tReplayDateTime:
+ return mReplay != NULL
+- ? (cxType)TimeType(mReplay->start, Token.Attrib.Text)
++ ? (cxType)TimeType(mReplay->Start(), Token.Attrib.Text)
+ : (cxType)false;
+
+ case tReplayShortText:
diff --git a/media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild b/media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild
index d1c2219ff1f3..aad7efaa3d8e 100644
--- a/media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild
+++ b/media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild,v 1.2 2012/01/15 19:31:24 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-text2skin/vdr-text2skin-1.3.2.ebuild,v 1.3 2012/04/07 19:08:48 hd_brummy Exp $
EAPI="4"
@@ -58,6 +58,10 @@ src_prepare() {
fi
vdr-plugin_src_prepare
+
+ if has_version ">=media-video/vdr-1.7.27"; then
+ epatch "${FILESDIR}/vdr-1.7.27.diff"
+ fi
}
src_install() {