summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2004-07-15 21:25:43 +0000
committerTom Martin <slarti@gentoo.org>2004-07-15 21:25:43 +0000
commit25d16cd3b3e86fe8212c5319337d579be7fb7166 (patch)
tree68bcedeb9959e93fec2cbc66c5bee52a2082570f /media-plugins/xmms-synaesthesia
parentbug #57224, don't call gnuconfig a bazillion times (diff)
downloadhistorical-25d16cd3b3e86fe8212c5319337d579be7fb7166.tar.gz
historical-25d16cd3b3e86fe8212c5319337d579be7fb7166.tar.bz2
historical-25d16cd3b3e86fe8212c5319337d579be7fb7166.zip
Bad patch -> fixed.
Diffstat (limited to 'media-plugins/xmms-synaesthesia')
-rw-r--r--media-plugins/xmms-synaesthesia/ChangeLog6
-rw-r--r--media-plugins/xmms-synaesthesia/Manifest4
-rw-r--r--media-plugins/xmms-synaesthesia/files/xmms-synaesthesia-0.0.3_rc3-amd64.patch178
3 files changed, 96 insertions, 92 deletions
diff --git a/media-plugins/xmms-synaesthesia/ChangeLog b/media-plugins/xmms-synaesthesia/ChangeLog
index a9d931f3cdc5..1caccba9aaf7 100644
--- a/media-plugins/xmms-synaesthesia/ChangeLog
+++ b/media-plugins/xmms-synaesthesia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/xmms-synaesthesia
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-synaesthesia/ChangeLog,v 1.7 2004/07/15 19:45:54 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-synaesthesia/ChangeLog,v 1.8 2004/07/15 21:25:43 slarti Exp $
+
+ 15 Jul 2004; Tom Martin <slarti@gentoo.org>
+ files/xmms-synaesthesia-0.0.3_rc3-amd64.patch:
+ Fixed the patch.
15 Jul 2004; Tom Martin <slarti@gentoo.org>
xmms-synaesthesia-0.0.3_rc3.ebuild:
diff --git a/media-plugins/xmms-synaesthesia/Manifest b/media-plugins/xmms-synaesthesia/Manifest
index 668d6bc99f2f..9224df837996 100644
--- a/media-plugins/xmms-synaesthesia/Manifest
+++ b/media-plugins/xmms-synaesthesia/Manifest
@@ -1,6 +1,6 @@
MD5 22e2feb1c5c739a656aac1820f62aa70 xmms-synaesthesia-0.0.3_rc3.ebuild 830
-MD5 5091e41ea200a0e76ce264f6e4bae72f ChangeLog 1078
+MD5 77b599a91bc62736a425b0baa0996fee ChangeLog 1193
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
MD5 859fafdcac4022b35eca555e692a64d1 files/xmms-synaesthesia-0.0.3_rc3-gcc34.patch 4218
MD5 7ba67c996535a47c1b9e0136f01a631f files/digest-xmms-synaesthesia-0.0.3_rc3 79
-MD5 48d67bb25da4c30e41705154ded8c5b8 files/xmms-synaesthesia-0.0.3_rc3-amd64.patch 4705
+MD5 3981baf76e4c63e1a2120828475f757d files/xmms-synaesthesia-0.0.3_rc3-amd64.patch 4703
diff --git a/media-plugins/xmms-synaesthesia/files/xmms-synaesthesia-0.0.3_rc3-amd64.patch b/media-plugins/xmms-synaesthesia/files/xmms-synaesthesia-0.0.3_rc3-amd64.patch
index f46c42f22c83..96e15cad0bac 100644
--- a/media-plugins/xmms-synaesthesia/files/xmms-synaesthesia-0.0.3_rc3-amd64.patch
+++ b/media-plugins/xmms-synaesthesia/files/xmms-synaesthesia-0.0.3_rc3-amd64.patch
@@ -1,179 +1,179 @@
---- syna_core.c.orig 2004-07-15 17:31:40.375165032 +0100
-+++ syna_core.c 2001-04-26 21:46:13.000000000 +0100
-@@ -150,20 +150,17 @@
+--- syna_core.c.orig 2004-07-15 22:18:39.666434864 +0100
++++ syna_core.c 2004-07-15 22:19:19.330405024 +0100
+@@ -150,17 +150,20 @@
static void fadeFade()
{
-- register unsigned int *ptr = (unsigned int *) output;
-+ register unsigned long *ptr = (unsigned long *) output;
+- register unsigned long *ptr = (unsigned long *) output;
++ register unsigned int *ptr = (unsigned int *) output;
int i = outWidth * outHeight * 2 / 4;
do
{
/* //Bytewize version was: *(ptr++) -= *ptr+(*ptr>>1)>>4;*/
if (*ptr)
-- {
++ {
/* //if (*ptr & 0xf0f0f0f0ul)*/
-- *(ptr) -=
-+ *(ptr++) -=
+- *(ptr++) -=
++ *(ptr) -=
((*ptr & 0xf0f0f0f0ul) >> 4) +
((*ptr & 0xe0e0e0e0ul) >> 5);
-- ptr++;
-- }
++ ptr++;
++ }
/* //else {
// *(ptr++) = (*ptr * 14 >> 4) & 0x0f0f0f0ful;
//}*/
-@@ -206,13 +203,9 @@
+@@ -203,9 +206,13 @@
gint x, y, i, j, start, end;
gint step = outWidth * 2;
-- synx_output[2]=synx_output[1];
-- synx_output[1]=synx_output[0];
-- synx_output[0]=t;
--
--// lastLastOutput = lastOutput;
--// lastOutput = output;
--// output = t;
-+ lastLastOutput = lastOutput;
-+ lastOutput = output;
-+ output = t;
+- lastLastOutput = lastOutput;
+- lastOutput = output;
+- output = t;
++ synx_output[2]=synx_output[1];
++ synx_output[1]=synx_output[0];
++ synx_output[0]=t;
++
++// lastLastOutput = lastOutput;
++// lastOutput = output;
++// output = t;
for (x = 0, i = 0, j = outWidth * (outHeight - 1) * 2; x < outWidth; x++, i += 2, j += 2)
{
-@@ -280,18 +273,13 @@
+@@ -273,13 +280,18 @@
static void fadeHeat()
{
--// guint16 *t = (guint16 *) lastLastOutput;
-- guint16 *t=synx_output[2];
-+ guint16 *t = (guint16 *) lastLastOutput;
+- guint16 *t = (guint16 *) lastLastOutput;
++// guint16 *t = (guint16 *) lastLastOutput;
++ guint16 *t=synx_output[2];
gint x, y, i, j, start, end;
gint step = outWidth * 2;
-- synx_output[2]=synx_output[1];
-- synx_output[1]=synx_output[0];
-- synx_output[0]=t;
--
--// lastLastOutput = lastOutput;
--// lastOutput = output;
--// output = t;
-+ lastLastOutput = lastOutput;
-+ lastOutput = output;
-+ output = t;
+- lastLastOutput = lastOutput;
+- lastOutput = output;
+- output = t;
++ synx_output[2]=synx_output[1];
++ synx_output[1]=synx_output[0];
++ synx_output[0]=t;
++
++// lastLastOutput = lastOutput;
++// lastOutput = output;
++// output = t;
for (x = 0, i = 0, j = outWidth * (outHeight - 1) * 2; x < outWidth; x++, i += 2, j += 2)
{
---- syna_xmms.c.orig 2004-07-15 17:31:47.527077776 +0100
-+++ syna_xmms.c 2004-07-15 20:01:25.380236640 +0100
-@@ -20,8 +20,6 @@
+--- syna_xmms.c.orig 2004-07-15 21:56:12.813187680 +0100
++++ syna_xmms.c 2004-07-15 22:19:29.203904024 +0100
+@@ -20,6 +20,8 @@
#include <gdk/gdkkeysyms.h>
#include <pthread.h>
#include <string.h>
--#include <stdlib.h>
--#include <string.h>
++#include <stdlib.h>
++#include <string.h>
#include "math.h"
#include <xmms/plugin.h>
#include <xmms/util.h>
-@@ -287,7 +285,6 @@
+@@ -285,6 +287,7 @@
case SYNX_MENU_FULLSCRN:
synx_fullscreen_toggle();
break;
-- break;
++ break;
default:
break;
/* ugh */
-@@ -388,32 +385,22 @@
+@@ -385,22 +388,32 @@
gdk_draw_pixmap(area->window, area->style->white_gc, bg_pixmap, 0, 0, (win_w-LOGO_OWIDTH)/2, (win_h-LOGO_OHEIGHT)/2, LOGO_WIDTH, LOGO_HEIGHT);
}
--static void *synx_main_thread(void *arg)
--{
-- guchar *tmpscr=NULL;
-- int cursize=0;
-+static void *synx_main_thread(void *arg) {
+-static void *synx_main_thread(void *arg) {
++static void *synx_main_thread(void *arg)
++{
++ guchar *tmpscr=NULL;
++ int cursize=0;
/* I don't care about lost conditions, darn it! */
pthread_mutex_lock(&dummy_mutex);
-- for (;;)
-- {
-+ for (;;) {
+- for (;;) {
++ for (;;)
++ {
pthread_cond_wait(&update_signal, &dummy_mutex);
if (synx_quit) break;
GDK_THREADS_ENTER();
SYNX_LOCK();
-- if (GTK_WIDGET_REALIZED(window))
-- {
--// guchar tmpscr[synx_img_w*synx_img_h]; /* FIXME: Probably GCC-specific. */
-- if((tmpscr==NULL)||(cursize!=(synx_img_w*synx_img_h)))
-- {
-- tmpscr=(guchar *)realloc(tmpscr,synx_img_w*synx_img_h);
-- cursize=synx_img_w*synx_img_h;
-- memset(tmpscr,0x80,cursize);
-- }
-+ if (GTK_WIDGET_REALIZED(window)) {
-+ guchar tmpscr[synx_img_w*synx_img_h]; /* FIXME: Probably GCC-specific. */
+- if (GTK_WIDGET_REALIZED(window)) {
+- guchar tmpscr[synx_img_w*synx_img_h]; /* FIXME: Probably GCC-specific. */
++ if (GTK_WIDGET_REALIZED(window))
++ {
++// guchar tmpscr[synx_img_w*synx_img_h]; /* FIXME: Probably GCC-specific. */
++ if((tmpscr==NULL)||(cursize!=(synx_img_w*synx_img_h)))
++ {
++ tmpscr=(guchar *)realloc(tmpscr,synx_img_w*synx_img_h);
++ cursize=synx_img_w*synx_img_h;
++ memset(tmpscr,0x80,cursize);
++ }
syna_fade();
syna_coreGo(pcm_data);
-+
+-
synx_screenShow(synx_output[0], tmpscr);
gdk_draw_indexed_image(area->window,area->style->white_gc,(win_w-synx_img_w)/2,(win_h-synx_img_h)/2,synx_img_w,synx_img_h,GDK_RGB_DITHER_NONE,tmpscr,synx_img_w,cmap);
}
-@@ -421,9 +408,6 @@
+@@ -408,6 +421,9 @@
GDK_THREADS_LEAVE();
}
-- if(tmpscr!=NULL)
-- free(tmpscr);
--
++ if(tmpscr!=NULL)
++ free(tmpscr);
++
pthread_mutex_unlock(&dummy_mutex);
pthread_exit(NULL);
-@@ -496,19 +480,16 @@
+@@ -480,16 +496,19 @@
SYNX_UNLOCK();
}
--static void synx_playback_start(void)
--{
-+static void synx_playback_start(void) {
+-static void synx_playback_start(void) {
++static void synx_playback_start(void)
++{
SYNX_LOCK();
synx_playing = TRUE;
-- if (GTK_WIDGET_REALIZED(window) && synx_cfg.auto_fullscreen)
-- {
-+ if (GTK_WIDGET_REALIZED(window) && synx_cfg.auto_fullscreen) {
+- if (GTK_WIDGET_REALIZED(window) && synx_cfg.auto_fullscreen) {
++ if (GTK_WIDGET_REALIZED(window) && synx_cfg.auto_fullscreen)
++ {
if (!synx_am_fullscreen) synx_fullscreen_toggle();
}
SYNX_UNLOCK();
}
--static void synx_playback_stop(void)
--{
-+static void synx_playback_stop(void) {
+-static void synx_playback_stop(void) {
++static void synx_playback_stop(void)
++{
SYNX_LOCK();
synx_playing = FALSE;
-@@ -522,10 +503,9 @@
+@@ -503,9 +522,10 @@
SYNX_UNLOCK();
}
--static void synx_screenShow(guint16 *src, unsigned char *dest)
--{
-- register unsigned int *ptr2 = (unsigned int*)src;
-- unsigned int *ptr1 = (unsigned int*)dest;
-+static void synx_screenShow(guint16 *src, unsigned char *dest) {
-+ register unsigned long *ptr2 = (unsigned long*)src;
-+ unsigned long *ptr1 = (unsigned long*)dest;
+-static void synx_screenShow(guint16 *src, unsigned char *dest) {
+- register unsigned long *ptr2 = (unsigned long*)src;
+- unsigned long *ptr1 = (unsigned long*)dest;
++static void synx_screenShow(guint16 *src, unsigned char *dest)
++{
++ register unsigned int *ptr2 = (unsigned int*)src;
++ unsigned int *ptr1 = (unsigned int*)dest;
int i = synx_img_w*synx_img_h/4;
/* Asger Alstrup Nielsen's (alstrup@diku.dk)
-@@ -583,8 +563,7 @@
+@@ -563,7 +583,8 @@
}
}
--static void synx_about(void)
--{
-+static void synx_about(void) {
+-static void synx_about(void) {
++static void synx_about(void)
++{
GtkWidget *dialog, *button, *label;
dialog = gtk_dialog_new();