summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2004-07-15 19:45:54 +0000
committerTom Martin <slarti@gentoo.org>2004-07-15 19:45:54 +0000
commit24dd7162d399763fd7c86b183b213420dce43af0 (patch)
tree0d6540a76d8fe0d384035894366fd1b732083e21 /media-plugins/xmms-synaesthesia
parentMPlayer and transcode inline fix - bug #57202. (diff)
downloadhistorical-24dd7162d399763fd7c86b183b213420dce43af0.tar.gz
historical-24dd7162d399763fd7c86b183b213420dce43af0.tar.bz2
historical-24dd7162d399763fd7c86b183b213420dce43af0.zip
Marked ~amd64, added a patch from Tyler Montbriand. Closing 54937.
Diffstat (limited to 'media-plugins/xmms-synaesthesia')
-rw-r--r--media-plugins/xmms-synaesthesia/ChangeLog7
-rw-r--r--media-plugins/xmms-synaesthesia/Manifest7
-rw-r--r--media-plugins/xmms-synaesthesia/files/xmms-synaesthesia-0.0.3_rc3-amd64.patch179
-rw-r--r--media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3.ebuild7
4 files changed, 192 insertions, 8 deletions
diff --git a/media-plugins/xmms-synaesthesia/ChangeLog b/media-plugins/xmms-synaesthesia/ChangeLog
index 0aeaa029c41c..a9d931f3cdc5 100644
--- a/media-plugins/xmms-synaesthesia/ChangeLog
+++ b/media-plugins/xmms-synaesthesia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/xmms-synaesthesia
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-synaesthesia/ChangeLog,v 1.6 2004/07/07 21:36:50 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-synaesthesia/ChangeLog,v 1.7 2004/07/15 19:45:54 slarti Exp $
+
+ 15 Jul 2004; Tom Martin <slarti@gentoo.org>
+ xmms-synaesthesia-0.0.3_rc3.ebuild:
+ Added amd64 patches, thanks to Tyler Montbriand <tsm@accesscomm.ca> in bug
+ 54937. Added ~amd64 keyword.
07 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
+files/xmms-synaesthesia-0.0.3_rc3-gcc34.patch:
diff --git a/media-plugins/xmms-synaesthesia/Manifest b/media-plugins/xmms-synaesthesia/Manifest
index 40bdfdb105a6..668d6bc99f2f 100644
--- a/media-plugins/xmms-synaesthesia/Manifest
+++ b/media-plugins/xmms-synaesthesia/Manifest
@@ -1,5 +1,6 @@
-MD5 8ee7c93f7e3fe83fa06dc70bc38bce73 ChangeLog 889
+MD5 22e2feb1c5c739a656aac1820f62aa70 xmms-synaesthesia-0.0.3_rc3.ebuild 830
+MD5 5091e41ea200a0e76ce264f6e4bae72f ChangeLog 1078
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-MD5 406cc3d3d62b1416189ffa23dd8d35a8 xmms-synaesthesia-0.0.3_rc3.ebuild 838
-MD5 7ba67c996535a47c1b9e0136f01a631f files/digest-xmms-synaesthesia-0.0.3_rc3 79
MD5 859fafdcac4022b35eca555e692a64d1 files/xmms-synaesthesia-0.0.3_rc3-gcc34.patch 4218
+MD5 7ba67c996535a47c1b9e0136f01a631f files/digest-xmms-synaesthesia-0.0.3_rc3 79
+MD5 48d67bb25da4c30e41705154ded8c5b8 files/xmms-synaesthesia-0.0.3_rc3-amd64.patch 4705
diff --git a/media-plugins/xmms-synaesthesia/files/xmms-synaesthesia-0.0.3_rc3-amd64.patch b/media-plugins/xmms-synaesthesia/files/xmms-synaesthesia-0.0.3_rc3-amd64.patch
new file mode 100644
index 000000000000..f46c42f22c83
--- /dev/null
+++ b/media-plugins/xmms-synaesthesia/files/xmms-synaesthesia-0.0.3_rc3-amd64.patch
@@ -0,0 +1,179 @@
+--- syna_core.c.orig 2004-07-15 17:31:40.375165032 +0100
++++ syna_core.c 2001-04-26 21:46:13.000000000 +0100
+@@ -150,20 +150,17 @@
+
+ static void fadeFade()
+ {
+- register unsigned int *ptr = (unsigned int *) output;
++ register unsigned long *ptr = (unsigned long *) output;
+ int i = outWidth * outHeight * 2 / 4;
+
+ do
+ {
+ /* //Bytewize version was: *(ptr++) -= *ptr+(*ptr>>1)>>4;*/
+ if (*ptr)
+- {
+ /* //if (*ptr & 0xf0f0f0f0ul)*/
+- *(ptr) -=
++ *(ptr++) -=
+ ((*ptr & 0xf0f0f0f0ul) >> 4) +
+ ((*ptr & 0xe0e0e0e0ul) >> 5);
+- ptr++;
+- }
+ /* //else {
+ // *(ptr++) = (*ptr * 14 >> 4) & 0x0f0f0f0ful;
+ //}*/
+@@ -206,13 +203,9 @@
+ gint x, y, i, j, start, end;
+ gint step = outWidth * 2;
+
+- synx_output[2]=synx_output[1];
+- synx_output[1]=synx_output[0];
+- synx_output[0]=t;
+-
+-// lastLastOutput = lastOutput;
+-// lastOutput = output;
+-// output = t;
++ lastLastOutput = lastOutput;
++ lastOutput = output;
++ output = t;
+
+ for (x = 0, i = 0, j = outWidth * (outHeight - 1) * 2; x < outWidth; x++, i += 2, j += 2)
+ {
+@@ -280,18 +273,13 @@
+
+ static void fadeHeat()
+ {
+-// guint16 *t = (guint16 *) lastLastOutput;
+- guint16 *t=synx_output[2];
++ guint16 *t = (guint16 *) lastLastOutput;
+ gint x, y, i, j, start, end;
+ gint step = outWidth * 2;
+
+- synx_output[2]=synx_output[1];
+- synx_output[1]=synx_output[0];
+- synx_output[0]=t;
+-
+-// lastLastOutput = lastOutput;
+-// lastOutput = output;
+-// output = t;
++ lastLastOutput = lastOutput;
++ lastOutput = output;
++ output = t;
+
+ for (x = 0, i = 0, j = outWidth * (outHeight - 1) * 2; x < outWidth; x++, i += 2, j += 2)
+ {
+--- syna_xmms.c.orig 2004-07-15 17:31:47.527077776 +0100
++++ syna_xmms.c 2004-07-15 20:01:25.380236640 +0100
+@@ -20,8 +20,6 @@
+ #include <gdk/gdkkeysyms.h>
+ #include <pthread.h>
+ #include <string.h>
+-#include <stdlib.h>
+-#include <string.h>
+ #include "math.h"
+ #include <xmms/plugin.h>
+ #include <xmms/util.h>
+@@ -287,7 +285,6 @@
+ case SYNX_MENU_FULLSCRN:
+ synx_fullscreen_toggle();
+ break;
+- break;
+ default:
+ break;
+ /* ugh */
+@@ -388,32 +385,22 @@
+ gdk_draw_pixmap(area->window, area->style->white_gc, bg_pixmap, 0, 0, (win_w-LOGO_OWIDTH)/2, (win_h-LOGO_OHEIGHT)/2, LOGO_WIDTH, LOGO_HEIGHT);
+ }
+
+-static void *synx_main_thread(void *arg)
+-{
+- guchar *tmpscr=NULL;
+- int cursize=0;
++static void *synx_main_thread(void *arg) {
+ /* I don't care about lost conditions, darn it! */
+ pthread_mutex_lock(&dummy_mutex);
+
+- for (;;)
+- {
++ for (;;) {
+ pthread_cond_wait(&update_signal, &dummy_mutex);
+ if (synx_quit) break;
+
+ GDK_THREADS_ENTER();
+ SYNX_LOCK();
+- if (GTK_WIDGET_REALIZED(window))
+- {
+-// guchar tmpscr[synx_img_w*synx_img_h]; /* FIXME: Probably GCC-specific. */
+- if((tmpscr==NULL)||(cursize!=(synx_img_w*synx_img_h)))
+- {
+- tmpscr=(guchar *)realloc(tmpscr,synx_img_w*synx_img_h);
+- cursize=synx_img_w*synx_img_h;
+- memset(tmpscr,0x80,cursize);
+- }
++ if (GTK_WIDGET_REALIZED(window)) {
++ guchar tmpscr[synx_img_w*synx_img_h]; /* FIXME: Probably GCC-specific. */
+
+ syna_fade();
+ syna_coreGo(pcm_data);
++
+ synx_screenShow(synx_output[0], tmpscr);
+ gdk_draw_indexed_image(area->window,area->style->white_gc,(win_w-synx_img_w)/2,(win_h-synx_img_h)/2,synx_img_w,synx_img_h,GDK_RGB_DITHER_NONE,tmpscr,synx_img_w,cmap);
+ }
+@@ -421,9 +408,6 @@
+ GDK_THREADS_LEAVE();
+ }
+
+- if(tmpscr!=NULL)
+- free(tmpscr);
+-
+ pthread_mutex_unlock(&dummy_mutex);
+
+ pthread_exit(NULL);
+@@ -496,19 +480,16 @@
+ SYNX_UNLOCK();
+ }
+
+-static void synx_playback_start(void)
+-{
++static void synx_playback_start(void) {
+ SYNX_LOCK();
+ synx_playing = TRUE;
+- if (GTK_WIDGET_REALIZED(window) && synx_cfg.auto_fullscreen)
+- {
++ if (GTK_WIDGET_REALIZED(window) && synx_cfg.auto_fullscreen) {
+ if (!synx_am_fullscreen) synx_fullscreen_toggle();
+ }
+ SYNX_UNLOCK();
+ }
+
+-static void synx_playback_stop(void)
+-{
++static void synx_playback_stop(void) {
+ SYNX_LOCK();
+ synx_playing = FALSE;
+
+@@ -522,10 +503,9 @@
+ SYNX_UNLOCK();
+ }
+
+-static void synx_screenShow(guint16 *src, unsigned char *dest)
+-{
+- register unsigned int *ptr2 = (unsigned int*)src;
+- unsigned int *ptr1 = (unsigned int*)dest;
++static void synx_screenShow(guint16 *src, unsigned char *dest) {
++ register unsigned long *ptr2 = (unsigned long*)src;
++ unsigned long *ptr1 = (unsigned long*)dest;
+ int i = synx_img_w*synx_img_h/4;
+
+ /* Asger Alstrup Nielsen's (alstrup@diku.dk)
+@@ -583,8 +563,7 @@
+ }
+ }
+
+-static void synx_about(void)
+-{
++static void synx_about(void) {
+ GtkWidget *dialog, *button, *label;
+
+ dialog = gtk_dialog_new();
diff --git a/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3.ebuild b/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3.ebuild
index 39fdcf06e9c2..381eb71282fc 100644
--- a/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3.ebuild
+++ b/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3.ebuild,v 1.6 2004/07/07 21:36:50 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3.ebuild,v 1.7 2004/07/15 19:45:54 slarti Exp $
IUSE=""
@@ -18,13 +18,13 @@ RDEPEND=""
SLOT="0"
LICENSE="GPL-2"
-#-amd64: 0.0.3_rc3: enabling causes xmms to segfault
-KEYWORDS="x86 ~ppc ~sparc -amd64"
+KEYWORDS="x86 ~ppc ~sparc ~amd64"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gcc34.patch
+ use amd64 && epatch ${FILESDIR}/${P}-amd64.patch
gnuconfig_update
}
@@ -32,4 +32,3 @@ src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog NEWS README
}
-