summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-11-12 19:32:16 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-11-12 19:32:16 +0000
commit2b5596e16d9591fa975952c3dfd2fe590c7d233e (patch)
tree8b669b14055996a78ae4b0b6387bbca09ce92af2 /media-plugins/xmms-speex/xmms-speex-0.9.1.ebuild
parentUpdate DEPEND .. we need later binutils. Also update gcc and gcc-config depe... (diff)
downloadhistorical-2b5596e16d9591fa975952c3dfd2fe590c7d233e.tar.gz
historical-2b5596e16d9591fa975952c3dfd2fe590c7d233e.tar.bz2
historical-2b5596e16d9591fa975952c3dfd2fe590c7d233e.zip
New Package. Thanks to all people involved on bug #60542. Added two patches made by me to fix build on amd64 and add utf8 support.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'media-plugins/xmms-speex/xmms-speex-0.9.1.ebuild')
-rw-r--r--media-plugins/xmms-speex/xmms-speex-0.9.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/xmms-speex/xmms-speex-0.9.1.ebuild b/media-plugins/xmms-speex/xmms-speex-0.9.1.ebuild
new file mode 100644
index 000000000000..18f1560cbcb3
--- /dev/null
+++ b/media-plugins/xmms-speex/xmms-speex-0.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-speex/xmms-speex-0.9.1.ebuild,v 1.1 2005/11/12 19:32:16 metalgod Exp $
+
+inherit eutils
+
+IUSE=""
+
+MY_P=speex-xmms-${PV}
+S=${WORKDIR}/speex-xmms
+DESCRIPTION="Speex plugin for XMMS"
+HOMEPAGE="http://jzb.rapanden.dk/projects/speex-xmms"
+SRC_URI="http://jzb.rapanden.dk/pub/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-sound/xmms"
+DEPEND="${RDEPEND}
+ >=media-libs/libogg-1.1
+ <=media-libs/speex-1.1.5
+ >=x11-libs/gtk+-1.2.10-r11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PF}.patch
+ epatch ${FILESDIR}/${P}-Makefile.patch
+ epatch ${FILESDIR}/${P}-fPIC.patch
+}
+
+src_install() {
+ exeinto `xmms-config --input-plugin-dir`
+ doexe libspeex.so || die
+ dodoc COPYING README
+}