summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-31 16:35:16 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-31 16:35:16 +0000
commit0e90f91a89e680e9b97af714d7905e308fb6531b (patch)
tree995e5a404b016860b6e8213e62154d68fe48c685 /media-plugins/xmms-itouch
parentxmms plugin for keyboard input (diff)
downloadhistorical-0e90f91a89e680e9b97af714d7905e308fb6531b.tar.gz
historical-0e90f91a89e680e9b97af714d7905e308fb6531b.tar.bz2
historical-0e90f91a89e680e9b97af714d7905e308fb6531b.zip
xmms plugin for keyboard input
Diffstat (limited to 'media-plugins/xmms-itouch')
-rw-r--r--media-plugins/xmms-itouch/ChangeLog5
-rw-r--r--media-plugins/xmms-itouch/files/digest-xmms-itouch-0.1.21
-rw-r--r--media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild38
3 files changed, 42 insertions, 2 deletions
diff --git a/media-plugins/xmms-itouch/ChangeLog b/media-plugins/xmms-itouch/ChangeLog
index 1f1a012886f6..113df6d94941 100644
--- a/media-plugins/xmms-itouch/ChangeLog
+++ b/media-plugins/xmms-itouch/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for media-plugins/xmms-itouch
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-itouch/ChangeLog,v 1.1 2002/10/31 16:33:44 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-itouch/ChangeLog,v 1.2 2002/10/31 16:35:16 seemant Exp $
*xmms-itouch-0.1.2 (31 Oct 2002)
@@ -8,4 +8,5 @@
ChangeLog files/digest-xmms-itouch-0.1.2 :
XMMS plugin to configure multimedia keys to control xmms. Can work with
- regular keyboards as well.
+ regular keyboards as well. Ebuild submitted by: faune@broadpark.no (Loke)
+ in bug #8339.
diff --git a/media-plugins/xmms-itouch/files/digest-xmms-itouch-0.1.2 b/media-plugins/xmms-itouch/files/digest-xmms-itouch-0.1.2
new file mode 100644
index 000000000000..fe4db6ab7541
--- /dev/null
+++ b/media-plugins/xmms-itouch/files/digest-xmms-itouch-0.1.2
@@ -0,0 +1 @@
+MD5 1e3faf8e834071ebc2f6fcfc2b87049f xmms-itouch-0.1.2.tar.gz 177951
diff --git a/media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild b/media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild
new file mode 100644
index 000000000000..1d9700e66475
--- /dev/null
+++ b/media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild,v 1.1 2002/10/31 16:35:16 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XMMS plugin for multimedia keys on Logitech keyboards and others alike"
+HOMEPAGE="http://www.saunalahti.fi/~syrjala/xmms-itouch/"
+SRC_URI="http://www.saunalahti.fi/~syrjala/xmms-itouch/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="media-sound/xmms"
+
+src_install () {
+ make DESTDIR=${D} install || die
+}
+
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf}
+ emake || die
+}
+
+pkg_postinst() {
+ einfo "To configure the multimedia keys, run \"xev\" and"
+ einfo "press desired keys to get the corresponding keycode."
+ einfo "Insert this into the xmms plugin config screen."
+ einfo "Multimedia key codes can also be found at"
+ einfo "\"http://www.saunalahti.fi/~syrjala/xmms-itouch/\""
+ einfo "for some keyboard models - but for complete freedom of choice "
+ einfo "xev is your friend :-)"
+}