summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-07-03 08:55:11 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-07-03 08:55:11 +0000
commit4662a8dc4093187595f7c86a8439cb1ea23cd818 (patch)
tree3efc2be03408f4730b4fa771315c25493fc5b447 /media-plugins/eq-xmms/eq-xmms-0.6-r3.ebuild
parent+ sse-filters for eq-xmms (diff)
downloadhistorical-4662a8dc4093187595f7c86a8439cb1ea23cd818.tar.gz
historical-4662a8dc4093187595f7c86a8439cb1ea23cd818.tar.bz2
historical-4662a8dc4093187595f7c86a8439cb1ea23cd818.zip
+ sse-filters
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'media-plugins/eq-xmms/eq-xmms-0.6-r3.ebuild')
-rw-r--r--media-plugins/eq-xmms/eq-xmms-0.6-r3.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/media-plugins/eq-xmms/eq-xmms-0.6-r3.ebuild b/media-plugins/eq-xmms/eq-xmms-0.6-r3.ebuild
new file mode 100644
index 000000000000..4f64d600838f
--- /dev/null
+++ b/media-plugins/eq-xmms/eq-xmms-0.6-r3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/eq-xmms/eq-xmms-0.6-r3.ebuild,v 1.1 2005/07/03 08:55:11 voxus Exp $
+
+IUSE="sse-filters"
+
+inherit eutils
+
+DESCRIPTION="EQU is a realtime graphical equalizer effect plugin that will equalize almost everything that you play through XMMS, not just the MP3s"
+HOMEPAGE="http://equ.sourceforge.net/"
+SRC_URI="mirror://sourceforge/equ/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+
+RDEPEND="media-sound/xmms"
+DEPEND="${RDEPEND}
+ !x86? ( >=sys-devel/automake-1.7 )"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-shade_fix.patch
+ epatch ${FILESDIR}/${P}-mono_fix.patch
+
+ if ! use x86 || use sse-filters; then
+ cd ${S}
+
+ use sse-filters && {
+ epatch ${FILESDIR}/${P}-sse_filters.patch.bz2
+
+ use x86 || {
+ epatch ${FILESDIR}/${P}-sse_round_trickfilters.patch
+ }
+ }
+
+ use x86 || {
+ epatch ${FILESDIR}/${P}-nonx86.patch
+ }
+
+ ebegin "Performing auto-magic"
+ eindent
+ ebegin "aclocal"
+ WANT_AUTOMAKE=1.7 aclocal
+ eend ${?}
+
+ ebegin "automake"
+ WANT_AUTOMAKE=1.7 automake
+ eend ${?}
+
+ ebegin "autoconf"
+ WANT_AUTOCONF=2.5 autoconf
+ eend ${?}
+
+ ebegin "libtoolize"
+ libtoolize --copy --force
+ eend ${?}
+ eoutdent
+ eend ${?}
+
+ use sse-filters && {
+ sed -e "s:@CFLAGS@:@CFLAGS@ -DSSE_FILTERS:" -i ${S}/src/Makefile.in
+ }
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" libdir=`xmms-config --effect-plugin-dir` install || die
+
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README README.BSD SKINS TODO
+}