summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-30 05:09:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-30 05:09:26 +0000
commitfcc6c32959216465c56ee9a92aed75421e4c1702 (patch)
tree4e876c5cc03138cda67b93261d6f3b645d8a1d60 /media-libs
parentAdd fixes from Debian for amd64 support #100109 Micha Wiernowolski. (diff)
downloadhistorical-fcc6c32959216465c56ee9a92aed75421e4c1702.tar.gz
historical-fcc6c32959216465c56ee9a92aed75421e4c1702.tar.bz2
historical-fcc6c32959216465c56ee9a92aed75421e4c1702.zip
keep smpeg-config output clean
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/smpeg/Manifest9
-rw-r--r--media-libs/smpeg/files/smpeg-0.4.4-config.patch18
-rw-r--r--media-libs/smpeg/smpeg-0.4.4-r5.ebuild3
3 files changed, 25 insertions, 5 deletions
diff --git a/media-libs/smpeg/Manifest b/media-libs/smpeg/Manifest
index 6c6404f04ee1..45a80f0bc16c 100644
--- a/media-libs/smpeg/Manifest
+++ b/media-libs/smpeg/Manifest
@@ -1,15 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 04d6e4b6481125b155e577ed57235106 smpeg-0.4.4-r5.ebuild 1505
+MD5 aacabc4710be1ec5dccda3680748fc04 smpeg-0.4.4-r5.ebuild 1545
MD5 f29cad817e61bb94d6244bdeece339fd ChangeLog 2964
+MD5 f70fffdbc4af6ca684817ede925c6087 files/smpeg-0.4.4-config.patch 472
MD5 dcc2db7c8aa509096fc557b99bd35490 files/smpeg-0.4.4-m4.patch 233
MD5 228adf6a40bb4eef222c38d23f97014b files/digest-smpeg-0.4.4-r5 63
MD5 ff8036a570bdd3a43ed9710f91ca0556 files/smpeg-0.4.4-gnu-stack.patch 907
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCzGJOgIKl8Uu19MoRAlzzAJ4qlpa9fNV8di9OpMGUNDCIhSK5mQCfQZX2
-EmhU6Jr3BSREU9csFewP3F4=
-=fehc
+iD8DBQFC6wuWgIKl8Uu19MoRAt/tAJ9pCU4umKeEgF5lIKiQ8l2qILFRKgCfW95K
+hz1MiRGJyw3kqVbCiAjdUJY=
+=SFNG
-----END PGP SIGNATURE-----
diff --git a/media-libs/smpeg/files/smpeg-0.4.4-config.patch b/media-libs/smpeg/files/smpeg-0.4.4-config.patch
new file mode 100644
index 000000000000..2175276c351f
--- /dev/null
+++ b/media-libs/smpeg/files/smpeg-0.4.4-config.patch
@@ -0,0 +1,18 @@
+Only dump -L/-rpath if libdir is non-standard
+
+--- smpeg-config.in
++++ smpeg-config.in
+@@ -45,11 +45,13 @@
+ echo $includes -I@includedir@/smpeg `@SDL_CONFIG@ --cflags`
+ ;;
+ --libs)
++ if [ "@libdir@" != "/usr/lib" ]; then
+ if [ "`uname`" = "SunOS" ]; then
+ libdirs="-L@libdir@ -R@libdir@"
+ else
+ libdirs="-L@libdir@ @SMPEG_RLD_FLAGS@"
+ fi
++ fi
+ echo $libdirs -lsmpeg `@SDL_CONFIG@ --libs`
+ ;;
+ *)
diff --git a/media-libs/smpeg/smpeg-0.4.4-r5.ebuild b/media-libs/smpeg/smpeg-0.4.4-r5.ebuild
index 33e314899691..de85a162ac28 100644
--- a/media-libs/smpeg/smpeg-0.4.4-r5.ebuild
+++ b/media-libs/smpeg/smpeg-0.4.4-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.4-r5.ebuild,v 1.3 2005/07/06 22:58:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.4-r5.ebuild,v 1.4 2005/07/30 05:09:26 vapier Exp $
inherit eutils toolchain-funcs
@@ -23,6 +23,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-m4.patch
epatch "${FILESDIR}"/${P}-gnu-stack.patch
+ epatch "${FILESDIR}"/${P}-config.patch
sed -i \
-e 's:-mcpu=ev4 -Wa,-mall::' \
-e 's:-march=486::' \