summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-12-06 07:26:59 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-12-06 07:26:59 +0000
commit8352af1cc775a78dd63362e0ed73c8e35fdc22fc (patch)
tree1a2c8e0789bf0b204eab42db22cfc8f32a34e5ef /media-libs
parentnew package: Visual Signal Transition Graph Lab (diff)
downloadhistorical-8352af1cc775a78dd63362e0ed73c8e35fdc22fc.tar.gz
historical-8352af1cc775a78dd63362e0ed73c8e35fdc22fc.tar.bz2
historical-8352af1cc775a78dd63362e0ed73c8e35fdc22fc.zip
made jpeg and X headers support optional, depending on X and jpeg use flags, see #9080
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libwmf/ChangeLog9
-rw-r--r--media-libs/libwmf/libwmf-0.2.7.ebuild25
2 files changed, 24 insertions, 10 deletions
diff --git a/media-libs/libwmf/ChangeLog b/media-libs/libwmf/ChangeLog
index 440d99768100..f28a77599f56 100644
--- a/media-libs/libwmf/ChangeLog
+++ b/media-libs/libwmf/ChangeLog
@@ -1,9 +1,16 @@
# ChangeLog for dev-libs/libwmf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/ChangeLog,v 1.6 2002/12/05 21:37:46 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/ChangeLog,v 1.7 2002/12/06 07:26:59 george Exp $
*libwmf-0.2.7 (27 Nov 2002)
+ 05 Dec 2002; George Shapovalov <george@gentoo.org> libwmf-0.2.7.ebuild :
+
+ Incorporated changes by Lapo Calamandrei <l_calamandrei@neri-group.com> (bug #9080).
+ Basically made jpeg and X headers support optional, depending on jped and X use falgs.
+ *Not* upping the revision number - there is no new functionality/interface changes, no need to force
+ rebuild on users.
+
05 Dec 2002; Jon Nall <nall@gentoo.org> libwmf-0.2.7.ebuild :
keyworded ~ppc
diff --git a/media-libs/libwmf/libwmf-0.2.7.ebuild b/media-libs/libwmf/libwmf-0.2.7.ebuild
index 0018e0aedf26..bc5a726d7fc9 100644
--- a/media-libs/libwmf/libwmf-0.2.7.ebuild
+++ b/media-libs/libwmf/libwmf-0.2.7.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/libwmf-0.2.7.ebuild,v 1.2 2002/12/05 21:37:46 nall Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/libwmf-0.2.7.ebuild,v 1.3 2002/12/06 07:26:59 george Exp $
+
+IUSE="jpeg X"
#The configure script finds the 5.50 ghostscript Fontmap file while run.
#This will probably work, especially since the real one (6.50) in this case
#is empty. However beware in case there is any trouble
-S=${WORKDIR}/${P}
+S=${WORKDIR}/${P}
DESCRIPTION="library for converting WMF files"
SRC_URI="mirror://sourceforge/wvware/${P}.tar.gz"
HOMEPAGE="http://www.wvware.com/libwmf.html"
@@ -16,27 +18,32 @@ SLOT="0"
KEYWORDS="~x86 ~ppc"
LICENSE="GPL-2"
-DEPEND=">=app-text/ghostscript-6.50
+DEPEND=">=app-text/ghostscript-6.50
dev-libs/expat
dev-libs/libxml2
>=media-libs/freetype-2.0.1
sys-libs/zlib
media-libs/libpng
- media-libs/jpeg"
+ jpeg? ( media-libs/jpeg )
+ X? ( virtual/x11 )"
# plotutils are not really supported yet, so looks like that's it
-
+
src_compile() {
-
+
+ use jpeg || myconf="${myconf} --with-jpeg=no"
+ use X || myconf="${myconf} --with-x=no"
+
econf \
+ ${myconf} \
--with-gsfontdir=/usr/share/ghostscript/fonts \
--with-fontdir=/usr/share/libwmf/fonts/ \
- --with-docdir=${D}/usr/share/doc/${PF} || die
+ --with-docdir=${D}/usr/share/doc/${PF} || die "./configure failed"
- emake || die
+ make || die
}
src_install () {
- einstall \
+ einstall \
fontdir=${D}/usr/share/libwmf/fonts || die
dodoc README AUTHORS COPYING CREDITS ChangeLog NEWS TODO