summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-17 14:25:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-17 14:25:41 +0000
commita9b146919800ba423564067dc8dcdd3857ed16f0 (patch)
treeeb7353ccb13a36aee4602359001c2f6c3e750390 /media-libs/xvid/xvid-1.1.0-r1.ebuild
parentppc stable, bug #130209 (diff)
downloadhistorical-a9b146919800ba423564067dc8dcdd3857ed16f0.tar.gz
historical-a9b146919800ba423564067dc8dcdd3857ed16f0.tar.bz2
historical-a9b146919800ba423564067dc8dcdd3857ed16f0.zip
Add a patch that changes the default emms function on x86_64 architecture to the MMX version, not using 3DNow! instructions in EM64T systems.
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'media-libs/xvid/xvid-1.1.0-r1.ebuild')
-rw-r--r--media-libs/xvid/xvid-1.1.0-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/xvid/xvid-1.1.0-r1.ebuild b/media-libs/xvid/xvid-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..01c696787efc
--- /dev/null
+++ b/media-libs/xvid/xvid-1.1.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-1.1.0-r1.ebuild,v 1.1 2006/04/17 14:25:41 flameeyes Exp $
+
+inherit eutils fixheadtails autotools
+
+MY_P=${PN}core-${PV/_beta/-beta}
+DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution"
+HOMEPAGE="http://www.xvid.org/"
+SRC_URI="http://downloads.xvid.org/downloads/${MY_P}.tar.bz2
+ mirror://gentoo/${PN}-1.1.0-noexec-stack.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="doc altivec"
+
+DEPEND="x86? ( >=dev-lang/nasm-0.98.36 )
+ amd64? ( dev-lang/yasm )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}/build/generic
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${WORKDIR}"/${MY_P}
+ epatch "${FILESDIR}/${PN}-1.1.0_beta2-altivec.patch"
+ epatch "${WORKDIR}/${PN}-1.1.0-noexec-stack.patch"
+ epatch "${FILESDIR}/${P}-3dnow.patch"
+
+ cd ${S}
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable altivec) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ cd "${S}"/../../
+ dodoc AUTHORS ChangeLog README TODO doc/*
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ local mylib=$(basename $(ls "${D}"/usr/$(get_libdir)/libxvidcore.*.dylib))
+ dosym ${mylib} /usr/$(get_libdir)/libxvidcore.dylib
+ else
+ local mylib=$(basename $(ls "${D}"/usr/$(get_libdir)/libxvidcore.so*))
+ dosym ${mylib} /usr/$(get_libdir)/libxvidcore.so
+ dosym ${mylib} /usr/$(get_libdir)/${mylib/.1}
+ fi
+
+ if use doc ; then
+ dodoc CodingStyle doc/README
+ docinto examples
+ dodoc examples/*
+ fi
+}