summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Hildebrand <zypher@gentoo.org>2004-09-04 16:29:58 +0000
committerMarc Hildebrand <zypher@gentoo.org>2004-09-04 16:29:58 +0000
commit406880fff089f325d331c0535cc244552199bfe3 (patch)
treeb16378df4890da6daaac59610035a815bed2f74d /media-libs/xvid/xvid-1.0.2.ebuild
parentfix manifest (diff)
downloadhistorical-406880fff089f325d331c0535cc244552199bfe3.tar.gz
historical-406880fff089f325d331c0535cc244552199bfe3.tar.bz2
historical-406880fff089f325d331c0535cc244552199bfe3.zip
Version bump, submitted by Thomas Galliano. see bug #62190
Diffstat (limited to 'media-libs/xvid/xvid-1.0.2.ebuild')
-rw-r--r--media-libs/xvid/xvid-1.0.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/xvid/xvid-1.0.2.ebuild b/media-libs/xvid/xvid-1.0.2.ebuild
new file mode 100644
index 000000000000..de33b887e987
--- /dev/null
+++ b/media-libs/xvid/xvid-1.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-1.0.2.ebuild,v 1.1 2004/09/04 16:29:58 zypher Exp $
+
+inherit eutils
+
+MY_P=${PN}core-${PV/_rc/-rc}
+DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution."
+HOMEPAGE="http://www.xvid.org/"
+SRC_URI="http://files.xvid.org/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~ppc64 ~mips"
+IUSE="doc"
+
+DEPEND="virtual/glibc
+ x86? ( >=dev-lang/nasm-0.98.36 )"
+
+S="${WORKDIR}/${MY_P}/build/generic"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-DESTDIR.patch
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ cd ${S}/../../
+ dodoc AUTHORS ChangeLog README TODO doc/*
+
+ local mylib="$(basename $(ls ${D}/usr/lib/libxvidcore.so*))"
+ dosym ${mylib} /usr/lib/libxvidcore.so
+ dosym ${mylib} /usr/lib/${mylib/.0}
+
+ if use doc ; then
+ dodoc CodingStyle doc/README
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}