summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-02-14 00:12:02 +0000
committerNick Hadaway <raker@gentoo.org>2003-02-14 00:12:02 +0000
commitbb6dde4944b17431c93a4af9b963d3955100eb42 (patch)
treebf4aafdfb516ef3ec593bb0dd689b41601895de6 /media-libs/netpbm/files
parentAdd missing entry for distcc-1.1-r8 ebuild (diff)
downloadhistorical-bb6dde4944b17431c93a4af9b963d3955100eb42.tar.gz
historical-bb6dde4944b17431c93a4af9b963d3955100eb42.tar.bz2
historical-bb6dde4944b17431c93a4af9b963d3955100eb42.zip
Version bump
Diffstat (limited to 'media-libs/netpbm/files')
-rw-r--r--media-libs/netpbm/files/10.11.5/Makefile.config476
-rw-r--r--media-libs/netpbm/files/10.11.5/Makefile.svga478
-rw-r--r--media-libs/netpbm/files/digest-netpbm-10.11.51
3 files changed, 955 insertions, 0 deletions
diff --git a/media-libs/netpbm/files/10.11.5/Makefile.config b/media-libs/netpbm/files/10.11.5/Makefile.config
new file mode 100644
index 000000000000..37e0b7a9bea6
--- /dev/null
+++ b/media-libs/netpbm/files/10.11.5/Makefile.config
@@ -0,0 +1,476 @@
+####This file was automatically created by 'configure.'
+####Many variables are set twice -- a generic setting, then
+####a system-specific override at the bottom of the file.
+####
+# This is a make file inclusion, to be included in all the Netpbm make
+# files.
+
+# This file is meant to contain variable settings that customize the
+# build for a particular target system configuration.
+
+# The distribution contains the file Makefile.config.in. You edit
+# Makefile.config.in in ways relevant to your particular environment
+# to create Makefile.config. The "configure" program will do this
+# for you in simple cases.
+
+# Some of the variables that the including make file must set for this
+# file to work:
+#
+# SRCDIR: The directory at the top of the Netpbm source tree. Note that
+# this is typically a relative directory, and it must be relative to the
+# make file that includes this file. So it's normally "..".
+
+DEFAULT_TARGET = nonmerge
+#DEFAULT_TARGET = merge
+
+# Fiasco has some special requirements that make it fail to compile on
+# some systems, and since it isn't very important, just set this to "N"
+# and skip it on those systems unless you want to debug it and fix it.
+# OpenBSD:
+#BUILD_FIASCO = N
+BUILD_FIASCO = Y
+
+# The following are commands for the build process to use. These values
+# do not get built into anything.
+
+# The C compiler (including macro preprocessor)
+#CC = gcc
+# Note that 'cc' is usually an alias for whatever is the main compiler
+# on a system, e.g. the GNU Compiler on Linux.
+CC = cc
+
+# The linker.
+LD = $(CC)
+#LD = ld
+#Tru64:
+#LD = cc
+#LD = gcc
+
+# CC and LD are for building the Netpbm programs, which are not necessarily
+# intended to run on the same system on which Make is running. But when we
+# build a build tool such as Libopt, it is meant to run only on the same
+# system on which the Make is running. The variables below define programs
+# to use to compile and link build tools.
+CC_FOR_BUILD = $(CC)
+LD_FOR_BUILD = $(LD)
+
+# MAKE is set automatically by Make to what was used to invoke Make.
+
+INSTALL = $(SRCDIR)/buildtools/install.sh
+#Solaris:
+#INSTALL = /usr/ucb/install
+#Tru64:
+#INSTALL = installbsd
+#OSF1:
+#INSTALL = $(SRCDIR)/buildtools/installosf
+#Red Hat Linux:
+#INSTALL = install
+
+# STRIPFLAG is the option you pass to the above install program to make it
+# strip unnecessary information out of binaries.
+STRIPFLAG = -s
+# If you don't want to strip the binaries, just leave it null:
+#STRIPFLAG =
+
+SYMLINK = ln -s
+# At least some Windows environments don't have any concept of symbolic
+# links, but direct copies are usually a passable alternative.
+#SYMLINK = cp
+
+#MANPAGE_FORMAT is "nroff" or "cat". It determines in what format the
+#pointer man pages are installed (ready to nroff, or ready to cat).
+#A pointer man pages is just a single-paragraph pages that tells you there is
+#no man page for the program, to look at the HTML documentation instead.
+MANPAGE_FORMAT = nroff
+#MANPAGE_FORMAT = cat
+
+AR = ar
+RANLIB = ranlib
+# IRIX, SCO don't have Ranlib:
+#RANLIB = true
+LEX = flex
+# Solaris:
+# LEX = flex -e
+# Or just skip parts that need Lex:
+# LEX =
+
+# C compiler options
+
+# gcc:
+# -ansi and -Werror should work too, but are not included
+# by default because there's no point in daring the build to fail.
+# -pedantic isn't a problem because it causes at worst a warning.
+#CFLAGS = -pedantic -O3 -Wall -Wno-uninitialized -Wmissing-declarations
+# The merged programs have a main_XXX subroutine instead of main(),
+# which would cause a warning with -Wmissing-declarations
+#CFLAGS_MERGE = -Wno-missing-declarations
+# On DEC Tru64 4.0F (at least), you need -DLONG_32 for ppmtompeg.
+#Tru64:
+#CFLAGS = -O2 -std1 -DLONG_32
+#AIX:
+#CFLAGS= -O3 -D_ALL_SOURCE
+#HP-UX:
+#CFLAGS= -O3 -fPIC
+
+
+# EXE is a suffix that the linker puts on any executable it generates.
+# In cygwin, this is .exe and most programs deal with its existence without
+# us having to know about it. Some don't though, so set this:
+
+EXE =
+#Cygwin, DJGPP/Windows:
+#EXE = .exe
+
+# linker options.
+
+# On some systems you have to build into an executable the list of
+# directories where its dynamically linked libraries can be found at
+# run time. This is typically done with a -R or --rpath linker
+# option. Even on systems that don't require it, you might prefer to do
+# that rather than set up environment variables or configuration files
+# to tell the system where the libraries are. A "Y" here means to put
+# the directory information in the executable at link time.
+
+NEED_RUNTIME_PATH = N
+# Solaris, SunOS, NetBSD:
+#NEED_RUNTIME_PATH = Y
+
+LDFLAGS =
+# Eunice users may want to use -noshare so that the executables can
+# run standalone:
+#LDFLAGS = -noshare
+#Tru64:
+# Russ Allberry says on 2001.06.09 that -oldstyle_liblookup may be necessary
+# to keep from finding an ancient system libjpeg.so that isn't compatible with
+# NetPBM. Michael Long found that /usr/local/lib is not in the default
+# search path, or not soon enough, and he was getting an old libjpeg that
+# caused all the jpeg symbol references to be unresolved. He had installed
+# a new libjpeg in /usr/local/lib.
+#LDFLAGS = -call_shared -oldstyle_liblookup -L/usr/local/lib
+#AIX:
+#LDFLAGS=-L /usr/pubsw/lib
+#HP-UX:
+#LDFLAGS = -Wl,+b,/usr/pubsw/lib
+#FreeBSD:
+#LDFLAGS = -L/usr/local/lib
+
+# Linker options for created Netpbm shared libraries.
+
+# Here, $(SONAME) resolves to the soname for the shared library being created.
+# The following are gcc options. This works on GNU libc systems.
+LDSHLIB = -shared -Wl,-soname,$(SONAME)
+# You need -nostart instead of -shared on BeOS. Though the BeOS compiler is
+# ostensibly gcc, it has the -nostart option, which is not mentioned in gcc
+# documentation and doesn't exist in at least one non-BeOS installation.
+# BeOS doesn't have sonames built in.
+#LDSHLIB = -nostart
+#LDSHLIB = -G
+# Solaris, SunOS with GNU Ld, SCO:
+# These systems have no soname option.
+#LDSHLIB = -shared
+# Solaris with Sun Ld:
+#LDSHLIB = -Wl,-Bdynamic,-G,-h,$(SONAME)
+#Tru64:
+#LDSHLIB = -shared -expect_unresolved "*"
+#AIX:
+#LDSHLIB = ???
+
+# On older systems, you have to make shared libraries out of position
+# independent code, so you need -fpic or fPIC here. (The rule is: if
+# -fpic works, use it. If it bombs, go to fPIC). On newer systems,
+# it isn't necessary, but can save real memory at the expense of
+# execution speed. Without position independent code, the library
+# loader may have to patch addresses into the executable text. On an
+# older system, this would cause a program crash because the loader
+# would be writing into read-only shared memory. But on newer
+# systems, the system silently creates a private mapping of the page
+# or segment being modified (the "copy on write" phenomenon). So it
+# needs its own private real page frame. In one experiment, A second
+# copy of Pbmtext used 16K less real memory when built with -fpic than
+# when built without. 2001.06.02.
+
+CFLAGS_SHLIB =
+# Solaris or SunOS with gcc, and NetBSD:
+#CFLAGS_SHLIB = -fpic
+#CFLAGS_SHLIB = -fPIC
+# Sun compiler:
+#CFLAGS_SHLIB = -Kpic
+#CFLAGS_SHLIB = -KPIC
+
+# SHLIB_CLIB is the link option to include the C library in a shared library,
+# normally "-lc". On typical systems, this serves no purpose. On some,
+# though, it causes information about which C library to use to be recorded
+# in the shared library and thus choose the correct library among several or
+# avoid using an incompatible one. But on some systems, the link fails.
+# On 2002.09.30, "John H. DuBois III" <spcecdt@armory.com> reports that on
+# SCO OpenServer, he gets the following error message with -lc:
+#
+# -lc; relocations referenced ; from file(s) /usr/ccs/lib/libc.so(random.o);
+# fatal error: relocations remain against allocatable but non-writable
+# section: ; .text
+
+SHLIB_CLIB = -lc
+# SCO:
+SHLIB_CLIB =
+
+# The following variables tell where your various libraries on which
+# Netpbm depends live. The LIBxxx variable is a full file
+# specification of the link library (not necessarily the library used
+# at run time). e.g. "/usr/local/lib/graphics/libpng.so". It usually
+# doesn't matter if the library prefix and suffix are right -- you can
+# use "lib" and ".so" or ".a" regardless of what your system actually
+# uses because these just turn into "-L" and "-l" linker options
+# anyway. ".a" implies a static library for some purposes, though.
+# If you don't have the library in question, use a value of NONE for
+# LIBxxx and the build will simply skip the programs that require that
+# library. If the library is in your linker's (or the Netpbm build's)
+# default search path, leave off the directory part, e.g. "libpng.so".
+
+# The xxxHDR_DIR variable is the directory in which the interface
+# headers for the library live (e.g. /usr/include). If they are in your
+# compiler's default search path, set this variable to null.
+
+# This is where the Netpbm shared libraries will reside when Netpbm is
+# fully installed. In some configurations, the Netpbm builder builds
+# this information into the Netpbm executables. This does NOT affect
+# where the Netpbm installer installs the libraries. A null value
+# means the libraries are in a default search path used by the runtime
+# library loader.
+NETPBMLIB_RUNTIME_PATH =
+#NETPBMLIB_RUNTIME_PATH = /usr/lib/netpbm
+
+# The TIFF library. See above. If you want to build the tiff
+# converters, you must have the tiff library already installed.
+
+TIFFLIB = NONE
+TIFFHDR_DIR =
+
+#TIFFLIB = libtiff.so
+#TIFFHDR_DIR = /usr/include/libtiff
+#NetBSD:
+#TIFFLIB = $(LOCALBASE)/lib/libtiff.so
+#TIFFHDR_DIR = $(LOCALBASE)/include
+# OSF, Tru64:
+#TIFFLIB = /usr/local1/DEC/lib/libtiff.so
+#TIFFHDR_DIR = /usr/local1/DEC/include
+
+# If your Tiff library depends on libraries other than libc and libm,
+# put the required linker options here.
+TIFFLIB_LDFLAGS =
+# John Milton <jmilton@fundsxpress.com> in September 2000 and
+# John Bartelt <bartelt@SLAC.Stanford.EDU> in August 2002 reported
+# needing libz with libtiff 3.5.5 (with and without LZW patch):
+#TIFFLIB_LDFLAGS = -lz
+
+# The JPEG library. See above. If you want to build the jpeg
+# converters you must have the jpeg library already installed.
+
+# Tiff files can use JPEG compression, so the Tiff library can reference
+# the JPEG library. If your Tiff library references a dynamic JPEG
+# library, you must specify at least JPEGLIB here, or the Tiff
+# converters will not build. Note that your Tiff library may have the
+# JPEG stuff statically linked in, in which case you won't need
+# JPEGLIB in order to build the Tiff converters.
+
+JPEGLIB = NONE
+JPEGHDR_DIR =
+#JPEGLIB = libjpeg.so
+#JPEGHDR_DIR = /usr/include/jpeg
+# Netbsd:
+#JPEGLIB = ${LOCALBASE}/lib/libjpeg.so
+#JPEGHDR_DIR = ${LOCALBASE}/include
+# OSF, Tru64:
+#JPEGLIB = /usr/local1/DEC/libjpeg.so
+#JPEGHDR_DIR = /usr/local1/DEC/include
+# Typical:
+#JPEGLIB = /usr/local/lib/libjpeg.so
+#JPEGHDR_DIR = /usr/local/include
+# Don't build JPEG stuff:
+#JPEGLIB = NONE
+
+
+# The PNG library. See above. If you want to build the PNG
+# converters you must have the PNG library already installed.
+
+# The PNG library, by convention starting around April 2002, gets installed
+# with names that include a version number, such as libpng10.a and header
+# files in /usr/include/libpng10.
+# option.
+PNGLIB = NONE
+PNGVER =
+#PNGLIB = libpng$(PNGVER).so
+#PNGHDR_DIR = /usr/include/libpng$(PNGVER)
+# NetBSD:
+#PNGLIB = $(LOCALBASE)/lib/libpng$(PNGVER).so
+#PNGHDR_DIR = $(LOCALBASE)/include
+# OSF/Tru64:
+#PNGLIB = /usr/local1/DEC/lib/libpng$(PNGVER).so
+#PNGHDR_DIR = /usr/local1/DEC/include
+
+# The zlib compression library. See above. You need it to build
+# anything that needs the PNG library (see above). If you selected
+# NONE for the PNG library, it doesn't matter what you specify here --
+# it won't get used.
+
+ZLIB = NONE
+ZHDR_DIR =
+#ZLIB = libz.so
+
+# The JBIG lossless image compression library (aka JBIG-KIT):
+
+JBIGLIB = $(BUILDDIR)/converter/other/jbig/libjbig.a
+JBIGHDR_DIR = $(SRCDIR)/converter/other/jbig
+
+# The Jasper JPEG-2000 image compression library (aka JasPer):
+JASPERLIB = $(INTERNAL_JASPERLIB)
+JASPERHDR_DIR = $(INTERNAL_JASPERHDR_DIR)
+
+# And the Utah Raster Toolkit (aka URT aka RLE) library:
+
+URTLIB = $(BUILDDIR)/urt/librle.a
+URTHDR_DIR = $(SRCDIR)/urt
+
+# The Linux SVGA library (Svgalib) is a facility for displaying graphics
+# on the Linux console. It is required by Ppmsvgalib.
+
+LINUXSVGALIB = NONE
+LINUXSVGAHDR_DIR =
+
+#LINUXSVGALIB_DIR =
+#LINUXSVGAHDR_DIR = /usr/include/vgalib
+
+# These are -l options to link in the network libraries. Often, these are
+# built into the standard C library, so this can be null. If you don't
+# want any network functions, make it NONE. The only thing that requires
+# network functions is the option in ppmtompeg to run it on multiple
+# computers simultaneously.
+
+NETWORKLD =
+# Solaris, SunOS:
+#NETWORKLD = -lsocket -lnsl
+# SCO:
+#NETWORKLD = -lsocket, -lresolv
+# Don't build network functions:
+#DJGPP/Windows, Tru64:
+# (there's some minor header problem that prevents network functions from
+# building on Tru64 2000.10.06)
+#NETWORKLD = NONE
+
+VMS =
+#VMS:
+#VMS = yes
+
+# The following variables are used only by 'make install' (and the
+# variants of it). Paths here don't, for example, get built into any
+# programs.
+
+# File permissions for installed files.
+# Note that on some systems (e.g. Solaris), 'install' can't use the
+# mnemonic permissions - you have to use octal.
+
+# binaries (pbmmake, etc)
+INSTALL_PERM_BIN = 755 # u=rwx,go=rx
+# shared libraries (libpbm.so, etc)
+INSTALL_PERM_LIBD = 755 # u=rwx,go=rx
+# static libraries (libpbm.a, etc)
+INSTALL_PERM_LIBS = 644 # u=rw,go=r
+# header files (pbm.h, etc)
+INSTALL_PERM_HDR = 644 # u=rw,go=r
+# man pages (pbmmake.1, etc)
+INSTALL_PERM_MAN = 644 # u=rw,go=r
+# data files (pnmtopalm color maps, etc)
+INSTALL_PERM_DATA = 644 # u=rw,go=r
+
+# Specify the suffix that want the man pages to have.
+
+SUFFIXMANUALS1 = 1
+SUFFIXMANUALS3 = 3
+SUFFIXMANUALS5 = 5
+
+#NETPBMLIBTYPE tells the kind of libraries that will get built to hold the
+#Netpbm library functions. The value is used only in make file tests.
+# "unixshared" means a unix-style shared library, typically named like
+# libxyz.so.2.3
+NETPBMLIBTYPE = unixshared
+# "unixstatic" means a unix-style static library, (like libxyz.a)
+#NETPBMLIBTYPE = unixstatic
+# "dll" means a Windows DLL shared library
+#NETPBMLIBTYPE = dll
+# "dylib" means a Darwin/Mac OS shared library
+#NETPBMLIBTYPE = dylib
+
+#NETPBMLIBSUFFIX is the suffix used on whatever kind of library is
+#selected above. All this is used for is to construct library names.
+#The make files never examine the actual value.
+NETPBMLIBSUFFIX = so
+# "a" is the suffix for unix-style static libraries. Also for AIX shared
+# libraries.
+#NETPBMLIBSUFFIX = a
+# For HP-UX shared libraries:
+#NETPBMLIBSUFFIX = sl
+# Darwin/Mac OS shared library:
+#NETPBMLIBSUFFIX = dylib
+# Windows shared library:
+#NETPBMLIBSUFFIX = dll
+
+#STATICLIB_TOO is "y" to signify that you want a static library built
+#and installed in addition to whatever library type you specified by
+#NETPBMLIBTYPE. If NETPBMLIBTYPE specified a static library,
+#STATICLIB_TOO simply has no effect.
+STATICLIB_TOO = y
+#STATICLIB_TOO = n
+
+#STATICLIBSUFFIX is the suffix that static libraries have. It's
+#meaningless if you aren't building static libraries.
+STATICLIBSUFFIX = a
+
+#SHLIBPREFIXLIST is a blank-delimited list of prefixes that a filename
+#of a shared library may have on this system. Traditionally, it's
+#just "lib", as in libc or libpbm. On Windows, though, varying
+#prefixes are used when multiple alternative forms of a library are
+#available. The first prefix in this list is what we use to name the
+#Netpbm shared libraries.
+SHLIBPREFIXLIST = lib
+#Cygwin:
+#SHLIBPREFIXLIST = cyg lib
+
+NETPBMSHLIBPREFIX = $(firstword $(SHLIBPREFIXLIST))
+
+#DLLVER is used to version the DLLs built on cygwin or other
+#windowsish platforms. We can't add this to LIBROOT, or we'd
+#version the static libs (which is bad). We can't add this
+#at the end of the name (like unix does with so numbers) because
+#windows will only load dlls whose name ends in "dll". So,
+#we have this variable, which becomes the end of the library "root" name
+#for DLLs only.
+DLLVER =
+#Cygwin
+#DLLVER = $(NETPBM_MAJOR_RELEASE)
+
+#NETPBM_DOCURL is the URL of the main documentation page for Netpbm.
+#This is a directory which contains a file for each Netpbm program,
+#library, and file type. E.g. The documentation for jpegtopnm might be in
+#http://netpbm.sourceforge.net/doc/jpegtopnm.html . This value gets
+#installed in the man pages (which say no more than to read the webpage)
+#and in the Webman netpbm.url file.
+NETPBM_DOCURL = http://netpbm.sourceforge.net/doc/
+#For a system with no web access, but a local copy of the doc:
+#NETPBM_DOCURL = file:/usr/doc/netpbm/
+
+# This is where everything goes when you do 'make package':
+PKGDIR = /tmp/netpbm
+
+
+
+####Lines above were copied from Makefile.config.in by 'configure'.
+####Lines below were added by 'configure' based on the GNU platform.
+DEFAULT_TARGET = nonmerge
+NETPBMLIBTYPE=unixshared
+NETPBMLIBSUFFIX=so
+STATICLIB_TOO=n
+CFLAGS = -pedantic -O3 -Wall -Wno-uninitialized -Wmissing-declarations -Wimplicit -Wwrite-strings
+CFLAGS_MERGE = -Wno-missing-declarations
+TIFFLIB = libtiff.so
+JPEGLIB = libjpeg.so
+PNGLIB = libpng.so
+ZLIB = libz.so
diff --git a/media-libs/netpbm/files/10.11.5/Makefile.svga b/media-libs/netpbm/files/10.11.5/Makefile.svga
new file mode 100644
index 000000000000..43f6c65531ff
--- /dev/null
+++ b/media-libs/netpbm/files/10.11.5/Makefile.svga
@@ -0,0 +1,478 @@
+####This file was automatically created by 'configure.'
+####Many variables are set twice -- a generic setting, then
+####a system-specific override at the bottom of the file.
+####
+# This is a make file inclusion, to be included in all the Netpbm make
+# files.
+
+# This file is meant to contain variable settings that customize the
+# build for a particular target system configuration.
+
+# The distribution contains the file Makefile.config.in. You edit
+# Makefile.config.in in ways relevant to your particular environment
+# to create Makefile.config. The "configure" program will do this
+# for you in simple cases.
+
+# Some of the variables that the including make file must set for this
+# file to work:
+#
+# SRCDIR: The directory at the top of the Netpbm source tree. Note that
+# this is typically a relative directory, and it must be relative to the
+# make file that includes this file. So it's normally "..".
+
+DEFAULT_TARGET = nonmerge
+#DEFAULT_TARGET = merge
+
+# Fiasco has some special requirements that make it fail to compile on
+# some systems, and since it isn't very important, just set this to "N"
+# and skip it on those systems unless you want to debug it and fix it.
+# OpenBSD:
+#BUILD_FIASCO = N
+BUILD_FIASCO = Y
+
+# The following are commands for the build process to use. These values
+# do not get built into anything.
+
+# The C compiler (including macro preprocessor)
+#CC = gcc
+# Note that 'cc' is usually an alias for whatever is the main compiler
+# on a system, e.g. the GNU Compiler on Linux.
+CC = cc
+
+# The linker.
+LD = $(CC)
+#LD = ld
+#Tru64:
+#LD = cc
+#LD = gcc
+
+# CC and LD are for building the Netpbm programs, which are not necessarily
+# intended to run on the same system on which Make is running. But when we
+# build a build tool such as Libopt, it is meant to run only on the same
+# system on which the Make is running. The variables below define programs
+# to use to compile and link build tools.
+CC_FOR_BUILD = $(CC)
+LD_FOR_BUILD = $(LD)
+
+# MAKE is set automatically by Make to what was used to invoke Make.
+
+INSTALL = $(SRCDIR)/buildtools/install.sh
+#Solaris:
+#INSTALL = /usr/ucb/install
+#Tru64:
+#INSTALL = installbsd
+#OSF1:
+#INSTALL = $(SRCDIR)/buildtools/installosf
+#Red Hat Linux:
+#INSTALL = install
+
+# STRIPFLAG is the option you pass to the above install program to make it
+# strip unnecessary information out of binaries.
+STRIPFLAG = -s
+# If you don't want to strip the binaries, just leave it null:
+#STRIPFLAG =
+
+SYMLINK = ln -s
+# At least some Windows environments don't have any concept of symbolic
+# links, but direct copies are usually a passable alternative.
+#SYMLINK = cp
+
+#MANPAGE_FORMAT is "nroff" or "cat". It determines in what format the
+#pointer man pages are installed (ready to nroff, or ready to cat).
+#A pointer man pages is just a single-paragraph pages that tells you there is
+#no man page for the program, to look at the HTML documentation instead.
+MANPAGE_FORMAT = nroff
+#MANPAGE_FORMAT = cat
+
+AR = ar
+RANLIB = ranlib
+# IRIX, SCO don't have Ranlib:
+#RANLIB = true
+LEX = flex
+# Solaris:
+# LEX = flex -e
+# Or just skip parts that need Lex:
+# LEX =
+
+# C compiler options
+
+# gcc:
+# -ansi and -Werror should work too, but are not included
+# by default because there's no point in daring the build to fail.
+# -pedantic isn't a problem because it causes at worst a warning.
+#CFLAGS = -pedantic -O3 -Wall -Wno-uninitialized -Wmissing-declarations
+# The merged programs have a main_XXX subroutine instead of main(),
+# which would cause a warning with -Wmissing-declarations
+#CFLAGS_MERGE = -Wno-missing-declarations
+# On DEC Tru64 4.0F (at least), you need -DLONG_32 for ppmtompeg.
+#Tru64:
+#CFLAGS = -O2 -std1 -DLONG_32
+#AIX:
+#CFLAGS= -O3 -D_ALL_SOURCE
+#HP-UX:
+#CFLAGS= -O3 -fPIC
+
+
+# EXE is a suffix that the linker puts on any executable it generates.
+# In cygwin, this is .exe and most programs deal with its existence without
+# us having to know about it. Some don't though, so set this:
+
+EXE =
+#Cygwin, DJGPP/Windows:
+#EXE = .exe
+
+# linker options.
+
+# On some systems you have to build into an executable the list of
+# directories where its dynamically linked libraries can be found at
+# run time. This is typically done with a -R or --rpath linker
+# option. Even on systems that don't require it, you might prefer to do
+# that rather than set up environment variables or configuration files
+# to tell the system where the libraries are. A "Y" here means to put
+# the directory information in the executable at link time.
+
+NEED_RUNTIME_PATH = N
+# Solaris, SunOS, NetBSD:
+#NEED_RUNTIME_PATH = Y
+
+LDFLAGS =
+# Eunice users may want to use -noshare so that the executables can
+# run standalone:
+#LDFLAGS = -noshare
+#Tru64:
+# Russ Allberry says on 2001.06.09 that -oldstyle_liblookup may be necessary
+# to keep from finding an ancient system libjpeg.so that isn't compatible with
+# NetPBM. Michael Long found that /usr/local/lib is not in the default
+# search path, or not soon enough, and he was getting an old libjpeg that
+# caused all the jpeg symbol references to be unresolved. He had installed
+# a new libjpeg in /usr/local/lib.
+#LDFLAGS = -call_shared -oldstyle_liblookup -L/usr/local/lib
+#AIX:
+#LDFLAGS=-L /usr/pubsw/lib
+#HP-UX:
+#LDFLAGS = -Wl,+b,/usr/pubsw/lib
+#FreeBSD:
+#LDFLAGS = -L/usr/local/lib
+
+# Linker options for created Netpbm shared libraries.
+
+# Here, $(SONAME) resolves to the soname for the shared library being created.
+# The following are gcc options. This works on GNU libc systems.
+LDSHLIB = -shared -Wl,-soname,$(SONAME)
+# You need -nostart instead of -shared on BeOS. Though the BeOS compiler is
+# ostensibly gcc, it has the -nostart option, which is not mentioned in gcc
+# documentation and doesn't exist in at least one non-BeOS installation.
+# BeOS doesn't have sonames built in.
+#LDSHLIB = -nostart
+#LDSHLIB = -G
+# Solaris, SunOS with GNU Ld, SCO:
+# These systems have no soname option.
+#LDSHLIB = -shared
+# Solaris with Sun Ld:
+#LDSHLIB = -Wl,-Bdynamic,-G,-h,$(SONAME)
+#Tru64:
+#LDSHLIB = -shared -expect_unresolved "*"
+#AIX:
+#LDSHLIB = ???
+
+# On older systems, you have to make shared libraries out of position
+# independent code, so you need -fpic or fPIC here. (The rule is: if
+# -fpic works, use it. If it bombs, go to fPIC). On newer systems,
+# it isn't necessary, but can save real memory at the expense of
+# execution speed. Without position independent code, the library
+# loader may have to patch addresses into the executable text. On an
+# older system, this would cause a program crash because the loader
+# would be writing into read-only shared memory. But on newer
+# systems, the system silently creates a private mapping of the page
+# or segment being modified (the "copy on write" phenomenon). So it
+# needs its own private real page frame. In one experiment, A second
+# copy of Pbmtext used 16K less real memory when built with -fpic than
+# when built without. 2001.06.02.
+
+CFLAGS_SHLIB =
+# Solaris or SunOS with gcc, and NetBSD:
+#CFLAGS_SHLIB = -fpic
+#CFLAGS_SHLIB = -fPIC
+# Sun compiler:
+#CFLAGS_SHLIB = -Kpic
+#CFLAGS_SHLIB = -KPIC
+
+# SHLIB_CLIB is the link option to include the C library in a shared library,
+# normally "-lc". On typical systems, this serves no purpose. On some,
+# though, it causes information about which C library to use to be recorded
+# in the shared library and thus choose the correct library among several or
+# avoid using an incompatible one. But on some systems, the link fails.
+# On 2002.09.30, "John H. DuBois III" <spcecdt@armory.com> reports that on
+# SCO OpenServer, he gets the following error message with -lc:
+#
+# -lc; relocations referenced ; from file(s) /usr/ccs/lib/libc.so(random.o);
+# fatal error: relocations remain against allocatable but non-writable
+# section: ; .text
+
+SHLIB_CLIB = -lc
+# SCO:
+SHLIB_CLIB =
+
+# The following variables tell where your various libraries on which
+# Netpbm depends live. The LIBxxx variable is a full file
+# specification of the link library (not necessarily the library used
+# at run time). e.g. "/usr/local/lib/graphics/libpng.so". It usually
+# doesn't matter if the library prefix and suffix are right -- you can
+# use "lib" and ".so" or ".a" regardless of what your system actually
+# uses because these just turn into "-L" and "-l" linker options
+# anyway. ".a" implies a static library for some purposes, though.
+# If you don't have the library in question, use a value of NONE for
+# LIBxxx and the build will simply skip the programs that require that
+# library. If the library is in your linker's (or the Netpbm build's)
+# default search path, leave off the directory part, e.g. "libpng.so".
+
+# The xxxHDR_DIR variable is the directory in which the interface
+# headers for the library live (e.g. /usr/include). If they are in your
+# compiler's default search path, set this variable to null.
+
+# This is where the Netpbm shared libraries will reside when Netpbm is
+# fully installed. In some configurations, the Netpbm builder builds
+# this information into the Netpbm executables. This does NOT affect
+# where the Netpbm installer installs the libraries. A null value
+# means the libraries are in a default search path used by the runtime
+# library loader.
+NETPBMLIB_RUNTIME_PATH =
+#NETPBMLIB_RUNTIME_PATH = /usr/lib/netpbm
+
+# The TIFF library. See above. If you want to build the tiff
+# converters, you must have the tiff library already installed.
+
+TIFFLIB = NONE
+TIFFHDR_DIR =
+
+#TIFFLIB = libtiff.so
+#TIFFHDR_DIR = /usr/include/libtiff
+#NetBSD:
+#TIFFLIB = $(LOCALBASE)/lib/libtiff.so
+#TIFFHDR_DIR = $(LOCALBASE)/include
+# OSF, Tru64:
+#TIFFLIB = /usr/local1/DEC/lib/libtiff.so
+#TIFFHDR_DIR = /usr/local1/DEC/include
+
+# If your Tiff library depends on libraries other than libc and libm,
+# put the required linker options here.
+TIFFLIB_LDFLAGS =
+# John Milton <jmilton@fundsxpress.com> in September 2000 and
+# John Bartelt <bartelt@SLAC.Stanford.EDU> in August 2002 reported
+# needing libz with libtiff 3.5.5 (with and without LZW patch):
+#TIFFLIB_LDFLAGS = -lz
+
+# The JPEG library. See above. If you want to build the jpeg
+# converters you must have the jpeg library already installed.
+
+# Tiff files can use JPEG compression, so the Tiff library can reference
+# the JPEG library. If your Tiff library references a dynamic JPEG
+# library, you must specify at least JPEGLIB here, or the Tiff
+# converters will not build. Note that your Tiff library may have the
+# JPEG stuff statically linked in, in which case you won't need
+# JPEGLIB in order to build the Tiff converters.
+
+JPEGLIB = NONE
+JPEGHDR_DIR =
+#JPEGLIB = libjpeg.so
+#JPEGHDR_DIR = /usr/include/jpeg
+# Netbsd:
+#JPEGLIB = ${LOCALBASE}/lib/libjpeg.so
+#JPEGHDR_DIR = ${LOCALBASE}/include
+# OSF, Tru64:
+#JPEGLIB = /usr/local1/DEC/libjpeg.so
+#JPEGHDR_DIR = /usr/local1/DEC/include
+# Typical:
+#JPEGLIB = /usr/local/lib/libjpeg.so
+#JPEGHDR_DIR = /usr/local/include
+# Don't build JPEG stuff:
+#JPEGLIB = NONE
+
+
+# The PNG library. See above. If you want to build the PNG
+# converters you must have the PNG library already installed.
+
+# The PNG library, by convention starting around April 2002, gets installed
+# with names that include a version number, such as libpng10.a and header
+# files in /usr/include/libpng10.
+# option.
+PNGLIB = NONE
+PNGVER =
+#PNGLIB = libpng$(PNGVER).so
+#PNGHDR_DIR = /usr/include/libpng$(PNGVER)
+# NetBSD:
+#PNGLIB = $(LOCALBASE)/lib/libpng$(PNGVER).so
+#PNGHDR_DIR = $(LOCALBASE)/include
+# OSF/Tru64:
+#PNGLIB = /usr/local1/DEC/lib/libpng$(PNGVER).so
+#PNGHDR_DIR = /usr/local1/DEC/include
+
+# The zlib compression library. See above. You need it to build
+# anything that needs the PNG library (see above). If you selected
+# NONE for the PNG library, it doesn't matter what you specify here --
+# it won't get used.
+
+ZLIB = NONE
+ZHDR_DIR =
+#ZLIB = libz.so
+
+# The JBIG lossless image compression library (aka JBIG-KIT):
+
+JBIGLIB = $(BUILDDIR)/converter/other/jbig/libjbig.a
+JBIGHDR_DIR = $(SRCDIR)/converter/other/jbig
+
+# The Jasper JPEG-2000 image compression library (aka JasPer):
+JASPERLIB = $(INTERNAL_JASPERLIB)
+JASPERHDR_DIR = $(INTERNAL_JASPERHDR_DIR)
+
+# And the Utah Raster Toolkit (aka URT aka RLE) library:
+
+URTLIB = $(BUILDDIR)/urt/librle.a
+URTHDR_DIR = $(SRCDIR)/urt
+
+# The Linux SVGA library (Svgalib) is a facility for displaying graphics
+# on the Linux console. It is required by Ppmsvgalib.
+
+LINUXSVGALIB = NONE
+LINUXSVGAHDR_DIR =
+
+#LINUXSVGALIB_DIR =
+#LINUXSVGAHDR_DIR = /usr/include/vgalib
+
+# These are -l options to link in the network libraries. Often, these are
+# built into the standard C library, so this can be null. If you don't
+# want any network functions, make it NONE. The only thing that requires
+# network functions is the option in ppmtompeg to run it on multiple
+# computers simultaneously.
+
+NETWORKLD =
+# Solaris, SunOS:
+#NETWORKLD = -lsocket -lnsl
+# SCO:
+#NETWORKLD = -lsocket, -lresolv
+# Don't build network functions:
+#DJGPP/Windows, Tru64:
+# (there's some minor header problem that prevents network functions from
+# building on Tru64 2000.10.06)
+#NETWORKLD = NONE
+
+VMS =
+#VMS:
+#VMS = yes
+
+# The following variables are used only by 'make install' (and the
+# variants of it). Paths here don't, for example, get built into any
+# programs.
+
+# File permissions for installed files.
+# Note that on some systems (e.g. Solaris), 'install' can't use the
+# mnemonic permissions - you have to use octal.
+
+# binaries (pbmmake, etc)
+INSTALL_PERM_BIN = 755 # u=rwx,go=rx
+# shared libraries (libpbm.so, etc)
+INSTALL_PERM_LIBD = 755 # u=rwx,go=rx
+# static libraries (libpbm.a, etc)
+INSTALL_PERM_LIBS = 644 # u=rw,go=r
+# header files (pbm.h, etc)
+INSTALL_PERM_HDR = 644 # u=rw,go=r
+# man pages (pbmmake.1, etc)
+INSTALL_PERM_MAN = 644 # u=rw,go=r
+# data files (pnmtopalm color maps, etc)
+INSTALL_PERM_DATA = 644 # u=rw,go=r
+
+# Specify the suffix that want the man pages to have.
+
+SUFFIXMANUALS1 = 1
+SUFFIXMANUALS3 = 3
+SUFFIXMANUALS5 = 5
+
+#NETPBMLIBTYPE tells the kind of libraries that will get built to hold the
+#Netpbm library functions. The value is used only in make file tests.
+# "unixshared" means a unix-style shared library, typically named like
+# libxyz.so.2.3
+NETPBMLIBTYPE = unixshared
+# "unixstatic" means a unix-style static library, (like libxyz.a)
+#NETPBMLIBTYPE = unixstatic
+# "dll" means a Windows DLL shared library
+#NETPBMLIBTYPE = dll
+# "dylib" means a Darwin/Mac OS shared library
+#NETPBMLIBTYPE = dylib
+
+#NETPBMLIBSUFFIX is the suffix used on whatever kind of library is
+#selected above. All this is used for is to construct library names.
+#The make files never examine the actual value.
+NETPBMLIBSUFFIX = so
+# "a" is the suffix for unix-style static libraries. Also for AIX shared
+# libraries.
+#NETPBMLIBSUFFIX = a
+# For HP-UX shared libraries:
+#NETPBMLIBSUFFIX = sl
+# Darwin/Mac OS shared library:
+#NETPBMLIBSUFFIX = dylib
+# Windows shared library:
+#NETPBMLIBSUFFIX = dll
+
+#STATICLIB_TOO is "y" to signify that you want a static library built
+#and installed in addition to whatever library type you specified by
+#NETPBMLIBTYPE. If NETPBMLIBTYPE specified a static library,
+#STATICLIB_TOO simply has no effect.
+STATICLIB_TOO = y
+#STATICLIB_TOO = n
+
+#STATICLIBSUFFIX is the suffix that static libraries have. It's
+#meaningless if you aren't building static libraries.
+STATICLIBSUFFIX = a
+
+#SHLIBPREFIXLIST is a blank-delimited list of prefixes that a filename
+#of a shared library may have on this system. Traditionally, it's
+#just "lib", as in libc or libpbm. On Windows, though, varying
+#prefixes are used when multiple alternative forms of a library are
+#available. The first prefix in this list is what we use to name the
+#Netpbm shared libraries.
+SHLIBPREFIXLIST = lib
+#Cygwin:
+#SHLIBPREFIXLIST = cyg lib
+
+NETPBMSHLIBPREFIX = $(firstword $(SHLIBPREFIXLIST))
+
+#DLLVER is used to version the DLLs built on cygwin or other
+#windowsish platforms. We can't add this to LIBROOT, or we'd
+#version the static libs (which is bad). We can't add this
+#at the end of the name (like unix does with so numbers) because
+#windows will only load dlls whose name ends in "dll". So,
+#we have this variable, which becomes the end of the library "root" name
+#for DLLs only.
+DLLVER =
+#Cygwin
+#DLLVER = $(NETPBM_MAJOR_RELEASE)
+
+#NETPBM_DOCURL is the URL of the main documentation page for Netpbm.
+#This is a directory which contains a file for each Netpbm program,
+#library, and file type. E.g. The documentation for jpegtopnm might be in
+#http://netpbm.sourceforge.net/doc/jpegtopnm.html . This value gets
+#installed in the man pages (which say no more than to read the webpage)
+#and in the Webman netpbm.url file.
+NETPBM_DOCURL = http://netpbm.sourceforge.net/doc/
+#For a system with no web access, but a local copy of the doc:
+#NETPBM_DOCURL = file:/usr/doc/netpbm/
+
+# This is where everything goes when you do 'make package':
+PKGDIR = /tmp/netpbm
+
+
+
+####Lines above were copied from Makefile.config.in by 'configure'.
+####Lines below were added by 'configure' based on the GNU platform.
+DEFAULT_TARGET = nonmerge
+NETPBMLIBTYPE=unixshared
+NETPBMLIBSUFFIX=so
+STATICLIB_TOO=n
+CFLAGS = -pedantic -O3 -Wall -Wno-uninitialized -Wmissing-declarations -Wimplicit -Wwrite-strings
+CFLAGS_MERGE = -Wno-missing-declarations
+TIFFLIB = libtiff.so
+JPEGLIB = libjpeg.so
+PNGLIB = libpng.so
+ZLIB = libz.so
+LINUXSVGAHDR_DIR = /usr/include
+LINUXSVGALIB = /usr/lib/libvga.so
diff --git a/media-libs/netpbm/files/digest-netpbm-10.11.5 b/media-libs/netpbm/files/digest-netpbm-10.11.5
new file mode 100644
index 000000000000..c6a2172516e9
--- /dev/null
+++ b/media-libs/netpbm/files/digest-netpbm-10.11.5
@@ -0,0 +1 @@
+MD5 3a10f98234d81bd0731c721a3a2b2876 netpbm-10.11.5.tgz 1910762