summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-17 02:40:02 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-17 02:40:02 +0000
commitb8e77b5bc1237daa2bbc76a80dac647c4fcfde00 (patch)
tree866cbbf130a212be4ff66ab889a8789816caea0b /media-libs/libsdl
parentUpdated ebuild to include support for the mailsubdir by default set to (diff)
downloadhistorical-b8e77b5bc1237daa2bbc76a80dac647c4fcfde00.tar.gz
historical-b8e77b5bc1237daa2bbc76a80dac647c4fcfde00.tar.bz2
historical-b8e77b5bc1237daa2bbc76a80dac647c4fcfde00.zip
resurrected an old one
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog9
-rw-r--r--media-libs/libsdl/libsdl-1.2.3-r1.ebuild123
2 files changed, 131 insertions, 1 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index e72354b25d5b..9688aa525bbd 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libsdl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.8 2002/07/23 22:10:34 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.9 2002/08/17 02:40:02 seemant Exp $
+
+*libsdl-1.2.3-r1 (16 Aug 2002)
+
+ 16 Aug 2002; Seemant Kulleen <seemant@gentoo.org> libsdl-1.2.3-r1.ebuild :
+
+ resurrected as the newer one seems to be problematic for creasy@pandora.be
+ (Kristof) in bug #3762
*libsdl-1.2.4-20020601 (7 Jun 2002)
diff --git a/media-libs/libsdl/libsdl-1.2.3-r1.ebuild b/media-libs/libsdl/libsdl-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..75fb452d911f
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.3-r1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.3-r1.ebuild,v 1.4 2002/08/17 02:40:02 seemant Exp $
+
+S=${WORKDIR}/SDL-${PV}
+DESCRIPTION="Simple Direct Media Layer"
+SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
+HOMEPAGE="http://www.libsdl.org/"
+
+DEPEND="virtual/glibc
+ >=dev-lang/nasm-0.98
+ >=media-libs/audiofile-0.1.9
+ opengl? ( virtual/opengl )
+ svga? ( >=media-libs/svgalib-1.4.2 )
+ esd? ( >=media-sound/esound-0.2.19 )
+ X? ( virtual/x11 )
+ arts? ( >=kde-base/kdelibs-2.0.1 )
+ nas? ( media-libs/nas )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ alsa? ( media-libs/alsa-lib )
+ directfb? ( >=dev-libs/DirectFB-0.9.7 )"
+
+RDEPEND="virtual/glibc
+ >=media-libs/audiofile-0.1.9
+ opengl? ( virtual/opengl )
+ svga? ( >=media-libs/svgalib-1.4.2 )
+ esd? ( >=media-sound/esound-0.2.19 )
+ X? ( virtual/x11 )
+ arts? ( >=kde-base/kdelibs-2.0.1 )
+ nas? ( media-libs/nas )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ alsa? ( media-libs/alsa-lib )
+ directfb? ( >=dev-libs/DirectFB-0.9.7 )"
+
+src_compile() {
+ local myconf
+ if [ -z "`use esd`" ]
+ then
+ myconf="--disable-esd"
+ else
+ myconf="--enable-esd"
+ fi
+ if [ -z "`use xv`" ]
+ then
+ myconf="${myconf} --disable-video-x11-xv"
+ else
+ myconf="${myconf} --enable-video-x11-xv"
+ fi
+ if [ -z "`use arts`" ]
+ then
+ myconf="${myconf} --disable-arts"
+ else
+ myconf="${myconf} --enable-arts"
+ fi
+
+ if [ -z "`use nas`" ]
+ then
+ myconf="${myconf} --disable-nas"
+ else
+ myconf="${myconf} --enable-nas"
+ fi
+ if [ -z "`use X`" ]
+ then
+ myconf="${myconf} --disable-video-x11"
+ else
+ myconf="${myconf} --enable-video-x11"
+ fi
+ if [ "`use svga`" ]
+ then
+ myconf="${myconf} --enable-video-svga"
+ else
+ myconf="${myconf} --disable-video-svga"
+ fi
+ if [ -z "`use fbcon`" ]
+ then
+ myconf="${myconf} --disable-video-fbcon"
+ else
+ myconf="${myconf} --enable-video-fbcon"
+ fi
+ if [ "`use aalib`" ]
+ then
+ myconf="${myconf} --enable-video-aalib"
+ else
+ myconf="${myconf} --disable-video-aalib"
+ fi
+ if [ "`use ggi`" ]
+ then
+ myconf="${myconf} --enable-video-ggi"
+ else
+ myconf="${myconf} --disable-video-ggi"
+ fi
+ if [ -z "`use opengl`" ]
+ then
+ myconf="${myconf} --disable-video-opengl"
+ else
+ myconf="${myconf} --enable-video-opengl"
+ fi
+ if [ -z "`use directfb`" ]
+ then
+ myconf="${myconf} --disable-video-directfb"
+ else
+ myconf="${myconf} --enable-video-directfb"
+ fi
+ if [ -n "`use alsa`" ]
+ then
+ myconf="${myconf} --enable-alsa"
+ else
+ myconf="${myconf} --disable-alsa"
+ fi
+ ./configure --host=${CHOST} --enable-input-events --prefix=/usr --mandir=/usr/share/man ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install || die
+ preplib /usr
+ dodoc BUGS COPYING CREDITS README* TODO WhatsNew
+ docinto html
+ dodoc *.html
+ docinto html/docs
+ dodoc docs/*.html
+}