summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2009-01-31 10:36:45 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2009-01-31 10:36:45 +0000
commitec5c3cda5ee664b529c8b075f45384bb7f327a3c (patch)
tree7687fc307df150b0400be9c206881b6e41a2503b /media-libs/libdc1394/libdc1394-1.2.2.ebuild
parentRemove obsolete ebuilds (diff)
downloadhistorical-ec5c3cda5ee664b529c8b075f45384bb7f327a3c.tar.gz
historical-ec5c3cda5ee664b529c8b075f45384bb7f327a3c.tar.bz2
historical-ec5c3cda5ee664b529c8b075f45384bb7f327a3c.zip
Version bump, + new patch to disable obsolete raw capture (required for bug #231908)
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'media-libs/libdc1394/libdc1394-1.2.2.ebuild')
-rw-r--r--media-libs/libdc1394/libdc1394-1.2.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/libdc1394/libdc1394-1.2.2.ebuild b/media-libs/libdc1394/libdc1394-1.2.2.ebuild
new file mode 100644
index 000000000000..7f68ea86d091
--- /dev/null
+++ b/media-libs/libdc1394/libdc1394-1.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdc1394/libdc1394-1.2.2.ebuild,v 1.1 2009/01/31 10:36:45 stefaan Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Library to interface with IEEE 1394 cameras following the IIDC specification"
+HOMEPAGE="http://sourceforge.net/projects/libdc1394/"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X"
+
+RDEPEND="sys-libs/libraw1394
+ X? ( x11-libs/libSM x11-libs/libXv )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+ if ! use X; then
+ epatch "${FILESDIR}"/${P}-nox11.patch
+ fi
+ epatch "${FILESDIR}"/${PN}-disable-raw-capture.patch
+}
+
+src_compile() {
+ if has_version '>=sys-libs/glibc-2.4' ; then
+ append-flags "-DCLK_TCK=CLOCKS_PER_SEC"
+ fi
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc NEWS README AUTHORS
+}