summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-04 13:15:03 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-04 13:15:03 +0000
commite2fe15203a8e79ee3f43fcc7124f4ccc4e2f89b5 (patch)
tree1f57d4abe78b757978ba3e8b4c8e226f10306adb /media-libs/id3lib
parentGCC3.1 compile fixes tested on 2.95.3 too (diff)
downloadhistorical-e2fe15203a8e79ee3f43fcc7124f4ccc4e2f89b5.tar.gz
historical-e2fe15203a8e79ee3f43fcc7124f4ccc4e2f89b5.tar.bz2
historical-e2fe15203a8e79ee3f43fcc7124f4ccc4e2f89b5.zip
GCC-3.1 fixes
Diffstat (limited to 'media-libs/id3lib')
-rw-r--r--media-libs/id3lib/files/digest-id3lib-3.8.0_pre2-r21
-rw-r--r--media-libs/id3lib/id3lib-3.8.0_pre2-r2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/id3lib/files/digest-id3lib-3.8.0_pre2-r2 b/media-libs/id3lib/files/digest-id3lib-3.8.0_pre2-r2
new file mode 100644
index 000000000000..72c7aeafef6d
--- /dev/null
+++ b/media-libs/id3lib/files/digest-id3lib-3.8.0_pre2-r2
@@ -0,0 +1 @@
+MD5 48444a1eb634c034c05388e8e2bb5024 id3lib-3.8.0pre2.tar.gz 680219
diff --git a/media-libs/id3lib/id3lib-3.8.0_pre2-r2.ebuild b/media-libs/id3lib/id3lib-3.8.0_pre2-r2.ebuild
new file mode 100644
index 000000000000..54d3803271e1
--- /dev/null
+++ b/media-libs/id3lib/id3lib-3.8.0_pre2-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/id3lib-3.8.0_pre2-r2.ebuild,v 1.1 2002/06/04 13:15:03 lostlogic Exp $
+
+A=${PN}-3.8.0pre2.tar.gz
+S=${WORKDIR}/${PN}-3.8.0pre2
+DESCRIPTION="Id3 library for C/C++"
+SRC_URI="mirror://sourceforge/id3lib/${A}"
+HOMEPAGE="http://id3lib.sourceforge.net/"
+LICENSE=GPL
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ if [ "`gcc --version | cut -f1 -d.`" -eq 3 ] ||
+ ([ -n "${CXX}" ] && [ "`${CXX} --version | cut -f1 -d.`" -eq 3 ]) ||
+ [ "`gcc --version|grep gcc|cut -f1 -d.|cut -f3 -d\ `" -eq 3 ]
+ then
+ cd ${S}
+ # Patch for compilation with gcc-3.0.x thanks to Dirk Jagdmann (doj),
+ # and me (fixed the const char** in utils.cpp)
+ #
+ # Azarah - 5 May 2002
+ patch -p1 <${FILESDIR}/${P}-gcc3.patch || die
+ fi
+}
+
+src_compile() {
+
+ CPPFLAGS="-Wno-deprecated" ./configure --host=${CHOST} --includedir="" --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog HISTORY INSTALL README THANKS TODO
+# some example programs to be placed in docs dir.
+ make clean
+ cp -a examples ${D}/usr/share/doc/${PF}/examples
+}
+