summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-04-28 20:00:37 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-04-28 20:00:37 +0000
commit96dd3d2c17f4f08d41277b590f849a2098c66383 (patch)
tree8d691c64812ce4c1017d3dacd9a48b4fdf3f4959 /media-libs/herqq/herqq-1.0.0-r1.ebuild
parentStable on amd64 wrt bug #349847 (diff)
downloadhistorical-96dd3d2c17f4f08d41277b590f849a2098c66383.tar.gz
historical-96dd3d2c17f4f08d41277b590f849a2098c66383.tar.bz2
historical-96dd3d2c17f4f08d41277b590f849a2098c66383.zip
[media-libs/herqq] added multilib support (fixes bug #365155)
Package-Manager: portage-2.1.9.42/cvs/Linux i686
Diffstat (limited to 'media-libs/herqq/herqq-1.0.0-r1.ebuild')
-rw-r--r--media-libs/herqq/herqq-1.0.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/herqq/herqq-1.0.0-r1.ebuild b/media-libs/herqq/herqq-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..03224eb60a05
--- /dev/null
+++ b/media-libs/herqq/herqq-1.0.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/herqq/herqq-1.0.0-r1.ebuild,v 1.1 2011/04/28 20:00:37 ottxor Exp $
+
+EAPI="3"
+
+inherit base multilib qt4-r2
+
+DESCRIPTION="A software library for building UPnP devices"
+HOMEPAGE="http://www.herqq.org"
+SRC_URI="mirror://sourceforge/hupnp/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+#no release of QtSolutions using bundled libQtSolutions_SOAP
+RDEPEND="x11-libs/qt-core"
+DEPEND="${RDEPEND}"
+
+DOCS=( hupnp/ChangeLog )
+HTML_DOCS=( hupnp/docs/html/ )
+
+src_prepare() {
+ find . -name "*.pro" -exec sed -i "s@PREFIX/lib@PREFIX/$(get_libdir)@" {} \; || die
+}
+
+src_configure() {
+ eqmake4 herqq.pro PREFIX="${EPREFIX}/usr" || die
+}
+
+src_install() {
+ qt4-r2_src_install || die
+ if use doc; then
+ base_src_install_docs || die
+ fi
+}