summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-21 00:39:39 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-21 00:39:39 +0000
commit8ac468813e2b2348ccf55398b7fccddc67f2ed15 (patch)
tree389e09bf9ef36e1195c26147158653101eb61e4e /media-libs/gdk-pixbuf
parentUpdated package to new version (diff)
downloadhistorical-8ac468813e2b2348ccf55398b7fccddc67f2ed15.tar.gz
historical-8ac468813e2b2348ccf55398b7fccddc67f2ed15.tar.bz2
historical-8ac468813e2b2348ccf55398b7fccddc67f2ed15.zip
new version
Diffstat (limited to 'media-libs/gdk-pixbuf')
-rw-r--r--media-libs/gdk-pixbuf/ChangeLog4
-rw-r--r--media-libs/gdk-pixbuf/files/digest-gdk-pixbuf-0.17.01
-rw-r--r--media-libs/gdk-pixbuf/gdk-pixbuf-0.17.0.ebuild59
3 files changed, 63 insertions, 1 deletions
diff --git a/media-libs/gdk-pixbuf/ChangeLog b/media-libs/gdk-pixbuf/ChangeLog
index 6350aa769bd2..a19307fe94dd 100644
--- a/media-libs/gdk-pixbuf/ChangeLog
+++ b/media-libs/gdk-pixbuf/ChangeLog
@@ -1,6 +1,8 @@
# ChangeLog for media-libs/gdk-pixbuf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/ChangeLog,v 1.8 2002/04/13 01:12:34 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/ChangeLog,v 1.9 2002/04/21 00:39:39 azarah Exp $
+
+*gdk-pixbuf-0.17.0 (20 Apr 2002)
*gdk-pixbuf-0.16.0-r9 (12 Apr 2002)
diff --git a/media-libs/gdk-pixbuf/files/digest-gdk-pixbuf-0.17.0 b/media-libs/gdk-pixbuf/files/digest-gdk-pixbuf-0.17.0
new file mode 100644
index 000000000000..c81ac586158d
--- /dev/null
+++ b/media-libs/gdk-pixbuf/files/digest-gdk-pixbuf-0.17.0
@@ -0,0 +1 @@
+MD5 021914ad9104f265527c28220315e542 gdk-pixbuf-0.17.0.tar.gz 547194
diff --git a/media-libs/gdk-pixbuf/gdk-pixbuf-0.17.0.ebuild b/media-libs/gdk-pixbuf/gdk-pixbuf-0.17.0.ebuild
new file mode 100644
index 000000000000..06ece9022dcd
--- /dev/null
+++ b/media-libs/gdk-pixbuf/gdk-pixbuf-0.17.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.17.0.ebuild,v 1.1 2002/04/21 00:39:39 azarah Exp $
+
+#provide Xmake and Xemake
+. /usr/portage/eclass/inherit.eclass
+inherit virtualx
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Image Library"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz"
+
+DEPEND="media-libs/jpeg
+ media-libs/tiff
+ >=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/libpng-1.2.1
+ >=gnome-base/gnome-libs-1.4.1.2-r1"
+# We need gnome-libs here, else gnome support do not get compiled into
+# gdk-pixbuf (the GnomeCanvasPixbuf library )
+
+SLOT="0"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cp ${S}/demo/Makefile.in ${S}/demo/Makefile.in.orig
+ sed -e 's:LDADD = :LDADD = $(LIBJPEG) $(LIBTIFF) $(LIBPNG) :' \
+ ${S}/demo/Makefile.in.orig > ${S}/demo/Makefile.in
+}
+
+src_compile() {
+
+ #update libtool, else we get the "relink bug"
+ libtoolize --copy --force
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/X11/gdk-pixbuf || die
+
+ #build needs to be able to
+ #connect to an X display.
+ Xemake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc/X11/gdk-pixbuf \
+ install || die
+
+ #fix permissions on the loaders
+ chmod a+rx ${D}/usr/lib/gdk-pixbuf/loaders
+ chmod a+r ${D}/usr/lib/gdk-pixbuf/loaders/*
+
+ dodoc AUTHORS COPYING* ChangeLog INSTALL README NEWS TODO
+}
+