summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-06-11 23:41:27 +0000
committerMarinus Schraal <foser@gentoo.org>2003-06-11 23:41:27 +0000
commite165c57a8b2bcd35e1e68691b624f10a7465d1a1 (patch)
treeb903f1952a5600c29bb5cb3ccd3f7cc93574c8e7 /media-libs/fontconfig
parentnew version (diff)
downloadhistorical-e165c57a8b2bcd35e1e68691b624f10a7465d1a1.tar.gz
historical-e165c57a8b2bcd35e1e68691b624f10a7465d1a1.tar.bz2
historical-e165c57a8b2bcd35e1e68691b624f10a7465d1a1.zip
new version
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/Manifest4
-rw-r--r--media-libs/fontconfig/files/digest-fontconfig-2.2.11
-rw-r--r--media-libs/fontconfig/files/patch/fontconfig-2.2-local_fontdir-r1.patch3
-rw-r--r--media-libs/fontconfig/fontconfig-2.2.1.ebuild107
4 files changed, 112 insertions, 3 deletions
diff --git a/media-libs/fontconfig/Manifest b/media-libs/fontconfig/Manifest
index 192599246e17..8d84ccdf2d6f 100644
--- a/media-libs/fontconfig/Manifest
+++ b/media-libs/fontconfig/Manifest
@@ -1,6 +1,6 @@
-MD5 bba5dcfb8bae13fc9ab69fb08c3d5eb7 fontconfig-2.2.1.ebuild 3113
+MD5 5e02aaa4f54dd5df44a7a5542340eb35 fontconfig-2.2.1.ebuild 3108
MD5 7fe12a982373d6e17ea1835252cd18d7 fontconfig-2.1-r1.ebuild 2651
-MD5 48c33a525074a67757eac7895ab52649 ChangeLog 6412
+MD5 193d8b2f416f8f16b39c72420619b416 ChangeLog 6410
MD5 7bff8b11e915517f7f5097d2fa1a4d31 fontconfig-2.2.0-r2.ebuild 3329
MD5 fd11506a1969709b4d447084344006ba files/digest-fontconfig-2.1-r1 140
MD5 82f9bbcca9f5c665c6610cbaace58579 files/digest-fontconfig-2.2.0-r2 145
diff --git a/media-libs/fontconfig/files/digest-fontconfig-2.2.1 b/media-libs/fontconfig/files/digest-fontconfig-2.2.1
new file mode 100644
index 000000000000..6daeaa00b0dc
--- /dev/null
+++ b/media-libs/fontconfig/files/digest-fontconfig-2.2.1
@@ -0,0 +1 @@
+MD5 a6a856606809b9ebfcc37a6380dcd6df fontconfig-2.2.1.tar.gz 613391
diff --git a/media-libs/fontconfig/files/patch/fontconfig-2.2-local_fontdir-r1.patch b/media-libs/fontconfig/files/patch/fontconfig-2.2-local_fontdir-r1.patch
index ee0219f0d279..3eb7aa0438f9 100644
--- a/media-libs/fontconfig/files/patch/fontconfig-2.2-local_fontdir-r1.patch
+++ b/media-libs/fontconfig/files/patch/fontconfig-2.2-local_fontdir-r1.patch
@@ -1,11 +1,12 @@
diff -ur fontconfig-2.1.94/fonts.conf.in fontconfig-2.1.94.patched/fonts.conf.in
--- fontconfig-2.1.94/fonts.conf.in 2003-04-16 23:57:38.000000000 +0200
+++ fontconfig-2.1.94.patched/fonts.conf.in 2003-04-18 02:59:54.000000000 +0200
-@@ -25,6 +25,9 @@
+@@ -25,6 +25,10 @@
<dir>@FC_DEFAULT_FONTS@</dir>
@FC_FONTPATH@
+ <dir>/usr/share/fonts</dir>
++ <dir>/usr/local/share/fonts</dir>
+ <dir>/usr/X11R6/lib/X11/fonts/75dpi</dir>
+ <dir>/usr/X11R6/lib/X11/fonts/100dpi</dir>
<dir>~/.fonts</dir>
diff --git a/media-libs/fontconfig/fontconfig-2.2.1.ebuild b/media-libs/fontconfig/fontconfig-2.2.1.ebuild
new file mode 100644
index 000000000000..bed2390fbd7b
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.2.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.1.ebuild,v 1.1 2003/06/11 23:41:08 foser Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A library for configuring and customizing font access."
+HOMEPAGE="http://fontconfig.org/"
+SRC_URI="http://fontconfig.org/release/${P}.tar.gz"
+
+IUSE=""
+LICENSE="fontconfig"
+SLOT="1.0"
+
+# Note about keywords here:
+# >=kde-base/kdebase-3.1.2 has a fix needed to work with fontconfig 2.2 and higher,
+# so don't mark this ebuild stable on archs where kde 3.1.2 is only ~.
+# this of course doesn't apply to archs where kde has no keywords at all :-)
+# -- danarmak@gentoo.org
+KEYWORDS="~x86 ~alpha ~ppc ~sparc ~mips ~hppa ~arm"
+
+DEPEND=">=sys-apps/sed-4
+ >=media-libs/freetype-2.1.4
+ >=dev-libs/expat-1.95.3
+ >=sys-apps/ed-0.2"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ local PPREFIX="${FILESDIR}/patch/${PN}"
+
+ # Some patches from Redhat
+ epatch ${PPREFIX}-2.1-slighthint.patch
+ # Add our local fontpaths (duh dont forget!)
+ epatch ${PPREFIX}-2.2-local_fontdir-r1.patch
+ # Blacklist some fonts that break fontconfig
+ epatch ${PPREFIX}-2.2-blacklist.patch
+ # Remove the subpixel test from local.conf (#12757)
+ epatch ${PPREFIX}-2.2-remove_subpixel_test.patch
+
+ # The date can be troublesome
+ sed -i "s:\`date\`::" configure
+}
+
+src_compile() {
+
+ [ "${ARCH}" == "alpha" -a "${CC}" == "ccc" ] && \
+ die "Dont compile fontconfig with ccc, it doesnt work very well"
+
+ # disable docs only disables docs generation (!)
+ econf --disable-docs \
+ --with-docdir=${D}/usr/share/doc/${PF} \
+ --x-includes=/usr/X11R6/include \
+ --x-libraries=/usr/X11R6/lib \
+ --with-default-fonts=/usr/X11R6/lib/X11/fonts/Type1 || die
+
+ # this triggers sandbox, we do this ourselves
+ sed -i "s:fc-cache/fc-cache -f -v:sleep 0:" Makefile
+
+ emake || die
+
+ # remove Luxi TTF fonts from the list, the Type1 are much better
+ sed -i "s:<dir>/usr/X11R6/lib/X11/fonts/TTF</dir>::" fonts.conf
+}
+
+src_install() {
+ einstall confdir=${D}/etc/fonts \
+ datadir=${D}/usr/share \
+ docdir=${D}/usr/share/doc/${P} || die
+
+ insinto /etc/fonts
+ doins ${S}/fonts.conf
+ newins ${S}/fonts.conf fonts.conf.new
+
+ cd ${S}
+
+ mv fc-cache/fc-cache.man fc-cache/fc-cache.1
+ mv fc-list/fc-list.man fc-list/fc-list.1
+ mv src/fontconfig.man src/fontconfig.3
+ for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
+ do
+ doman ${x}
+ done
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ # Changes should be made to /etc/fonts/local.conf, and as we had
+ # too much problems with broken fonts.conf, we force update it ...
+ # <azarah@gentoo.org> (11 Dec 2002)
+ ewarn "Please make fontconfig related changes to /etc/fonts/local.conf,"
+ ewarn "and NOT to /etc/fonts/fonts.conf, as it will be replaced!"
+ mv -f ${ROOT}/etc/fonts/fonts.conf.new ${ROOT}/etc/fonts/fonts.conf
+ rm -f ${ROOT}/etc/fonts/._cfg????_fonts.conf
+
+ if [ "${ROOT}" = "/" ]
+ then
+ echo
+ einfo "Creating font cache..."
+ HOME="/root" /usr/bin/fc-cache -f
+ fi
+}