summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-11 19:58:09 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-11 19:58:09 +0000
commit8ef4afdfe3cd1dcffdb5afb49b19038af81e774e (patch)
tree19f04edbc3e2b262dc5c500cc65095f66ab8bd6f /media-libs/fontconfig
parentversion bump (diff)
downloadhistorical-8ef4afdfe3cd1dcffdb5afb49b19038af81e774e.tar.gz
historical-8ef4afdfe3cd1dcffdb5afb49b19038af81e774e.tar.bz2
historical-8ef4afdfe3cd1dcffdb5afb49b19038af81e774e.zip
new version
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/ChangeLog11
-rw-r--r--media-libs/fontconfig/files/digest-fontconfig-2.11
-rw-r--r--media-libs/fontconfig/files/patch/fontconfig-2.1-slighthint.patch57
-rw-r--r--media-libs/fontconfig/files/patch/fontconfig-2.1-x11fontpath-date-configure.patch20
-rw-r--r--media-libs/fontconfig/fontconfig-2.1.ebuild91
5 files changed, 177 insertions, 3 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index 8d3fad9dfa8b..01f10aad8b98 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for media-libs/fontconfig
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.10 2002/12/09 04:26:10 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.11 2002/12/11 19:58:09 azarah Exp $
-\* Autoupdate keywords (12-6-02)
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
+*fontconfig-2.1 (11 Dec 2002)
+
+ 11 Dec 2002; Martin Schlemmer <azarah@gentoo.org> fontconfig-2.1.ebuild :
+ New version.
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> :
+ Changed sparc ~sparc keywords
02 Dec 2002; foser <foser@gentoo.org> fontconfig-2.0-r3.ebuild :
Depend on freetype-2.1.2-r2, as it fixes bug #10028.
diff --git a/media-libs/fontconfig/files/digest-fontconfig-2.1 b/media-libs/fontconfig/files/digest-fontconfig-2.1
new file mode 100644
index 000000000000..1952672e6a0d
--- /dev/null
+++ b/media-libs/fontconfig/files/digest-fontconfig-2.1
@@ -0,0 +1 @@
+MD5 2f2852c80924a9b5356c3037a471c1a1 fcpackage.2_1.tar.gz 544661
diff --git a/media-libs/fontconfig/files/patch/fontconfig-2.1-slighthint.patch b/media-libs/fontconfig/files/patch/fontconfig-2.1-slighthint.patch
new file mode 100644
index 000000000000..b26785aac5db
--- /dev/null
+++ b/media-libs/fontconfig/files/patch/fontconfig-2.1-slighthint.patch
@@ -0,0 +1,57 @@
+--- fontconfig/fontconfig/fontconfig.h.slighthint Sun Aug 11 14:10:41 2002
++++ fontconfig/fontconfig/fontconfig.h Mon Aug 12 16:23:51 2002
+@@ -55,6 +55,7 @@
+ #define FC_FOUNDRY "foundry" /* String */
+ #define FC_ANTIALIAS "antialias" /* Bool (depends) */
+ #define FC_HINTING "hinting" /* Bool (true) */
++#define FC_HINT_STYLE "hintstyle" /* Int */
+ #define FC_VERTICAL_LAYOUT "verticallayout" /* Bool (false) */
+ #define FC_AUTOHINT "autohint" /* Bool (false) */
+ #define FC_GLOBAL_ADVANCE "globaladvance" /* Bool (true) */
+@@ -102,6 +103,12 @@
+ #define FC_RGBA_VRGB 3
+ #define FC_RGBA_VBGR 4
+
++/* hinting style */
++#define FC_HINT_NONE 0
++#define FC_HINT_SLIGHT 1
++#define FC_HINT_MEDIUM 2
++#define FC_HINT_FULL 3
++
+ typedef enum _FcType {
+ FcTypeVoid,
+ FcTypeInteger,
+--- fontconfig/src/fcdefault.c.slighthint Tue Jul 9 18:08:14 2002
++++ fontconfig/src/fcdefault.c Mon Aug 12 16:22:01 2002
+@@ -137,4 +137,9 @@
+ FcPatternAddString (pattern, FC_LANG, (FcChar8 *) lang);
+ }
+ }
++
++ if (FcPatternGet (pattern, FC_HINT_STYLE, 0, &v) == FcResultNoMatch)
++ {
++ FcPatternAddInteger (pattern, FC_HINT_STYLE, FC_HINT_FULL);
++ }
+ }
+--- fontconfig/src/fcname.c.slighthint Sun Aug 11 14:10:42 2002
++++ fontconfig/src/fcname.c Mon Aug 12 16:24:28 2002
+@@ -40,6 +40,7 @@
+ { FC_FOUNDRY, FcTypeString, },
+ /* { FC_CORE, FcTypeBool, }, */
+ { FC_ANTIALIAS, FcTypeBool, },
++ { FC_HINT_STYLE, FcTypeInteger, },
+ { FC_HINTING, FcTypeBool, },
+ { FC_VERTICAL_LAYOUT, FcTypeBool, },
+ { FC_AUTOHINT, FcTypeBool, },
+@@ -158,6 +158,11 @@
+ { (FcChar8 *) "vrgb", "rgba", FC_RGBA_VRGB },
+ { (FcChar8 *) "vbgr", "rgba", FC_RGBA_VBGR },
+ { (FcChar8 *) "none", "rgba", FC_RGBA_NONE },
++
++ { (FcChar8 *) "hintnone", "hintstyle", FC_HINT_NONE },
++ { (FcChar8 *) "hintslight", "hintstyle", FC_HINT_SLIGHT },
++ { (FcChar8 *) "hintmedium", "hintstyle", FC_HINT_MEDIUM },
++ { (FcChar8 *) "hintfull", "hintstyle", FC_HINT_FULL },
+ };
+
+ #define NUM_FC_CONSTANTS (sizeof _FcBaseConstants/sizeof _FcBaseConstants[0])
diff --git a/media-libs/fontconfig/files/patch/fontconfig-2.1-x11fontpath-date-configure.patch b/media-libs/fontconfig/files/patch/fontconfig-2.1-x11fontpath-date-configure.patch
new file mode 100644
index 000000000000..9e15ddd4afa8
--- /dev/null
+++ b/media-libs/fontconfig/files/patch/fontconfig-2.1-x11fontpath-date-configure.patch
@@ -0,0 +1,20 @@
+--- fcpackage.2_1/fontconfig/setfontdirs.orig 2002-08-01 18:17:33.000000000 +0200
++++ fcpackage.2_1/fontconfig/setfontdirs 2002-12-11 21:31:37.000000000 +0200
+@@ -6,15 +6,15 @@
+ export LANG
+ FONTDIRS=fontdirs$$
+ trap "rm $FONTDIRS" 0
+-sh ./findfonts ${1+"$@"} > $FONTDIRS
++sh ./findfonts ${1+"$@"} |awk '!/\/usr\/X11R6\/lib\/X11\/fonts/ { print }' > $FONTDIRS
+ cp fonts.conf.in fonts.conf
+ chmod +w fonts.conf
+ ed fonts.conf << EOF
+ /FONTPATH_END/a
+-<!-- Font directory list configured on `date` -->
+ .
+ +r $FONTDIRS
+ a
++ <dir>/usr/X11R6/lib/X11/fonts</dir>
+ <dir>~/.fonts</dir>
+
+ .
diff --git a/media-libs/fontconfig/fontconfig-2.1.ebuild b/media-libs/fontconfig/fontconfig-2.1.ebuild
new file mode 100644
index 000000000000..4b4a4eed2199
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.1.ebuild,v 1.1 2002/12/11 19:58:09 azarah Exp $
+
+inherit debug eutils
+
+S="${WORKDIR}/fcpackage.${PV/\./_}/fontconfig"
+DESCRIPTION="A library for configuring and customizing font access."
+SRC_URI="http://fontconfig.org/release/fcpackage.${PV/\./_}.tar.gz"
+HOMEPAGE="http://fontconfig.org/"
+
+LICENSE="fontconfig"
+SLOT="1.0"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc"
+
+# Seems like patches in freetype-2.1.2-r2 fixes bug #10028
+DEPEND=">=media-libs/freetype-2.1.2-r2
+ >=dev-libs/expat-1.95.3
+ >=sys-apps/ed-0.2"
+
+
+fc_setup() {
+ # Do not use 'cc' to compile
+ [ ! -n "${CC}" ] && export CC="gcc" || :
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ local PPREFIX="${FILESDIR}/patch/${PN}"
+ #einfo "Applying patches..."
+ # Some patches from Redhat
+ epatch ${PPREFIX}-2.0-defaultconfig.patch
+ epatch ${PPREFIX}-2.1-slighthint.patch
+ # Blacklist certain fonts that freetype can't handle
+ epatch ${PPREFIX}-0.0.1.020826.1330-blacklist.patch
+ # Fix config script to alway include X11 fontpath and remove date
+ epatch ${PPREFIX}-2.1-x11fontpath-date-configure.patch
+}
+
+src_compile() {
+ fc_setup
+
+ econf \
+ --x-includes=/usr/X11R6/include \
+ --x-libraries=/usr/X11R6/lib || die
+
+ emake || die
+}
+
+src_install() {
+ fc_setup
+
+ einstall confdir=${D}/etc/fonts \
+ datadir=${D}/usr/share || die
+
+ insinto /etc/fonts
+ doins ${S}/fonts.conf
+ newins ${S}/fonts.conf fonts.conf.new
+
+ cd ${S}
+
+ mv fc-cache/fc-cache.man fc-cache/fc-cache.1
+ mv fc-list/fc-list.man fc-list/fc-list.1
+ mv src/fontconfig.man src/fontconfig.3
+ for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
+ do
+ doman ${x}
+ done
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ # Changes should be made to /etc/fonts/local.conf, and as we had
+ # too much problems with broken fonts.conf, we force update it ...
+ # <azarah@gentoo.org> (11 Dec 2002)
+ ewarn "Please make fontconfig related changes to /etc/fonts/local.conf,"
+ ewarn "and NOT to /etc/fonts/fonts.conf, as it will be replaced!"
+ mv -f ${ROOT}/etc/fonts/fonts.conf.new ${ROOT}/etc/fonts/fonts.conf
+ rm -f ${ROOT}/etc/fonts/._cfg????_fonts.conf
+
+ if [ "${ROOT}" = "/" ]
+ then
+ echo
+ einfo "Creating font cache..."
+ HOME="/root" /usr/bin/fc-cache -f
+ fi
+}
+