summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-11-20 22:00:27 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-11-20 22:00:27 +0000
commit900b7bbbbbc0936442332392c8bbcc8d8ea7b68f (patch)
tree1792831b38d9e036e3f4849fd91909235418ab1e /media-libs/flac
parentbump ssh to openssh-3.0.1_p1 (diff)
downloadhistorical-900b7bbbbbc0936442332392c8bbcc8d8ea7b68f.tar.gz
historical-900b7bbbbbc0936442332392c8bbcc8d8ea7b68f.tar.bz2
historical-900b7bbbbbc0936442332392c8bbcc8d8ea7b68f.zip
new lossless audio encoder with xmms input plugin
Diffstat (limited to 'media-libs/flac')
-rw-r--r--media-libs/flac/files/digest-flac-1.0.11
-rw-r--r--media-libs/flac/flac-1.0.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/flac/files/digest-flac-1.0.1 b/media-libs/flac/files/digest-flac-1.0.1
new file mode 100644
index 000000000000..8f5f8b52fb5c
--- /dev/null
+++ b/media-libs/flac/files/digest-flac-1.0.1
@@ -0,0 +1 @@
+MD5 54e03732655274ff127080a2ec8248d6 flac-1.0.1-src.tar.gz 458752
diff --git a/media-libs/flac/flac-1.0.1.ebuild b/media-libs/flac/flac-1.0.1.ebuild
new file mode 100644
index 000000000000..0e524c7e0df4
--- /dev/null
+++ b/media-libs/flac/flac-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.0.1.ebuild,v 1.1 2001/11/20 22:00:27 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A free lossless audio encoder"
+SRC_URI="http://prdownloads.sourceforge.net/flac/${P}-src.tar.gz"
+HOMEPAGE="http://flac.sourceforge.net/"
+#flac has an optional xmms plugin. For now, we just depend on xmms. We can optimize this later.
+RDEPEND="virtual/glibc >=media-sound/xmms-1.2.5-r2 >=media-libs/libogg-1.0_rc2"
+DEPEND="virtual/glibc dev-lang/nasm sys-apps/gawk $RDEPEND"
+
+src_compile() {
+ cd ${S}
+ local myflags
+ [ `use sse` ] && myflags="--sse-os"
+ #--use-3dnow is documented but apparently not yet enabled.
+ #[ `use 3dnow` ] && myflags="$myflags --use-3dnow"
+ ./configure --prefix=/usr $myflags --host=$CHOST || die
+ cp Makefile Makefile.orig
+ #the man page ebuild requires docbook2man... yick!
+ sed -e 's:include man:include:g' Makefile.orig > Makefile
+ #emake seems to mess up the building of the xmms input plugin
+ make || die
+}
+src_install() {
+ #it looks like we need to run the xmms install first
+ ( cd src/plugin_xmms; make DESTDIR=${D} install )
+ make DESTDIR=${D} install
+}
+
+