summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-19 18:11:48 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-19 18:11:48 +0000
commite41d620026c9e1c607e5c66b4f37a6536c687b3e (patch)
tree2e1bccd1fbe4448d69e2464c90b9bf2f3fce3a7f /media-libs/allegromp3
parentMarked stable for alpha (diff)
downloadhistorical-e41d620026c9e1c607e5c66b4f37a6536c687b3e.tar.gz
historical-e41d620026c9e1c607e5c66b4f37a6536c687b3e.tar.bz2
historical-e41d620026c9e1c607e5c66b4f37a6536c687b3e.zip
touchups
Diffstat (limited to 'media-libs/allegromp3')
-rw-r--r--media-libs/allegromp3/allegromp3-2.0.2.ebuild44
1 files changed, 18 insertions, 26 deletions
diff --git a/media-libs/allegromp3/allegromp3-2.0.2.ebuild b/media-libs/allegromp3/allegromp3-2.0.2.ebuild
index a8c3120509c6..6f3c0d58de5b 100644
--- a/media-libs/allegromp3/allegromp3-2.0.2.ebuild
+++ b/media-libs/allegromp3/allegromp3-2.0.2.ebuild
@@ -1,43 +1,35 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegromp3/allegromp3-2.0.2.ebuild,v 1.2 2003/02/13 12:40:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegromp3/allegromp3-2.0.2.ebuild,v 1.3 2003/06/19 18:11:48 vapier Exp $
-DESCRIPTION="AllegroMP3 is an Allegro wrapper for the mpglib MP3 decoder part of mpg123."
+DESCRIPTION="Allegro wrapper for the mpglib MP3 decoder part of mpg123"
HOMEPAGE="http://nekros.freeshell.org/delirium/almp3.php"
SRC_URI="http://raythe.sytes.net/TheDeath/almp3.zip"
+
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86"
-IUSE=""
+
DEPEND=">=media-libs/allegro-4.0.0
- >=media-sound/mpg123-0.59r
- >=app-arch/unzip-5.50"
-RDEPEND="${DEPEND}"
-S="${WORKDIR}"
+ media-sound/mpg123-0.59r
+ app-arch/unzip"
-src_compile() {
- cd ${S}
- sh fixunix.sh
- mv Makefile Makefile_orig
- sed s/'^TARGET=DJGPP_STATIC'/'#TARGET=DJGPP_STATIC'/ Makefile_orig| sed s/'#TARGET=LINUX_STATIC'/'TARGET=LINUX_STATIC'/ > Makefile
+S=${WORKDIR}
- emake || die
+src_compile() {
+ sh fixunix.sh
+ mv Makefile Makefile_orig
+ sed s/'^TARGET=DJGPP_STATIC'/'#TARGET=DJGPP_STATIC'/ Makefile_orig| sed s/'#TARGET=LINUX_STATIC'/'TARGET=LINUX_STATIC'/ > Makefile
+ emake || die
}
src_install() {
- cd ${S} # needed? -- just to be sure ;)
- dodir /usr/include
- dodir /usr/lib
-
- insinto /usr/lib
- doins lib/linux/libalmp3.a
-
- insinto /usr/include
- doins include/*.h
-
- dodoc docs/*.txt *.txt
+ dolib.a lib/linux/libalmp3.a
- insinto /usr/share/doc/${P}/examples
- doins examples/Makefile examples/example.c
+ insinto /usr/include
+ doins include/*.h
+ dodoc docs/*.txt *.txt
+ docinto examples
+ dodoc examples/{Makefile,example.c}
}