summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-14 17:43:00 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-14 17:43:00 +0000
commitd895bb741f467981ce652fefc068aaed748b1d32 (patch)
treee1f9ac2925d4f446f0b4f1125a9819d3cd2db929 /media-libs/allegro
parentquick cleanup (diff)
downloadhistorical-d895bb741f467981ce652fefc068aaed748b1d32.tar.gz
historical-d895bb741f467981ce652fefc068aaed748b1d32.tar.bz2
historical-d895bb741f467981ce652fefc068aaed748b1d32.zip
Version bump -- and changed fbcon USE flag to fb USE flag instead
Diffstat (limited to 'media-libs/allegro')
-rw-r--r--media-libs/allegro/ChangeLog9
-rw-r--r--media-libs/allegro/allegro-4.0.1.ebuild103
-rw-r--r--media-libs/allegro/files/digest-allegro-4.0.11
3 files changed, 112 insertions, 1 deletions
diff --git a/media-libs/allegro/ChangeLog b/media-libs/allegro/ChangeLog
index 4665cbc1bf18..28c66c35871c 100644
--- a/media-libs/allegro/ChangeLog
+++ b/media-libs/allegro/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/allegro
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.1 2002/02/01 21:53:30 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/ChangeLog,v 1.2 2002/04/14 17:43:00 seemant Exp $
+
+*allegro-4.0.1 (14 Apr 2002)
+
+ 14 Apr 2002; Seemant Kulleen <seemant@gentoo.org> allegro-4.0.1.ebuild
+ files/digest-allegro-4.0.1.ebuild :
+
+ Version bump, and changed the fbcon USE flag to just fb
*allegro-3.9.37 (1 Feb 2002)
diff --git a/media-libs/allegro/allegro-4.0.1.ebuild b/media-libs/allegro/allegro-4.0.1.ebuild
new file mode 100644
index 000000000000..3338bd44d4a9
--- /dev/null
+++ b/media-libs/allegro/allegro-4.0.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gantoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/allegro/allegro-4.0.1.ebuild,v 1.1 2002/04/14 17:43:00 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Allegro is a cross-platform multimedia library"
+SRC_URI="http://prdownloads.sourceforge.net/alleg/${P}.tar.gz"
+HOMEPAGE="http://alleg.sourceforge.net/"
+
+DEPEND="X? ( virtual/x11 )"
+
+src_compile() {
+
+ confopts="--infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST}"
+
+ # Always enable Linux console support and accompanying drivers
+ confopts="${confopts} --enable-linux --enable-vga"
+
+ # if USE static defined, use static library as default to link with
+ use static \
+ && confopts="${confopts} --enable-staticprog --enable-static"
+
+ # Pentium optimizations
+ if [ ${CHOST} = "i586-pc-linux-gnu" -o ${CHOST} = "i686-pc-linux-gnu" ]
+ then
+ confopts="${confopts} --enable-pentiumopts"
+ fi
+
+ # Use MMX instructions
+ use mmx \
+ && confopts="${confopts} --enable-mmx" \
+ || confopts="${confopts} --enable-mmx=no"
+
+ # Have OSS support
+ use oss \
+ && confopts="${confopts} --enable-ossdigi --enable-ossmidi" \
+ || confopts="${confopts} --disable-ossdigi --disable-ossmidi"
+
+ # Have ALSA support
+ use alsa \
+ && confopts="${confopts} --enable-alsadigi --enable-alsamidi" \
+ || confopts="${confopts} --disable-alsadigi --disable-alsamidi"
+
+ # Have ESD support
+ use esd \
+ && confopts="${confopts} --enable-esddigi" \
+ || confopts="${confopts} --disable-esddigi"
+
+ # Have X11 support
+ use X \
+ && confopts="${confopts} \
+ --with-x \
+ --enable-xwin-shm \
+ --enable-xwin-vidmode \
+ --enable-xwin-dga \
+ --enable-xwin-dga2" \
+ || confopts="${confopts} --without-x \
+ --disable-xwin-shm \
+ --disable-xwin-vidmode \
+ --disable-xwin-dga \
+ --disable-xwin-dga2"
+
+ # Have SVGALib support
+ use svga \
+ && confopts="${confopts} --enable-svgalib" \
+ || confopts="${confopts} --disable-svgalib"
+
+ # Have fbcon support
+ use fb \
+ && confopts="${confopts} --enable-fbcon" \
+ || confopts="${confopts} --disable-fbcon"
+
+ # --------------
+
+ ./configure \
+ ${confopts} || die
+
+ # emake doesn't work
+ make || die
+
+ make docs-ps docs-dvi || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install install-gzipped-man install-gzipped-info || die
+
+ cd ${S}
+ # Different format versions of the Allegro documentation
+ dohtml allegro.dvi allegro.ps
+ dodoc allegro.txt
+
+}
+
diff --git a/media-libs/allegro/files/digest-allegro-4.0.1 b/media-libs/allegro/files/digest-allegro-4.0.1
new file mode 100644
index 000000000000..d431fa1df4e3
--- /dev/null
+++ b/media-libs/allegro/files/digest-allegro-4.0.1
@@ -0,0 +1 @@
+MD5 224296524ffafc8369f3b29f5b73cdcb allegro-4.0.1.tar.gz 2391111