summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-09-26 17:32:18 +0000
committerFabian Groffen <grobian@gentoo.org>2006-09-26 17:32:18 +0000
commitdbd2c0d5240a8db4de6fa2c0a21196150255bba4 (patch)
tree855bf3eca1803684a43092fd29a5e3cb0a3074e0 /media-gfx
parentMasking sys-devel/gcc-4* on uclibc/hardened/x86. (diff)
downloadhistorical-dbd2c0d5240a8db4de6fa2c0a21196150255bba4.tar.gz
historical-dbd2c0d5240a8db4de6fa2c0a21196150255bba4.tar.bz2
historical-dbd2c0d5240a8db4de6fa2c0a21196150255bba4.zip
Drop ppc-macos from 2.8 series as we don't have swig keyworded
Package-Manager: portage-2.1.1
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphviz/files/graphviz-2.6-macos.patch54
-rw-r--r--media-gfx/graphviz/graphviz-2.6-r1.ebuild9
-rw-r--r--media-gfx/graphviz/graphviz-2.6.ebuild3
-rw-r--r--media-gfx/graphviz/graphviz-2.8-r1.ebuild4
-rw-r--r--media-gfx/graphviz/graphviz-2.8-r2.ebuild4
-rw-r--r--media-gfx/graphviz/graphviz-2.8.ebuild4
6 files changed, 62 insertions, 16 deletions
diff --git a/media-gfx/graphviz/files/graphviz-2.6-macos.patch b/media-gfx/graphviz/files/graphviz-2.6-macos.patch
index e42d31f12170..ad95dd9ba7f4 100644
--- a/media-gfx/graphviz/files/graphviz-2.6-macos.patch
+++ b/media-gfx/graphviz/files/graphviz-2.6-macos.patch
@@ -1,6 +1,5 @@
-diff -Naur graphviz-2.6-orig/lib/ast/pathpath.c graphviz-2.6/lib/ast/pathpath.c
---- graphviz-2.6-orig/lib/ast/pathpath.c 2005-10-30 15:15:30.000000000 +0100
-+++ graphviz-2.6/lib/ast/pathpath.c 2005-10-30 15:16:20.000000000 +0100
+--- lib/ast/pathpath.c
++++ lib/ast/pathpath.c
@@ -33,7 +33,12 @@
#include <unistd.h>
@@ -14,3 +13,52 @@ diff -Naur graphviz-2.6-orig/lib/ast/pathpath.c graphviz-2.6/lib/ast/pathpath.c
char **opt_info_argv;
char *pathpath(register char *path, const char *p, const char *a, int mode)
+--- lib/expr/Makefile.in
++++ lib/expr/Makefile.in
+@@ -362,7 +362,11 @@
+ pkglib_LTLIBRARIES = libexpr.la
+ man_MANS = expr.3
+ pdf_DATA = expr.pdf
++ifeq ($(host_os),darwin)
++libexpr_la_LDFLAGS = -version-info @VERSION_INFO@
++else
+ libexpr_la_LDFLAGS = -version-info @VERSION_INFO@ -no-undefined
++endif
+ libexpr_la_SOURCES = excc.c excontext.c exdata.c exerror.c \
+ exeval.c exexpr.c exlexname.c exopen.c exrewind.c extoken.c \
+ extype.c exzero.c exparse.y
+--- lib/plugin/Makefile.in
++++ lib/plugin/Makefile.in
+@@ -370,7 +370,13 @@
+ libgvplugin_dot_layout.la \
+ libgvplugin_usershape_gd.la
+
+-libgvplugin_neato_layout_la_LDFLAGS = -version-info @VERSION_INFO@ -no-undefined
++ifneq ($(host_os),darwin)
++EXTRALDFLAGS="-no_undefined"
++else
++EXTRALDFLAGS=""
++endif
++
++libgvplugin_neato_layout_la_LDFLAGS = -version-info @VERSION_INFO@ $(EXTRALDFLAGS)
+ libgvplugin_neato_layout_la_SOURCES = \
+ gvplugin_neato_layout.c \
+ gvlayout_neato_layout.c
+@@ -384,7 +390,7 @@
+ $(top_builddir)/lib/pack/libpack.la \
+ $(top_builddir)/lib/gvc/libgvc.la
+
+-libgvplugin_dot_layout_la_LDFLAGS = -version-info @VERSION_INFO@ -no-undefined
++libgvplugin_dot_layout_la_LDFLAGS = -version-info @VERSION_INFO@ $(EXTRALDFLAGS)
+ libgvplugin_dot_layout_la_SOURCES = \
+ gvplugin_dot_layout.c \
+ gvlayout_dot_layout.c
+@@ -394,7 +400,7 @@
+ $(top_builddir)/lib/pathplan/libpathplan.la \
+ $(top_builddir)/lib/gvc/libgvc.la
+
+-libgvplugin_usershape_gd_la_LDFLAGS = -version-info @VERSION_INFO@ -no-undefined
++libgvplugin_usershape_gd_la_LDFLAGS = -version-info @VERSION_INFO@ $(EXTRALDFLAGS)
+ libgvplugin_usershape_gd_la_SOURCES = \
+ gvplugin_usershape_gd.c \
+ gvusershape_gd.c
diff --git a/media-gfx/graphviz/graphviz-2.6-r1.ebuild b/media-gfx/graphviz/graphviz-2.6-r1.ebuild
index 6a689b0d3596..a899e1f81cd7 100644
--- a/media-gfx/graphviz/graphviz-2.6-r1.ebuild
+++ b/media-gfx/graphviz/graphviz-2.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.6-r1.ebuild,v 1.7 2006/07/05 16:56:01 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.6-r1.ebuild,v 1.8 2006/09/26 17:32:18 grobian Exp $
inherit eutils libtool
@@ -10,7 +10,7 @@ SRC_URI="http://www.graphviz.org/pub/graphviz/ARCHIVE/${P}.tar.gz"
LICENSE="CPL-1.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ppc ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="cairo tcl tk X static"
RDEPEND=">=sys-libs/zlib-1.1.3
@@ -34,8 +34,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch ${FILESDIR}/${P}-no-undefined.patch || die "epatch failed"
- epatch ${FILESDIR}/${P}-macos.patch || die "epatch failed"
+ epatch "${FILESDIR}/${P}"-macos.patch || die "epatch failed"
elibtoolize
}
@@ -43,8 +42,8 @@ src_unpack() {
src_compile() {
econf --with-mylibgd \
--disable-dependency-tracking \
+ --without-ruby \
$(use_enable static) \
- $(use_with tcl tclsh) \
$(use_with tcl) \
$(use_with tk) \
$(use_with X x) || die "Configure Failed!"
diff --git a/media-gfx/graphviz/graphviz-2.6.ebuild b/media-gfx/graphviz/graphviz-2.6.ebuild
index e961a3e85016..bfde3930c70e 100644
--- a/media-gfx/graphviz/graphviz-2.6.ebuild
+++ b/media-gfx/graphviz/graphviz-2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.6.ebuild,v 1.10 2006/05/28 09:20:02 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.6.ebuild,v 1.11 2006/09/26 17:32:18 grobian Exp $
inherit eutils
@@ -33,7 +33,6 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-no-undefined.patch || die "epatch failed"
epatch ${FILESDIR}/${P}-macos.patch || die "epatch failed"
}
diff --git a/media-gfx/graphviz/graphviz-2.8-r1.ebuild b/media-gfx/graphviz/graphviz-2.8-r1.ebuild
index 10f45e5a1b53..9052c06621b6 100644
--- a/media-gfx/graphviz/graphviz-2.8-r1.ebuild
+++ b/media-gfx/graphviz/graphviz-2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.8-r1.ebuild,v 1.2 2006/09/23 07:54:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.8-r1.ebuild,v 1.3 2006/09/26 17:32:18 grobian Exp $
inherit eutils libtool
@@ -10,7 +10,7 @@ SRC_URI="http://www.graphviz.org/pub/graphviz/ARCHIVE/${P}.tar.gz"
LICENSE="CPL-1.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 m68k ppc ~ppc-macos ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="cairo tcltk X static minimal"
RDEPEND=">=sys-libs/zlib-1.1.3
diff --git a/media-gfx/graphviz/graphviz-2.8-r2.ebuild b/media-gfx/graphviz/graphviz-2.8-r2.ebuild
index 0c95714a9900..0ca863d8baab 100644
--- a/media-gfx/graphviz/graphviz-2.8-r2.ebuild
+++ b/media-gfx/graphviz/graphviz-2.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.8-r2.ebuild,v 1.2 2006/09/25 12:18:48 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.8-r2.ebuild,v 1.3 2006/09/26 17:32:18 grobian Exp $
WANT_AUTOCONF=latest
WANT_AUTOMAKE=latest
@@ -13,7 +13,7 @@ SRC_URI="http://www.graphviz.org/pub/graphviz/ARCHIVE/${P}.tar.gz"
LICENSE="CPL-1.0"
SLOT="0"
-KEYWORDS="~alpha amd64 hppa ia64 ppc ~ppc-macos ppc64 s390 sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 hppa ia64 ppc ppc64 s390 sparc x86 ~x86-fbsd"
IUSE="cairo tcltk X static guile java lua perl php python ruby ocaml"
RDEPEND=">=sys-libs/zlib-1.1.3
diff --git a/media-gfx/graphviz/graphviz-2.8.ebuild b/media-gfx/graphviz/graphviz-2.8.ebuild
index c68adee43606..631abb38e00b 100644
--- a/media-gfx/graphviz/graphviz-2.8.ebuild
+++ b/media-gfx/graphviz/graphviz-2.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.8.ebuild,v 1.13 2006/09/14 00:29:00 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-2.8.ebuild,v 1.14 2006/09/26 17:32:18 grobian Exp $
inherit eutils libtool
@@ -10,7 +10,7 @@ SRC_URI="http://www.graphviz.org/pub/graphviz/ARCHIVE/${P}.tar.gz"
LICENSE="CPL-1.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ppc ~ppc-macos ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="cairo tcltk X static minimal"
RDEPEND=">=sys-libs/zlib-1.1.3