summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-10 12:01:38 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-10 12:01:38 +0000
commit8a47f492ef0561c146eef9b6c0d7c606614086bd (patch)
tree28c2ede2b9723161886a2ced603c666067ef411c /media-gfx
parentfilter out -fomit-frame-pointer for k6's (diff)
downloadhistorical-8a47f492ef0561c146eef9b6c0d7c606614086bd.tar.gz
historical-8a47f492ef0561c146eef9b6c0d7c606614086bd.tar.bz2
historical-8a47f492ef0561c146eef9b6c0d7c606614086bd.zip
k6 fixes
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp/ChangeLog7
-rw-r--r--media-gfx/gimp/gimp-1.2.3-r2.ebuild40
-rw-r--r--media-gfx/gimp/gimp-1.2.3-r3.ebuild16
-rw-r--r--media-gfx/gimp/gimp-1.3.11.ebuild12
-rw-r--r--media-gfx/gimp/gimp-1.3.12.ebuild9
5 files changed, 60 insertions, 24 deletions
diff --git a/media-gfx/gimp/ChangeLog b/media-gfx/gimp/ChangeLog
index 2496a1fb69e2..c0ae919cd501 100644
--- a/media-gfx/gimp/ChangeLog
+++ b/media-gfx/gimp/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for media-gfx/gimp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.26 2003/03/04 00:51:28 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.27 2003/03/10 12:01:38 seemant Exp $
*gimp-1.3.12 (24 Feb 2003)
+ 10 Mar 2003; Seemant Kulleen <seemant@gentoo.org> gimp-1.2.3-r2.ebuild,
+ gimp-1.2.3-r3.ebuild, gimp-1.3.11.ebuild, gimp-1.3.12.ebuild:
+ strip out -fomit-frame-pointer for k6 based cpu's. closes bug #15559 by
+ sinterklaas <jerroose@xs4all.nl>
+
25 Feb 2003; Martin Holzer <mholzer@gentoo.org> gimp-1.3.12.ebuild :
Filter out -Os and replace with -O2. Closes #12644.
diff --git a/media-gfx/gimp/gimp-1.2.3-r2.ebuild b/media-gfx/gimp/gimp-1.2.3-r2.ebuild
index 7db3e1c5b78c..4cbd09149717 100644
--- a/media-gfx/gimp/gimp-1.2.3-r2.ebuild
+++ b/media-gfx/gimp/gimp-1.2.3-r2.ebuild
@@ -1,43 +1,42 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.3-r2.ebuild,v 1.13 2003/02/13 12:32:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.3-r2.ebuild,v 1.14 2003/03/10 12:01:38 seemant Exp $
+
+inherit eutils flag-o-matic
IUSE="python nls gnome aalib perl"
-S="${WORKDIR}/${P}"
-DESCRIPTION="The GIMP"
+S=${WORKDIR}/${P}
+DESCRIPTION="The GIMP -- GNU Image Manipulation Program"
SRC_URI="ftp://ftp.gimp.org/pub/gimp/v1.2/v${PV}/${P}.tar.bz2"
HOMEPAGE="http://www.gimp.org/"
SLOT="1.2"
-KEYWORDS="x86 ppc"
LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/autoconf
- sys-devel/automake
- =x11-libs/gtk+-1.2*
- >=media-libs/mpeg-lib-1.3.1
+RDEPEND="=x11-libs/gtk+-1.2*
aalib? ( >=media-libs/aalib-1.2 )
- perl? ( >=dev-perl/PDL-2.2.1
- >=dev-perl/Parse-RecDescent-1.80
+ perl? ( >=dev-perl/PDL-2.2.1
+ >=dev-perl/Parse-RecDescent-1.80
>=dev-perl/gtk-perl-0.7004 )
python? ( >=dev-lang/python-2.0 )
gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
-RDEPEND="=x11-libs/gtk+-1.2*
- aalib? ( >=media-libs/aalib-1.2 )
- perl? ( >=dev-perl/PDL-2.2.1 >=dev-perl/Parse-RecDescent-1.80 >=dev-perl/gtk-perl-0.7004 )
- python? ( >=dev-lang/python-2.0 )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake
+ >=media-libs/mpeg-lib-1.3.1
+ nls? ( sys-devel/gettext )"
src_unpack() {
+
unpack ${A}
cd ${S}/plug-ins/common
# compile with nonstandard psd_save plugin
cp ${FILESDIR}/psd_save.c .
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
+ epatch ${FILESDIR}/${PF}-gentoo.diff
cd ${S}
if [ -f ${ROOT}/usr/share/gettext/config.rpath ] ; then
@@ -69,6 +68,13 @@ src_unpack() {
}
src_compile() {
+
+ # Strip out -fomit-frame-pointer for k6's
+ is-flag "-march=k6-3" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && strip-flags "-fomit-frame-pointer"
+
+
local myconf=""
local mymake=""
local myvars=""
diff --git a/media-gfx/gimp/gimp-1.2.3-r3.ebuild b/media-gfx/gimp/gimp-1.2.3-r3.ebuild
index 67c9945edb63..578b30bbcd32 100644
--- a/media-gfx/gimp/gimp-1.2.3-r3.ebuild
+++ b/media-gfx/gimp/gimp-1.2.3-r3.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.3-r3.ebuild,v 1.9 2003/03/04 00:51:28 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.3-r3.ebuild,v 1.10 2003/03/10 12:01:38 seemant Exp $
+
+inherit eutils flag-o-matic
IUSE="python nls gnome aalib perl"
-S="${WORKDIR}/${P}"
+S=${WORKDIR}/${P}
DESCRIPTION="The GIMP"
SRC_URI="ftp://ftp.gimp.org/pub/gimp/v1.2/v${PV}/${P}.tar.bz2"
HOMEPAGE="http://www.gimp.org/"
@@ -42,7 +44,7 @@ src_unpack() {
cd ${S}/plug-ins/common
# compile with nonstandard psd_save plugin
cp ${FILESDIR}/psd_save.c .
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
+ epatch ${FILESDIR}/${PF}-gentoo.diff
cd ${S}
if [ -f ${ROOT}/usr/share/gettext/config.rpath ] ; then
@@ -78,6 +80,14 @@ src_unpack() {
}
src_compile() {
+
+
+ # Strip out -fomit-frame-pointer for k6's
+ is-flag "-march=k6-3" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && strip-flags "-fomit-frame-pointer"
+
+
local myconf=""
local mymake=""
local myvars=""
diff --git a/media-gfx/gimp/gimp-1.3.11.ebuild b/media-gfx/gimp/gimp-1.3.11.ebuild
index ec949561ce67..a848db3530e4 100644
--- a/media-gfx/gimp/gimp-1.3.11.ebuild
+++ b/media-gfx/gimp/gimp-1.3.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.11.ebuild,v 1.5 2003/02/25 21:30:12 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.11.ebuild,v 1.6 2003/03/10 12:01:38 seemant Exp $
IUSE="doc python"
@@ -34,8 +34,16 @@ DEPEND="${RDEPEND}
doc? ( >=dev-util/gtk-doc-0.9 )"
src_compile() {
+
+ # Strip out -fomit-frame-pointer for k6's
+ is-flag "-march=k6-3" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && strip-flags "-fomit-frame-pointer"
+
local myconf
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
use python \
&& myconf="${myconf} --enable-python" \
diff --git a/media-gfx/gimp/gimp-1.3.12.ebuild b/media-gfx/gimp/gimp-1.3.12.ebuild
index 7a8fdaa2a20e..f0184790cf65 100644
--- a/media-gfx/gimp/gimp-1.3.12.ebuild
+++ b/media-gfx/gimp/gimp-1.3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.12.ebuild,v 1.3 2003/02/25 21:30:12 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.12.ebuild,v 1.4 2003/03/10 12:01:38 seemant Exp $
IUSE="doc python aalib"
@@ -39,6 +39,13 @@ DEPEND="${RDEPEND}
doc? ( >=dev-util/gtk-doc-1 )"
src_compile() {
+
+ # Strip out -fomit-frame-pointer for k6's
+ is-flag "-march=k6-3" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && strip-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && strip-flags "-fomit-frame-pointer"
+
+
local myconf
use doc \