summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-27 05:54:56 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-27 05:54:56 +0000
commit2e4703a0bf2732a0a2a6370e90d2d1fd5bf1b671 (patch)
treeea4f1951c897c262f94bdb0f65d6523af6e4f42f /media-gfx
parentarm KEYWORD (diff)
downloadhistorical-2e4703a0bf2732a0a2a6370e90d2d1fd5bf1b671.tar.gz
historical-2e4703a0bf2732a0a2a6370e90d2d1fd5bf1b671.tar.bz2
historical-2e4703a0bf2732a0a2a6370e90d2d1fd5bf1b671.zip
Initial ebuild by me.
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/maya/ChangeLog10
-rw-r--r--media-gfx/maya/Manifest2
-rw-r--r--media-gfx/maya/files/aw_flexlm41
-rw-r--r--media-gfx/maya/files/aw_flexlm.conf.d3
-rw-r--r--media-gfx/maya/files/digest-maya-5.0.12
-rw-r--r--media-gfx/maya/files/maya-docs17
-rw-r--r--media-gfx/maya/maya-5.0.1.ebuild184
-rw-r--r--media-gfx/maya/metadata.xml9
8 files changed, 268 insertions, 0 deletions
diff --git a/media-gfx/maya/ChangeLog b/media-gfx/maya/ChangeLog
new file mode 100644
index 000000000000..39bda26ab37a
--- /dev/null
+++ b/media-gfx/maya/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/maya
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/maya/ChangeLog,v 1.1 2004/04/27 05:54:56 eradicator Exp $
+
+*maya-5.0.1 (26 Apr 2004)
+
+ 26 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org> maya-5.0.1.ebuild,
+ metadata.xml, files/aw_flexlm, files/aw_flexlm.conf.d, files/maya-docs:
+ Initial ebuild by me.
+
diff --git a/media-gfx/maya/Manifest b/media-gfx/maya/Manifest
new file mode 100644
index 000000000000..67aeeed8ac05
--- /dev/null
+++ b/media-gfx/maya/Manifest
@@ -0,0 +1,2 @@
+MD5 2ddbc610a236ebaeaf057278e53f6413 maya-5.0.1.ebuild 1208
+MD5 911ab2c4c3366141b3c1e6e567324a85 files/digest-maya-5.0.1 158
diff --git a/media-gfx/maya/files/aw_flexlm b/media-gfx/maya/files/aw_flexlm
new file mode 100644
index 000000000000..5e9926a180a1
--- /dev/null
+++ b/media-gfx/maya/files/aw_flexlm
@@ -0,0 +1,41 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/maya/files/aw_flexlm,v 1.1 2004/04/27 05:54:56 eradicator Exp $
+
+# description: aw_flexlm controls the Flexlm License Server Daemon for \
+# Alias|Wavefront Products.
+# processname: lmgrd
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ -x "/usr/aw/COM/etc/lmgrd" ]; then
+ if [ -f "$LICENSE_FILE" ] ; then
+ return 0
+ else
+ eerror "ERROR Cannot run FLEXlm Licensing daemon: lmgrd"
+ eerror "$LICENSE_FILE does not exist."
+ fi
+ else
+ eerror "ERROR Cannot run FLEXlm Licensing daemon: lmgrd"
+ eerror "/usr/aw/COM/etc/lmgrd does not exist or is not executable"
+ fi
+
+ return 1
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting FLEXlm License Server Daemon for Alias|Wavefront software"
+ su nobody -c "/usr/aw/COM/etc/lmgrd -c $LICENSE_FILE -l ${LOG}"
+ eend $?
+}
+
+stop() {
+ ebegin "Shutting Down FLEXlm License Server Daemon for Alias|Wavefront software"
+ /usr/aw/COM/bin/lmdown -q -c "$LICENSE_FILE"
+ eend $?
+}
diff --git a/media-gfx/maya/files/aw_flexlm.conf.d b/media-gfx/maya/files/aw_flexlm.conf.d
new file mode 100644
index 000000000000..ebfdcebb5a29
--- /dev/null
+++ b/media-gfx/maya/files/aw_flexlm.conf.d
@@ -0,0 +1,3 @@
+LICENSE_DIR=/var/flexlm
+LICENSE_FILE="$LICENSE_DIR/aw_`/bin/uname -n | awk -F. '{print $1}'`.dat"
+LOG=/var/log/aw_flexlm.log
diff --git a/media-gfx/maya/files/digest-maya-5.0.1 b/media-gfx/maya/files/digest-maya-5.0.1
new file mode 100644
index 000000000000..81d5f7e87c14
--- /dev/null
+++ b/media-gfx/maya/files/digest-maya-5.0.1
@@ -0,0 +1,2 @@
+MD5 945fe2f84bdfaca1d22ab039e53326e4 Maya-5.0-linux-software.tar.gz 104776674
+MD5 266ca7b2904138a4e2ffcd7a6a2f0313 myr_maya501_gold_linux_update.tgz 91584847
diff --git a/media-gfx/maya/files/maya-docs b/media-gfx/maya/files/maya-docs
new file mode 100644
index 000000000000..da6da64a28bd
--- /dev/null
+++ b/media-gfx/maya/files/maya-docs
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Maya Doc Server"
+ start-stop-daemon --start --quiet --exec /usr/aw/maya/docs/startDocServer.sh
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Maya Doc Server"
+ start-stop-daemon --start --quiet --exec /usr/aw/maya/docs/shutdownDocServer.sh
+ eend $?
+}
diff --git a/media-gfx/maya/maya-5.0.1.ebuild b/media-gfx/maya/maya-5.0.1.ebuild
new file mode 100644
index 000000000000..1e9d9e626a27
--- /dev/null
+++ b/media-gfx/maya/maya-5.0.1.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/maya/maya-5.0.1.ebuild,v 1.1 2004/04/27 05:54:56 eradicator Exp $
+
+inherit rpm
+
+IUSE="maya5-bundled-runtime"
+S="${WORKDIR}"
+
+DESCRIPTION="Alias Wavefront's Maya. Comercial modeling and animation package."
+HOMEPAGE="http://www.alias.com/eng/products-services/maya/index.shtml"
+
+SRC_URI="Maya-5.0-linux-software.tar.gz myr_maya501_gold_linux_update.tgz"
+RESTRICT="fetch"
+
+# RPM versions within the tarballs which will get installed
+AWCOMMON="5.3-5.i686"
+AWCOMMON_SERVER="5.3-5.i686"
+MAYA5_0="5.0.1-135.i686"
+
+SLOT="5.0"
+
+LICENSE="mayadoc-5.0"
+KEYWORDS="~x86"
+
+DEPEND="app-arch/unzip"
+
+RDEPEND=">=sys-libs/lib-compat-1.3
+ !maya5-bundled-runtime ( =x11-libs/qt-3*
+ >=sys-devel/gcc-3*
+ >=x11-libs/openmotif-2.1.30 )
+ virtual/opengl"
+
+pkg_nofetch() {
+ einfo "Please place the required files and place them in ${DISTDIR}:"
+ einfo
+ einfo "From the Maya 5.0 CD provided by Alias:"
+ einfo "Maya-5.0-linux-docs.tar.gz"
+ einfo "Maya-5.0-linux-software.tar.gz"
+ einfo
+ einfo "Downloads from Alias's support server:"
+ einfo "http://aliaswavefront.topdownloads.com/pub/bws/bws_107/myr_maya501_gold_linux_update.tgz"
+ einfo "http://aliaswavefront.topdownloads.com/pub/bws/bws_79/myr_TechDocs.zip"
+}
+
+src_unpack() {
+ mkdir ${S}/RPMS
+ cd ${S}/RPMS
+ unpack Maya-5.0-linux-software.tar.gz
+ unpack myr_maya501_gold_linux_update.tgz
+
+ # rpm_unpack unpacks in ${WORKDIR} no matter what we try... so get it out of the way...
+ cd ${S}
+ rpm_unpack ${S}/RPMS/AWCommon-${AWCOMMON}.rpm
+ rpm_unpack ${S}/RPMS/AWCommon-server-${AWCOMMON_SERVER}.rpm
+ rpm_unpack ${S}/RPMS/Maya5_0-${MAYA5_0}.rpm
+
+ mkdir ${S}/insroot
+ mv ${S}/usr ${S}/insroot
+
+ # Don't need their init script
+ rm -rf etc
+
+ # Remove unneeded libs (provided by DEPEND).
+ if ! use maya5-bundled-runtime; then
+ rm -f ${S}/insroot/usr/aw/COM/lib/libXm.so.2.1
+ rm -f ${S}/insroot/usr/aw/maya5.0/lib/libgcc_s.so.1
+ rm -f ${S}/insroot/usr/aw/maya5.0/lib/libstdc++.so.5.0.2
+ rm -f ${S}/insroot/usr/aw/maya5.0/lib/libqt.so.3
+ rm -f ${S}/insroot/usr/aw/maya5.0/lib/libXm.so.2
+ fi
+
+ mkdir ${S}/docs
+ cd ${S}/docs
+ unpack Maya-5.0-linux-docs.tar.gz
+
+ mkdir ${S}/docs.upgrade
+ cd ${S}/docs.upgrade
+ unpack myr_TechDocs.zip
+}
+
+src_install() {
+ dohtml ${S}/RPMS/README.html
+
+ cd ${S}/insroot
+ cp -a . ${D}
+
+ # What follows is modified from rpm -qp --scripts RPMS/AWCommon-5.3-5.i686.rpm
+ for lmexec in lmcksum lmdiag lmdown lmhostid lmremove lmreread lmstat lmver; do
+ dosym lmutil /usr/aw/COM/bin/${lmexec}
+ done
+
+ # We use our own Motif runtime unless USE=maya5-bundled-runtime
+ if use maya5-bundled-runtime; then
+ dosym libXm.so.2.1 libXm.so
+ dosym libXm.so.2.1 libXm.so.2
+ fi
+
+ dosym COM /usr/aw/COM2
+ # End rpm -qp --scripts RPMS/AWCommon-5.3-5.i686.rpm
+
+ # What follows is modified from rpm -qp --scripts RPMS/Maya5_0-5.0.1-135.i686.rpm
+ keepdir /var/flexlm
+ fperms ugo+w /var/flexlm
+
+ dosym maya5.0 /usr/aw/maya
+
+ # The RPM puts these in /usr/local/bin
+ keepdir /usr/bin
+ dosym /usr/aw/maya5.0/bin/Maya5.0 /usr/bin/maya
+ for mayaexec in Render fcheck imgcvt; do
+ dosym /usr/aw/maya5.0/bin/${mayaexec} /usr/bin/${mayaexec}
+ done
+
+ dosym Mayatomr.so /usr/aw/maya5.0/bin/plug-ins/Mayatomr.sog
+
+ # We use our own gcc3 runtime unless USE=maya5-bundled-runtime
+ if use maya5-bundled-runtime; then
+ dosym libgcc_s.so.1 /usr/aw/maya5.0/lib/libgcc_s.so
+ dosym libstdc++.so.5.0.2 /usr/aw/maya5.0/lib/libstdc++.so.5
+ dosym libstdc++.so.5.0.2 /usr/aw/maya5.0/lib/libstdc++.so
+ fi
+
+ # update the mental ray configuration files in place
+ dosed "/\[PREFIX\]/s//\/usr/" /usr/aw/maya5.0/mentalray/maya.rayrc
+ dosed "/\[PREFIX\]/s//\/usr/" /usr/aw/maya5.0/bin/mayarender_with_mr
+ dosed "/\[PREFIX\]/s//\/usr/" /usr/aw/maya5.0/bin/mentalrayrender
+ dosed "/\[PREFIX\]/s//\/usr/" /usr/aw/maya5.0/bin/mayaexport_with_mr
+ fperms 755 /usr/aw/maya5.0/bin/mayarender_with_mr /usr/aw/maya5.0/bin/mentalrayrender
+
+ # End rpm -qp --scripts RPMS/Maya5_0-5.0.1-135.i686.rpm
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/maya-docs ${FILESDIR}/aw_flexlm
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/aw_flexlm.conf.d aw_flexlm
+
+ # Now for the docs stuff...
+ cd ${S}/docs/documentation
+ addpredict /var/.com.zerog.registry.lock
+ addwrite /var/.com.zerog.registry.xml
+ einfo "Starting Maya 5.0 DocServer installation..."
+ ./Linux_Maya50Docs_Installer/installMayaDocServer.bin -DUSER_INSTALL_DIR="${D}/usr/aw/maya5.0/docs" -i silent
+ einfo "Starting Maya 5.0 English Documentation installation..."
+ ./Linux_M5en_US_Installer/install_en_US_docs.bin -DUSER_INSTALL_DIR="${D}/usr/aw/maya5.0/docs/Documents" -i silent
+
+ # And now the doc update
+ cd ${S}/docs.upgrade
+ insinto /usr/aw/maya5.0/docs/Documents/Maya5.0/en_US
+ doins *.zip
+
+ cd ${S}/docs.upgrade/style
+ insinto /usr/aw/maya5.0/docs/Documents/Maya5.0/en_US/style
+ doins *
+}
+
+pkg_postinstall() {
+ # What follows is modified from rpm -qp --scripts RPMS/Maya5_0-5.0.1-135.i686.rpm
+ cp /etc/services /tmp/services.maya_save
+ awk '/mi-ray3_2maya5_0/ { found++; print ; next } {print} END {if (0==found) print "mi-ray3_2maya5_0 7054/tcp" }' /tmp/services.maya_save > /etc/service
+
+ # update the magic file
+ if [ -e /usr/share/magic ]; then
+ mv /usr/share/magic /tmp/magic.rpmsave
+ awk '/Alias.Wavefront Maya files. begin/ {p=1} /Alias.Wavefront Maya files. end/ {p=2} {if (p==2) { p=0} else if (p==0) print }' /tmp/magic.rpmsave > /usr/share/magic
+ cat /usr/aw/maya5.0/.tmpdata/awmagic >> /usr/share/magic;
+ # get file to rebuild the cache
+ file -C > /dev/null 2>&1
+ rm -Rf /usr/aw/maya5.0/.tmpdata/awmagic 2>&1 > /dev/null
+ fi
+ # End rpm -qp --scripts RPMS/Maya5_0-5.0.1-135.i686.rpm
+
+ einfo "There may be a more recent license for this workstation available on the Alias|Wavefront"
+ einfo "web site. Please visit the following URL to check for updated licenses:"
+ einfo "http://www.aliaswavefront.com/en/Community/Special/keys/maya/"
+ einfo
+ einfo "To install your key, either place aw.dat in /var/flexlm or run the following command from an X session:"
+ einfo "/usr/aw/COM/bin/installKey -input /usr/aw/maya5.0/license_data/maya_prekey_data"
+ einfo
+ einfo "Two init scripts have been installed:"
+ einfo "maya-docs is for the document server (help system)."
+ einfo "aw_flexlm is for the license server"
+}
diff --git a/media-gfx/maya/metadata.xml b/media-gfx/maya/metadata.xml
new file mode 100644
index 000000000000..b61685c8cc99
--- /dev/null
+++ b/media-gfx/maya/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>eradicator@gentoo.org</email>
+ <name>Jeremy Huddleston</name>
+</maintainer>
+</pkgmetadata>