summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-06 11:41:15 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-06 11:41:15 +0000
commit29f42a90b916aacd7450ee9a793520642ac209f7 (patch)
tree3361b80d87a4996aa3e26b69759bd2815badf75c /media-gfx
parentmany small fix0rs (diff)
downloadhistorical-29f42a90b916aacd7450ee9a793520642ac209f7.tar.gz
historical-29f42a90b916aacd7450ee9a793520642ac209f7.tar.bz2
historical-29f42a90b916aacd7450ee9a793520642ac209f7.zip
flag-o-matic
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gphoto/ChangeLog5
-rw-r--r--media-gfx/gphoto/gphoto-0.4.3-r2.ebuild14
2 files changed, 14 insertions, 5 deletions
diff --git a/media-gfx/gphoto/ChangeLog b/media-gfx/gphoto/ChangeLog
index cb70528e4ae2..5a59bee990d0 100644
--- a/media-gfx/gphoto/ChangeLog
+++ b/media-gfx/gphoto/ChangeLog
@@ -1,12 +1,13 @@
# ChangeLog for media-gfx/gphoto
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/ChangeLog,v 1.5 2002/11/06 10:37:55 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/ChangeLog,v 1.6 2002/11/06 11:41:15 seemant Exp $
*gphoto-0.4.3-r2 (12 June 2002)
06 Nov 2002; Seemant Kulleen <seemant@gentoo.org> gphoto-0.4.3-r2 :
- FHS standard manpages installation now -- switched to econf and einstall
+ FHS standard manpages installation now -- switched to econf and einstall.
+ Also use flag-o-matic eclass to filter out the -pipe compile optimisation.
12 June 2002; Matthew Kennedy <mkennedy@gentoo.org>
files/digest-gphoto-0.4.3-r2,
diff --git a/media-gfx/gphoto/gphoto-0.4.3-r2.ebuild b/media-gfx/gphoto/gphoto-0.4.3-r2.ebuild
index db623b2823a3..d170a50a73dc 100644
--- a/media-gfx/gphoto/gphoto-0.4.3-r2.ebuild
+++ b/media-gfx/gphoto/gphoto-0.4.3-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/gphoto-0.4.3-r2.ebuild,v 1.7 2002/11/06 10:37:55 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/gphoto-0.4.3-r2.ebuild,v 1.8 2002/11/06 11:41:15 seemant Exp $
+
+inherit flag-o-matic
S=${WORKDIR}/${P}
DESCRIPTION="free, redistributable digital camera software application"
@@ -22,8 +24,14 @@ src_unpack() {
src_compile() {
# -pipe does no work
- CFLAGS="${CFLAGS/-pipe}"
- econf --sysconfdir=/etc/gnome || die
+ filter-flags -pipe
+
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf \
+ --sysconfdir=/etc/gnome \
+ ${myconf} || die
make clean || die
pmake || die
}