summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2002-12-27 17:08:46 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2002-12-27 17:08:46 +0000
commit83892f6acdd4fc5840bda04fcb770194da9a8e1c (patch)
tree3a53f3469ab14e99d6a28f1573ee17538ee59b27 /media-gfx/gimp-print
parentnew version fixes bug #12106 (diff)
downloadhistorical-83892f6acdd4fc5840bda04fcb770194da9a8e1c.tar.gz
historical-83892f6acdd4fc5840bda04fcb770194da9a8e1c.tar.bz2
historical-83892f6acdd4fc5840bda04fcb770194da9a8e1c.zip
new version
Diffstat (limited to 'media-gfx/gimp-print')
-rw-r--r--media-gfx/gimp-print/files/digest-gimp-print-4.2.41
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.4.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/media-gfx/gimp-print/files/digest-gimp-print-4.2.4 b/media-gfx/gimp-print/files/digest-gimp-print-4.2.4
new file mode 100644
index 000000000000..04737a7d14ea
--- /dev/null
+++ b/media-gfx/gimp-print/files/digest-gimp-print-4.2.4
@@ -0,0 +1 @@
+MD5 3831ee2d325a3ba5400216a74d8b48f8 gimp-print-4.2.4.tar.gz 4938844
diff --git a/media-gfx/gimp-print/gimp-print-4.2.4.ebuild b/media-gfx/gimp-print/gimp-print-4.2.4.ebuild
new file mode 100644
index 000000000000..49588edc026b
--- /dev/null
+++ b/media-gfx/gimp-print/gimp-print-4.2.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.4.ebuild,v 1.1 2002/12/27 17:08:46 lordvan Exp $
+
+IUSE="cups doc nls"
+
+inherit libtool
+
+MY_P=${P}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Gimp Plugin and Ghostscript driver for Gimp"
+SRC_URI="mirror://sourceforge/gimp-print/${MY_P}.tar.gz"
+HOMEPAGE="http://gimp-print.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ =media-gfx/gimp-1.2*
+ app-text/ghostscript
+ net-print/foomatic
+ doc? ( app-text/texi2html )
+ cups? ( >=net-print/cups-1.1.16 )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ elibtoolize
+ aclocal
+
+ local myconf
+
+ use cups && myconf="${myconf} --with-cups" \
+ || myconf="${myconf} --without-cups"
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
+
+ econf \
+ --with-ghost \
+ --sysconfdir=/etc/gimp/1.2/ \
+ --with-gimp-exec-prefix=/usr \
+ --with-testpattern \
+ ${myconf} || die
+
+ cp src/gimp/Makefile src/gimp/Makefile.orig
+ sed -e 's:--install-admin-bin:--install-bin:g' \
+ src/gimp/Makefile.orig >src/gimp/Makefile
+
+ emake || die
+
+}
+
+src_install() {
+
+ dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins/print
+
+ make \
+ DESTDIR=${D} \
+ HOME=/usr/lib/gimp/1.2 \
+ install || die "make install failed"
+
+ # NOTE: this build uses gimptool to install the plugin, so
+ # if we dont do it this way, it will install to / no
+ # matter what.
+ #
+ # NOTE to whoever commented this: Please DO NOT!
+ mv ${D}/usr/lib/gimp/1.2/.gimp-1.2/plug-ins/ \
+ ${D}/usr/lib/gimp/1.2/
+ rm -rf ${D}/usr/lib/gimp/1.2/.gimp-1.2/
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README*
+ dohtml -r doc
+
+}