summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-01-16 04:02:41 +0000
committerTroy Dack <tad@gentoo.org>2003-01-16 04:02:41 +0000
commitec725a348f2437564b3ac85ff697c37c1038e068 (patch)
tree48e12b8d63cae8a0a9cb397aec8a6f7c8116eead /media-gfx/bootsplash
parentChanged ~sparc keyword to sparc. (diff)
downloadhistorical-ec725a348f2437564b3ac85ff697c37c1038e068.tar.gz
historical-ec725a348f2437564b3ac85ff697c37c1038e068.tar.bz2
historical-ec725a348f2437564b3ac85ff697c37c1038e068.zip
New ebuild
Diffstat (limited to 'media-gfx/bootsplash')
-rw-r--r--media-gfx/bootsplash/ChangeLog9
-rw-r--r--media-gfx/bootsplash/bootsplash-0.2.ebuild119
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.21
3 files changed, 129 insertions, 0 deletions
diff --git a/media-gfx/bootsplash/ChangeLog b/media-gfx/bootsplash/ChangeLog
new file mode 100644
index 000000000000..d023d3bf2b8a
--- /dev/null
+++ b/media-gfx/bootsplash/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-gfx/bootsplash
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.1 2003/01/16 04:02:41 tad Exp $
+
+*bootsplash-0.2-r0 (16 JAN 2003)
+
+ 16 JAN 2003; Troy Dack <tad@gentoo.org> bootsplash-0.2.ebuild:
+ Initial import.
+
diff --git a/media-gfx/bootsplash/bootsplash-0.2.ebuild b/media-gfx/bootsplash/bootsplash-0.2.ebuild
new file mode 100644
index 000000000000..135cc8e3d64b
--- /dev/null
+++ b/media-gfx/bootsplash/bootsplash-0.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/bootsplash-0.2.ebuild,v 1.1 2003/01/16 04:02:41 tad Exp $
+
+DESCRIPTION="Graphical backgrounds for frame buffer consoles"
+
+HOMEPAGE="http://linux.tkdack.com"
+
+SRC_URI="http://gentoo.tkdack.com/downloads/gentoo/bootsplash-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+
+RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+#src_unpack() {
+#
+#}
+
+src_compile() {
+ # compile splashutil
+ cd ${S}/splashutil
+ make || die
+ # compile bootsplash-config maker
+ cd ${S}/bootsplash-config
+ make || die
+ # create config files for different resolutions
+ sh bootsplash-config.sh
+}
+
+src_install() {
+
+ exeinto /usr/bin
+ doexe ${S}/splashutil/splash
+ doexe ${S}/bootsplash-config/bootsplash-config
+
+ insinto /usr/share/${P}
+ doins ${S}/bootsplash-config/*.cfg
+# doins ${S}/bootsplash-config/bootsplash-1280x1024.cfg
+# doins ${S}/bootsplash-config/bootsplash-800x600.cfg
+# doins ${S}/bootsplash-config/bootsplash.cfg
+ doins ${S}/*.jpg
+
+ # link default config
+ dosym ./gentoo-boot-1280x1024.jpg /usr/share/${P}/bootsplash.jpg
+ dosym ./gentoo-boot-1280x1024.cfg /usr/share/${P}/bootsplash.cfg
+
+ doins ${S}/boot_splash_complete.2.4.19-vanilla.patch
+ doins ${S}/grub.conf.sample
+
+ insinto /etc/conf.d
+ doins ${S}/local.start
+ doins ${S}/local.stop
+
+ dodoc README
+ dodoc COPYING
+
+ # generate initial initrd file
+ ${S}/splashutil/splash -s -f ${D}/usr/share/${P}/bootsplash.cfg > ${D}/usr/share/${P}/initrd
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your kernel sources in /usr/src/linux patched with the"
+ einfo "Framebuffer Bootsplash patches"
+ einfo
+ echo ""
+ ewarn "If you have already patched the kernel then you only need to copy"
+ ewarn "the initrd from /usr/share/${P}/initrd to /boot"
+ ewarn
+ echo ""
+ einfo
+ einfo "Please \"merge\" any changed files in /etc/conf.d"
+ einfo
+}
+
+pkg_config() {
+ ewarn
+ ewarn "Patching the kernel in /usr/src/linux ..."
+ ewarn
+ cd ${ROOT}/usr/src/linux
+ cat ${ROOT}/usr/share/${P}/boot_splash_complete.2.4.19-vanilla.patch | patch -p1 || die
+ ewarn
+ ewarn " ... complete."
+ einfo
+ einfo "Your kernel has been patched, rebuild with the following options"
+ einfo "enabled (do not build them as modules!):"
+ einfo " Block Devices ->"
+ einfo " [*] RAM disk support"
+ einfo " [*] Loopback device support"
+ einfo " [*] Initial RAM disk (initrd) support"
+ einfo
+ einfo " Console Drivers ->"
+ einfo " [*] Video mode selection support"
+ einfo " Frame-buffer support ->"
+ einfo " [*] Support for frame buffer devices"
+ einfo " [*] VESA VGA graphics console"
+ einfo " [*] Use splash screen instead of boot logo"
+ einfo
+ einfo "Copy /usr/share/${P}/initrd to /boot"
+ einfo
+ einfo "Look at \"/usr/share/${P}/grub.conf.sample\" for an example"
+ einfo "grub.conf file with the appropriate changes to enable the"
+ einfo "framebuffer boot screens"
+ einfo
+ einfo "Ensure you make the appropriate changes to your grub.conf"
+ einfo
+}
+
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.2 b/media-gfx/bootsplash/files/digest-bootsplash-0.2
new file mode 100644
index 000000000000..cd3e43358672
--- /dev/null
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.2
@@ -0,0 +1 @@
+MD5 7c0e7e4e9375b86e400ff0671c8e043d bootsplash-0.2.tar.bz2 220475